summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-11-21 08:41:25 +0100
committerAntonio Rojas2022-11-21 08:41:25 +0100
commit4b0ef0803fdb2bf1ee077b73fda52944d14bee77 (patch)
treea69ac4823c49bfea0942533a3b7441c4fa202dbc
parenta2d26ba73f64321368003df55d68970b164b5986 (diff)
downloadaur-4b0ef0803fdb2bf1ee077b73fda52944d14bee77.tar.gz
import from community
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--install-appdata.patch32
3 files changed, 60 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58d4eb0a56d6..20bbb912eb58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
-# Generated by mksrcinfo v8
-# Mon Apr 16 20:48:11 UTC 2018
pkgbase = quiterss
pkgdesc = Fast and light RSS/Atom feed reader written in Qt/С++
- pkgver = 0.18.10
- pkgrel = 1
- url = https://quiterss.org
- arch = i686
+ pkgver = 0.19.4
+ pkgrel = 2
+ url = https://quiterss.org/
arch = x86_64
license = GPL3
makedepends = qt5-tools
- depends = desktop-file-utils
depends = gst-plugins-good
- depends = gtk-update-icon-cache
depends = qt5-multimedia
depends = qt5-webkit
- source = https://github.com/QuiteRSS/quiterss/archive/0.18.10.tar.gz
- sha512sums = 74a493a93378f9f3bfb3b476cf80df1f4e565ce2f89116ee898a45a4941aa5de557a6ab80e284298fefa4d832bfca58bf7163bbdef467c4fea7091001fac1fa4
+ source = https://github.com/QuiteRSS/quiterss/archive/0.19.4/quiterss-0.19.4.tar.gz
+ source = install-appdata.patch
+ sha256sums = d9dffa205a8ec4e7bf00d87183fd94d4a12f045fae04a6efd41d6557827233bc
+ sha256sums = 81cc287b8fbd53016a125f210c193c58bcac093cc86ee226c5f4fd23b26188c9
pkgname = quiterss
-
diff --git a/PKGBUILD b/PKGBUILD
index 258539a7211a..865dedd87607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
-# Maintainer: willemw <willemw12@gmail.com>
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: willemw <willemw12@gmail.com>
# Contributor: ThecaTTony <thecattony at gmx dot com>
# Contributor: <giacomogiorgianni at gmail dot com>
-_pkgname=QuiteRSS
pkgname=quiterss
-pkgver=0.18.10
-pkgrel=1
-pkgdesc="Fast and light RSS/Atom feed reader written in Qt/С++"
-arch=('i686' 'x86_64')
-url="https://quiterss.org"
+pkgver=0.19.4
+pkgrel=2
+pkgdesc='Fast and light RSS/Atom feed reader written in Qt/С++'
+arch=('x86_64')
+url='https://quiterss.org/'
license=('GPL3')
-depends=('desktop-file-utils' 'gst-plugins-good' 'gtk-update-icon-cache' 'qt5-multimedia' 'qt5-webkit')
+depends=('gst-plugins-good' 'qt5-multimedia' 'qt5-webkit')
makedepends=('qt5-tools')
-source=(https://github.com/$_pkgname/$pkgname/archive/$pkgver.tar.gz)
-sha512sums=('74a493a93378f9f3bfb3b476cf80df1f4e565ce2f89116ee898a45a4941aa5de557a6ab80e284298fefa4d832bfca58bf7163bbdef467c4fea7091001fac1fa4')
+source=("https://github.com/QuiteRSS/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ 'install-appdata.patch')
+sha256sums=('d9dffa205a8ec4e7bf00d87183fd94d4a12f045fae04a6efd41d6557827233bc'
+ '81cc287b8fbd53016a125f210c193c58bcac093cc86ee226c5f4fd23b26188c9')
-build() {
+prepare() {
cd $pkgname-$pkgver
- rm -rf _build
- mkdir _build
+ patch -Np1 -i ../install-appdata.patch
+ sed -i '/INSTALLS +=/ s/ target1//' QuiteRSS.pro
+}
- cd _build
- qmake-qt5 CONFIG+=release PREFIX=/usr ../QuiteRSS.pro \
- DISABLE_PHONON=1
+build() {
+ cd $pkgname-$pkgver
+ qmake-qt5 CONFIG+=release PREFIX=/usr
make
}
package() {
- cd $pkgname-$pkgver/_build
- make INSTALL_ROOT="$pkgdir/" install
+ cd $pkgname-$pkgver
+ make INSTALL_ROOT="$pkgdir" install
}
-
diff --git a/install-appdata.patch b/install-appdata.patch
new file mode 100644
index 000000000000..3f784f7f0fb3
--- /dev/null
+++ b/install-appdata.patch
@@ -0,0 +1,32 @@
+From ea8b4dce33fd5a74012d14d92bef43e26c6dda66 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
+Date: Sat, 17 Apr 2021 21:00:32 +0200
+Subject: [PATCH] Install appdata file
+
+---
+ QuiteRSS.pro | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/QuiteRSS.pro b/QuiteRSS.pro
+index d5088fdf..22dceac5 100644
+--- a/QuiteRSS.pro
++++ b/QuiteRSS.pro
+@@ -287,6 +287,9 @@ unix:!mac {
+
+ desktop.files = quiterss.desktop
+ desktop.path = $$quote($$PREFIX/share/applications)
++
++ appdata.files = quiterss.appdata.xml
++ appdata.path = $$quote($$PREFIX/share/metainfo)
+
+ target1.files = images/48x48/quiterss.png
+ target1.path = $$quote($$PREFIX/share/pixmaps)
+@@ -314,7 +317,7 @@ unix:!mac {
+ style.files = style
+ style.path = $$quote($$DATA_DIR)
+
+- INSTALLS += target desktop target1
++ INSTALLS += target desktop appdata target1
+ INSTALLS += icon_16 icon_32 icon_48 icon_64 icon_128 icon_256
+ INSTALLS += translations sound style
+ }