summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEndlessEden2021-08-21 14:13:43 +1000
committerEndlessEden2021-08-21 14:13:43 +1000
commit4b208882bf55ef9028ae7665aebf9f1816801ac6 (patch)
treee5fd86360af679ff9cb8979c0f43f096a448a420
parent21e2f46e59716ceafa3a09b518e4479571752942 (diff)
downloadaur-4b208882bf55ef9028ae7665aebf9f1816801ac6.tar.gz
Updated: added missing depends, cleaned up slightly. Will improve more at a later date.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b8bf7fba627..612258debcdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,20 @@ pkgbase = python-pocketsphinx-git
pkgver = r185.769492d
pkgrel = 2
url = https://github.com/bambocher/pocketsphinx-python
+ arch = i386
arch = i686
+ arch = pentium4
+ arch = core2
arch = x86_64
license = BSD
makedepends = git
makedepends = python
makedepends = python2
+ makedepends = bison
depends = python
depends = swig
+ depends = python-setuptools
+ depends = python2-setuptools
source = python-pocketsphinx::git+https://github.com/bambocher/pocketsphinx-python.git
source = pocketsphinx::git+https://github.com/cmusphinx/pocketsphinx.git
source = sphinxbase::git+https://github.com/cmusphinx/sphinxbase.git
@@ -30,4 +36,3 @@ pkgname = pocketsphinx-git
depends = sphinxbase
provides = pocketsphinx
conflicts = procketsphinx
-
diff --git a/PKGBUILD b/PKGBUILD
index 50b2d79f46aa..9c89100b54f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ pkgname=('python-pocketsphinx-git' 'python2-pocketsphinx-git' 'sphinxbase-git' '
pkgver=r185.769492d
pkgrel=2
pkgdesc='Python interface to CMU SphinxBase and PocketSphinx libraries'
-arch=('i686' 'x86_64')
+arch=('i386' 'i686' 'pentium4' 'core2' 'x86_64')
url='https://github.com/bambocher/pocketsphinx-python'
license=('BSD')
-depends=('python' 'swig')
-makedepends=('git' 'python' 'python2')
+depends=('python' 'swig' 'python-setuptools' 'python2-setuptools')
+makedepends=('git' 'python' 'python2' 'bison')
# The Python bindings to pocketsphinx are made by bambocher. Dependencies are
# stored as git submodules and are maintained by the CMU Sphinx project.
source=(
@@ -33,7 +33,7 @@ prepare() {
git submodule init
git config submodule.deps/pocketsphinx.url ${srcdir}/pocketsphinx
git config submodule.deps/sphinxbase.url ${srcdir}/sphinxbase
- git submodule update
+ git submodule update --remote
# We want a python2 package as well. Let's copy the sources.
cd "${srcdir}"