summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2019-06-23 07:27:16 +1000
committerRod Kay2019-06-23 07:27:16 +1000
commit4b2151ac8ce8cf66c35e802029a5b08ced371655 (patch)
tree2d1d9b1cd0767f123891f1aa18f2291ab24fb43d
parent978be9f43b6b58729d97888015f4eed1babc85d4 (diff)
downloadaur-4b2151ac8ce8cf66c35e802029a5b08ced371655.tar.gz
Update to 2019
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--ali.adb-patch26
3 files changed, 48 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0cc05c2451d..f5a0a0f643cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = gnat_util
pkgdesc = Internal GNAT compiler components used by (at least) ASIS.
- pkgver = 2018
+ pkgver = 2019
pkgrel = 1
url = https://libre.adacore.com/
arch = i686
arch = x86_64
license = GPL V3.0 without any Runtime Exception
- makedepends = gprbuild>=2018
- depends = gcc-ada>=8.2.1
- depends = gcc-ada<9.0.0
- source = http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a6b
- sha1sums = 462a1304d1ed1ee5a37bfc6e956fa8b07896b715
+ makedepends = gprbuild
+ depends = gcc-ada
+ source = http://mirrors.cdn.adacore.com/art/5cdf8e5031e87a8f1d425090
+ source = ali.adb-patch
+ sha1sums = ccd37abcc9fbbe89b782dbe789b77278cb1d3789
+ sha1sums = 2a29832fec08f4f94ddf79b61ed7d40a87a3f8ed
pkgname = gnat_util
diff --git a/PKGBUILD b/PKGBUILD
index 90b6612bfac7..341680b98dc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Pierre-Marie de Rodat <pmderodat@kawie.fr>
pkgname=gnat_util
-pkgver=2018
+pkgver=2019
pkgrel=1
pkgdesc="Internal GNAT compiler components used by (at least) ASIS."
@@ -10,13 +10,22 @@ arch=('i686' 'x86_64')
url="https://libre.adacore.com/"
license=('GPL V3.0 without any Runtime Exception')
-depends=('gcc-ada>=8.2.1' 'gcc-ada<9.0.0')
-makedepends=('gprbuild>=2018')
+depends=('gcc-ada')
+makedepends=('gprbuild')
-source=('http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a6b')
-sha1sums=('462a1304d1ed1ee5a37bfc6e956fa8b07896b715')
+source=('http://mirrors.cdn.adacore.com/art/5cdf8e5031e87a8f1d425090'
+ 'ali.adb-patch')
+sha1sums=('ccd37abcc9fbbe89b782dbe789b77278cb1d3789'
+ '2a29832fec08f4f94ddf79b61ed7d40a87a3f8ed')
-_pkg_src_dir="$pkgname-gpl-$pkgver-src"
+_pkg_src_dir="gnat_util-2019-20190517-194CA-src"
+
+
+prepare()
+{
+ cd "$srcdir/$_pkg_src_dir"
+ patch -Np0 -i "$srcdir/ali.adb-patch"
+}
build()
diff --git a/ali.adb-patch b/ali.adb-patch
new file mode 100644
index 000000000000..2e3c983ae644
--- /dev/null
+++ b/ali.adb-patch
@@ -0,0 +1,26 @@
+--- ali.adb-orig 2019-06-23 05:38:00.742172886 +1000
++++ ali.adb 2019-06-23 05:38:23.382873117 +1000
+@@ -161,7 +161,7 @@
+ (IS_Rec : Invocation_Signature_Record) return Bucket_Range_Type;
+ -- Obtain the hash of key IS_Rec
+
+- package Sig_Map is new Dynamic_Hash_Tables
++ package Sig_Map is new Dynamic_HTable
+ (Key_Type => Invocation_Signature_Record,
+ Value_Type => Invocation_Signature_Id,
+ No_Value => No_Invocation_Signature,
+@@ -170,13 +170,12 @@
+ Compression_Threshold => 0.3,
+ Compression_Factor => 2,
+ "=" => "=",
+- Destroy_Value => Destroy,
+ Hash => Hash);
+
+ -- The following map relates invocation signature records to invocation
+ -- signature ids.
+
+- Sig_To_Sig_Map : constant Sig_Map.Dynamic_Hash_Table :=
++ Sig_To_Sig_Map : constant Sig_Map.Instance :=
+ Sig_Map.Create (500);
+
+ -- The folowing table maps declaration placement kinds to character codes