summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2022-06-06 10:35:18 +0100
committerGreyson Christoforo2022-06-06 10:35:18 +0100
commit4b22355a546540575a2c51efe09ef93ed0095a01 (patch)
tree2ada54c9f91c17e3ef320e9179f9fbd15ae6522a
parenteb88fd0467c0460d47d4e7b4c697a6adfa4f04e2 (diff)
downloadaur-4b22355a546540575a2c51efe09ef93ed0095a01.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7740445a2fe1..c85796ff1b02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = python-cq_warehouse
pkgdesc = A cadquery parametric part collection
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/gumyr/cq_warehouse
arch = x86_64
license = Apache
+ makedepends = python-build
+ makedepends = python-installer
depends = python-cadquery
- source = python-cq_warehouse-0.6.0.tar.gz::https://github.com/gumyr/cq_warehouse/archive/refs/tags/v0.6.0.tar.gz
- sha256sums = 3f928eebde439b3c7c161059bb8a8442cf243c4f401916e4bda6ec97099768dc
+ source = python-cq_warehouse-0.7.0.tar.gz::https://github.com/gumyr/cq_warehouse/archive/refs/tags/v0.7.0.tar.gz
+ sha256sums = 6c2783f7a948e7e2743d57b487568e733cd6f5b477565def31bed7bbb44b33b6
pkgname = python-cq_warehouse
diff --git a/PKGBUILD b/PKGBUILD
index b229be6029a4..dfa4ffe95b5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-cq_warehouse
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="A cadquery parametric part collection"
arch=(x86_64)
@@ -11,12 +11,18 @@ license=('Apache')
depends=(
python-cadquery
)
+makedepends=(
+python-build
+python-installer
+)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gumyr/cq_warehouse/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('3f928eebde439b3c7c161059bb8a8442cf243c4f401916e4bda6ec97099768dc')
+sha256sums=('6c2783f7a948e7e2743d57b487568e733cd6f5b477565def31bed7bbb44b33b6')
prepare() {
cd cq_warehouse-${pkgver}
+ rm -rf dist
+ #curl --silent https://patch-diff.githubusercontent.com/raw/gumyr/cq_warehouse/pull/37.patch | patch -p1
}
build() {
@@ -31,7 +37,6 @@ check() {
package() {
cd cq_warehouse-${pkgver}
- # python -m installer --destdir="${pkgdir}" dist/*.whl
- python -m installer --destdir="${pkgdir}" dist/cq_warehouse-${pkgver}*.whl
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}