summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author007exe2021-12-09 19:51:20 +0300
committer007exe2021-12-09 19:51:20 +0300
commit4b5e67a972339dcaec19458be001d3a79205937f (patch)
tree29bbfc2f88986a156b02eaab0dbe8a4dfc095b51
parent413450b2858b7a7b6c315fb43039fe6257125166 (diff)
downloadaur-4b5e67a972339dcaec19458be001d3a79205937f.tar.gz
Update => 1144-december-2021-rc1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD38
-rw-r--r--info.install26
3 files changed, 41 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2e03a96a701..a0ce8bc86210 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openxray-git
pkgdesc = Unofficial X-Ray Engine port for Linux from the OpenXRay team (originally developed by GSC Game World)
- pkgver = 1.6.02_822
+ pkgver = 1.6.02_1144
pkgrel = 1
url = https://github.com/OpenXRay/xray-16
install = info.install
@@ -32,4 +32,3 @@ pkgbase = openxray-git
md5sums = SKIP
pkgname = openxray-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 667f018bf1b0..0fda45c155d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,41 @@
# https://aur.archlinux.org/packages/openxray-git/
# <openxray@yahoo.com>
pkgname=openxray-git
-pkgver=1.6.02_822
+pkgver=1.6.02_1144
pkgrel=1
-pkgdesc="Unofficial X-Ray Engine port for Linux from the OpenXRay team (originally developed by GSC Game World)"
-arch=('x86_64')
+pkgdesc="Unofficial X-Ray Engine port for Linux from the OpenXRay team (originally developed by GSC Game World)"
+arch=('x86_64')
url="https://github.com/OpenXRay/xray-16"
license=('custom:Custom 3-сlause BSD')
install="info.install"
makedepends=(gcc git cmake libglvnd libjpeg6-turbo ncurses pcre2 pcre)
-depends=(glew sdl2 openal crypto++ liblockfile freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo)
+depends=(glew sdl2 openal crypto++ liblockfile freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo)
conflicts=(openxray openxray-dev)
source=(xray-16::git+https://github.com/OpenXRay/xray-16.git#branch=dev)
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/xray-16"
- printf 1.6.02_822_"$(git rev-parse --short HEAD)"
+ cd "$srcdir/xray-16"
+ printf 1.6.02_1144_"$(git rev-parse --short HEAD)"
}
prepare(){
-cd "$srcdir/xray-16"
-git submodule init
-git submodule update
+ cd "$srcdir/xray-16"
+ git submodule init
+ git submodule update
}
build() {
- cd "$srcdir/xray-16"
- rm -fr bin
- mkdir "$srcdir/xray-16/bin"
- cd "$srcdir/xray-16/bin"
- cmake .. -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- # -DCMAKE_BUILD_TYPE=Debug
- # -DMEMORY_ALLOCATOR=standard
- make
+ cd "$srcdir/xray-16"
+ rm -fr bin
+ mkdir "$srcdir/xray-16/bin"
+ cd "$srcdir/xray-16/bin"
+ cmake .. -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+# -DCMAKE_BUILD_TYPE=Debug
+# -DMEMORY_ALLOCATOR=standard
+ make
}
package() {
diff --git a/info.install b/info.install
index d958c6712230..0eab2cad0766 100644
--- a/info.install
+++ b/info.install
@@ -1,19 +1,35 @@
post_install() {
cat << EOF
+===========================================================================
-The OpenXRay project continues the unofficial support and development of the X-Ray 1.6.02 game engine. The original engine is used in the game S.T.A.L.K.E.R.: Call of Pripyat, released by GSC Game World.
+The OpenXRay project continues the unofficial support and development of the X-Ray 1.6.02 game engine. The original engine is used in the
+S.T.A.L.K.E.R.: Call of Pripyat game released by GSC Game World.
-Attention!!! Keep in mind that this GSC Game World project is in no way authorized, and they remain the copyright holders of all source code.
+Attention!!! Keep in mind that this GSC Game World project is in no way authorized, and they remain the copyright holders of the entire source code.
-This package does not provide game resources, to start the game you will need the original game resources of a licensed copy of S.T.A.L.K.E.R.: Call of Pripyat version 1.6.02 and S.T.A.L.K.E.R.: Clear Sky
+This package does not provide game resources, to start the game you will need the original game resources of a licensed copy of
+S.T.A.L.K.E.R.: Call of Pripyat version 1.6.02 and S.T.A.L.K.E.R.: Clear Sky 1.5.10
-From the original licensed version of the game, copy the following directories, localization, mp, patches and resources to ~/.local/share/GSC Game World/S.T.A.L.K.E.R. - Call of Pripyat for S.T.A.L.K.E.R.: Call of Pripyat and ~/.local/share/GSC Game World/S.T.A.L.K.E.R. - Clear Sky for S.T.A.L.K.E.R.: Clear Sky respectively. You can use resources from Steam or physical DVD media, GOG to unpack the distribution of the game, you can use the innoextract program.
+From the original licensed version of the game, copy the following directories, levels, localization, mp, patches and resources to
+~/.local/share/GSC Game World/S.T.A.L.K.E.R. - Call of Pripyat for S.T.A.L.K.E.R.: Call of Pripyat and
+~/.local/share/GSC Game World/S.T.A.L.K.E.R. - Clear Sky for S.T.A.L.K.E.R.: - Clear Sky respectively.
+You can use the resources of Steam or a physical DVD-media, GOG to unpack the distribution of the game, you can use the innoextract program.
Attention!!! All directory and file names inside directories must be lowercase.
+When using a copy from GOG, you may have problems localizing the game to solve it, go to the ~/.local/share/GSC Game World/S.T.A.L.K.E.R..../localization directory
+and delete all directories and files related to third-party translations in the localization directory there should be a db archive with your
+localization for example xrussian.db some translations may contain separate archives with voice acting for characters and video clips for
+example base_sounds.db and xefis_movies.db
+
+Despite the fact that in the Ira section you will see the item S.T.A.L.K.E.R.:Shadow of Chernobyl (OpenXRay) to launch this part of the trilogy at the
+moment it is not possible it is at an early stage of development
+
+===========================================================================
+
EOF
-
+
}