summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Buchacher2015-06-10 10:31:12 +0200
committerClemens Buchacher2015-06-10 10:35:09 +0200
commit4b5e795f05a797a56ed81d5e98e55f9309b5a126 (patch)
tree5234df731a635be748b83b854acbc8b258119e88
downloadaur-4b5e795f05a797a56ed81d5e98e55f9309b5a126.tar.gz
image 2.2.2-2
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD56
-rw-r--r--octave-image.install13
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de3412567925
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = octave-image
+ pkgdesc = The Octave-forge Image package provides functions for processing images. The package also provides functions for feature extraction, image statistics, spatial and geometric transformations, morphological operations, linear filtering, and much more.
+ pkgver = 2.2.2
+ pkgrel = 2
+ url = http://octave.sourceforge.net/image/
+ install = octave-image.install
+ arch = any
+ groups = octave-forge
+ license = custom
+ depends = octave>=3.8.0
+ depends = octave-signal>=1.2.0
+ depends = octave-general>=1.3.0
+ noextract = image-2.2.2.tar.gz
+ source = http://downloads.sourceforge.net/octave/image-2.2.2.tar.gz
+ md5sums = c02a05ba37ffb38ad2b59906a56c7807
+
+pkgname = octave-image
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef46e7bf4e8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b438684e9586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+#
+# Contributor: Philipp Brüschweiler <blei42 gmail com>
+# Contributor: Ng Oon-Ee <ngoonee.talk@gmail.com>
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=image
+pkgname=octave-$_pack
+pkgver=2.2.2
+pkgrel=2
+pkgdesc="The Octave-forge Image package provides functions for processing images. The package also provides functions for feature extraction, image statistics, spatial and geometric transformations, morphological operations, linear filtering, and much more."
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('custom')
+groups=('octave-forge')
+depends=('octave>=3.8.0' 'octave-signal>=1.2.0' 'octave-general>=1.3.0')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('c02a05ba37ffb38ad2b59906a56c7807')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-image.install b/octave-image.install
new file mode 100644
index 000000000000..7c9ea5667f44
--- /dev/null
+++ b/octave-image.install
@@ -0,0 +1,13 @@
+_pack=image
+
+post_install() {
+ octave -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave -q -f --eval "pkg rebuild -global"
+}