summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2021-08-18 02:07:24 +0100
committergrufo2021-08-18 02:07:24 +0100
commit4b752c0812e341d8a9bed910e8515e7cd300ea39 (patch)
tree09847f25cc977938337e8f103caa10668d6c90ab
parent028b475d127d48649fb25fdfd2a0c4054a5b4211 (diff)
downloadaur-4b752c0812e341d8a9bed910e8515e7cd300ea39.tar.gz
New release (0.15.0-1)
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD91
-rw-r--r--gnunet.service4
-rw-r--r--gnunet.sysusers3
-rw-r--r--gnunet.tmpfiles1
-rw-r--r--gnunetd.conf (renamed from defaults.conf)0
6 files changed, 93 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d5f5db67e7f..51590c7a700c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,54 @@
pkgbase = gnunet
pkgdesc = A framework for secure peer-to-peer networking
- pkgver = 0.14.1
+ pkgver = 0.15.0
pkgrel = 1
- url = https://gnunet.org
+ url = http://gnunet.org
+ arch = i686
arch = x86_64
license = GPL
- makedepends = git
+ makedepends = gettext
+ makedepends = pkgconfig
+ makedepends = autoconf
+ makedepends = gst-plugins-base-libs
makedepends = bluez-libs
makedepends = python
makedepends = glpk
makedepends = libpulse
+ makedepends = git
makedepends = opus
- makedepends = gst-plugins-base-libs
+ depends = gmp
+ depends = libgcrypt
depends = libextractor
depends = sqlite
depends = gnurl
+ depends = libsodium
depends = libmicrohttpd
+ depends = libunistring
depends = libidn
depends = jansson
- depends = libsodium
- optdepends = bluez-libs
+ depends = zbar
optdepends = python
optdepends = glpk
optdepends = libpulse
optdepends = opus
optdepends = gst-plugins-base-libs: for gnunet-helper-audio-record
+ conflicts = gnunet-git
+ conflicts = gnunet-bin
options = !makeflags
backup = etc/gnunetd.conf
- source = http://ftpmirror.gnu.org/gnunet/gnunet-0.14.1.tar.gz
- source = http://ftpmirror.gnu.org/gnunet/gnunet-0.14.1.tar.gz.sig
+ source = http://ftpmirror.gnu.org/gnunet/gnunet-0.15.0.tar.gz
+ source = http://ftpmirror.gnu.org/gnunet/gnunet-0.15.0.tar.gz.sig
source = gnunet.service
- source = defaults.conf
+ source = gnunet.sysusers
+ source = gnunet.tmpfiles
+ source = gnunetd.conf
validpgpkeys = 19647543F7861D3BF4E64FF7BF60708B48426C7E
validpgpkeys = 3D11063C10F98D14BD24D1470B0998EF86F59B6A
- sha256sums = 4a3205c570c30756f1a8b1ad0f1a63d078a92f0fac8e543471d54f4552da18c2
+ sha256sums = cca23d6fb40890a5eb2ccae4b8f7e74c8e4e84d3fca2f419d775cb4a58dd9a67
sha256sums = SKIP
- sha256sums = 42a91cd5c291227a2b452f4131808d2393887991ec905159bc470e68548098ba
+ sha256sums = 2fb156b5bda51ef7c0659ca19113e7c8cd651637ffb379264e2b61f65be367d1
+ sha256sums = 65daa9fb07bdc8b8a11ca06f320b94ce6cfcc9681c6693ac655ca54881645a39
+ sha256sums = 4832e45c02ad768a713ca7f2a04b58794e268a49130b5b8ab6b91917e3d4f945
sha256sums = 582c617cfcb0b28e28c8ab42925307f79cf147f3231a9782c46893383c31b19e
pkgname = gnunet
-
diff --git a/PKGBUILD b/PKGBUILD
index a851c2c40235..1cef5905024e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,80 @@
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: wahnby <wahnby@yahoo.fr>
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+# Contributor: redfish <redfish AT galactica DOT pw>
+# Contributor: kertase <kertase AT gmail DOT com>
+# Contributor: Sergej Pupykin <pupykin DOT s+arch AT gmail.com>
+# Contributor: wahnby <wahnby AT yahoo DOT fr>
-pkgname=gnunet
-pkgver=0.14.1
+pkgname='gnunet'
+pkgver='0.15.0'
pkgrel=1
-pkgdesc="A framework for secure peer-to-peer networking"
-arch=('x86_64')
-url="https://gnunet.org"
+pkgdesc='A framework for secure peer-to-peer networking'
+arch=('i686' 'x86_64')
+url="http://${pkgname}.org"
license=('GPL')
-depends=('libextractor' 'sqlite' 'gnurl' 'libmicrohttpd' 'libidn' 'jansson' 'libsodium')
-makedepends=('git' 'bluez-libs' 'python' 'glpk' 'libpulse' 'opus' 'gst-plugins-base-libs')
-optdepends=('bluez-libs'
- 'python'
+conflicts=("${pkgname}-git" "${pkgname}-bin")
+depends=('gmp' 'libgcrypt' 'libextractor' 'sqlite' 'gnurl' 'libsodium'
+ 'libmicrohttpd' 'libunistring' 'libidn' 'jansson' 'zbar')
+makedepends=('gettext' 'pkgconfig' 'autoconf' 'gst-plugins-base-libs'
+ 'bluez-libs' 'python' 'glpk' 'libpulse' 'git' 'opus')
+optdepends=('python'
'glpk'
'libpulse'
'opus'
'gst-plugins-base-libs: for gnunet-helper-audio-record')
-backup=(etc/gnunetd.conf)
+backup=('etc/gnunetd.conf')
options=('!makeflags')
-source=(http://ftpmirror.gnu.org/gnunet/gnunet-0.14.1.tar.gz{,.sig}
- gnunet.service
- defaults.conf)
+source=("http://ftpmirror.gnu.org/gnunet/${pkgname}-${pkgver}.tar.gz"{,.sig}
+ "${pkgname}.service"
+ "${pkgname}.sysusers"
+ "${pkgname}.tmpfiles"
+ 'gnunetd.conf')
validpgpkeys=('19647543F7861D3BF4E64FF7BF60708B48426C7E'
'3D11063C10F98D14BD24D1470B0998EF86F59B6A')
-sha256sums=('4a3205c570c30756f1a8b1ad0f1a63d078a92f0fac8e543471d54f4552da18c2'
+sha256sums=('cca23d6fb40890a5eb2ccae4b8f7e74c8e4e84d3fca2f419d775cb4a58dd9a67'
'SKIP'
- '42a91cd5c291227a2b452f4131808d2393887991ec905159bc470e68548098ba'
+ '2fb156b5bda51ef7c0659ca19113e7c8cd651637ffb379264e2b61f65be367d1'
+ '65daa9fb07bdc8b8a11ca06f320b94ce6cfcc9681c6693ac655ca54881645a39'
+ '4832e45c02ad768a713ca7f2a04b58794e268a49130b5b8ab6b91917e3d4f945'
'582c617cfcb0b28e28c8ab42925307f79cf147f3231a9782c46893383c31b19e')
+prepare() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i 's|contrib doc|doc|' Makefile.*
+
+}
+
build() {
- cd $pkgname-$pkgver
- sed -i 's|contrib doc|doc|' Makefile.*
- ./configure --prefix=/usr \
- --without-mysql
- make
- make -C contrib
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ test -f Makefile || ./configure --prefix=/usr --without-mysql
+ make
+ make -C contrib
+
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" -C contrib install
- install -D -m0644 "$srcdir"/defaults.conf "$pkgdir"/etc/gnunetd.conf
- rm -rf "$pkgdir"/usr/include/libltdl "$pkgdir"/usr/lib/libltdl.* "$pkgdir"/usr/include/ltdl.h
- install -Dm0644 "$srcdir"/$pkgname.service "$pkgdir"/usr/lib/systemd/system/$pkgname.service
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" -C contrib install
+
+ # rm -rf "${pkgdir}/usr/include/libltdl" "${pkgdir}"/usr/lib/libltdl.* "${pkgdir}/usr/include/ltdl.h"
+
+ install -dm755 "${pkgdir}/etc"
+ install -Dm644 "${srcdir}/gnunetd.conf" "${pkgdir}/etc/gnunetd.conf"
+
+ install -dm755 "${pkgdir}/usr/lib/systemd/system"
+ install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+
+ install -dm755 "${pkgdir}/usr/lib/sysusers.d"
+ install -Dm644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+
+ install -dm755 "${pkgdir}/usr/lib/tmpfiles.d"
+ install -Dm644 "${srcdir}/${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+
}
+
diff --git a/gnunet.service b/gnunet.service
index 5625978a5e50..f4bf3a2d326e 100644
--- a/gnunet.service
+++ b/gnunet.service
@@ -2,9 +2,11 @@
Description=A framework for secure peer-to-peer networking
[Service]
-User=nobody
+User=gnunet
Type=forking
ExecStart=/usr/bin/gnunet-arm -s -c /etc/gnunetd.conf
+ExecStop=/usr/bin/gnunet-arm -e -c /etc/gnunetd.conf
+GuessMainPID=no
[Install]
WantedBy=multi-user.target
diff --git a/gnunet.sysusers b/gnunet.sysusers
new file mode 100644
index 000000000000..718bcfac1eb8
--- /dev/null
+++ b/gnunet.sysusers
@@ -0,0 +1,3 @@
+g gnunet -
+u gnunet - "GNUnet" /var/lib/gnunet
+g gnunetdns -
diff --git a/gnunet.tmpfiles b/gnunet.tmpfiles
new file mode 100644
index 000000000000..981e940f256b
--- /dev/null
+++ b/gnunet.tmpfiles
@@ -0,0 +1 @@
+Z /var/lib/gnunet - gnunet gnunet - -
diff --git a/defaults.conf b/gnunetd.conf
index bb419343320d..bb419343320d 100644
--- a/defaults.conf
+++ b/gnunetd.conf