summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuckket2016-08-10 16:05:25 +0200
committerbuckket2016-08-10 16:05:25 +0200
commit4b83bf03c1f41db4206525bafef362c906b1c5e4 (patch)
tree9f86a95ff364b938d5f42200f6ca9410d876953d
downloadaur-4b83bf03c1f41db4206525bafef362c906b1c5e4.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rwxr-xr-xlibcirc8
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aea6350f5b06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 10 14:02:55 UTC 2016
+pkgbase = liberation-circuit
+ pkgdesc = A real-time strategy/programming game
+ pkgver = alpha2_1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/liberation-circuit/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = redo
+ depends = allegro
+ source = http://downloads.sourceforge.net/project/liberation-circuit/alpha_2/LibCirc_alpha2_1_src.zip
+ source = libcirc
+ sha256sums = 4a034d9fb079a21bc93b07b480beef293a13abcc7e4e22592f1ee467f025e7de
+ sha256sums = 2560ef7dd15ec609177b2330e075d6414421b4a4ed857873675cd748b511d54a
+
+pkgname = liberation-circuit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8e947ef401a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: buckket <buckket@cock.li>
+
+pkgname=liberation-circuit
+pkgver=alpha2_1
+pkgrel=1
+pkgdesc="A real-time strategy/programming game"
+arch=("x86_64" "i686")
+license=("GPL3")
+url="https://sourceforge.net/projects/liberation-circuit/"
+depends=("allegro")
+makedepends=("redo")
+source=("http://downloads.sourceforge.net/project/${pkgname}/alpha_2/LibCirc_${pkgver}_src.zip" "libcirc")
+sha256sums=('4a034d9fb079a21bc93b07b480beef293a13abcc7e4e22592f1ee467f025e7de'
+ '2560ef7dd15ec609177b2330e075d6414421b4a4ed857873675cd748b511d54a')
+
+build() {
+ cd LibCirc_src
+ redo
+}
+
+package() {
+ cd LibCirc_src
+ install -Dm755 ../libcirc "${pkgdir}/usr/bin/libcirc"
+ install -Dm755 src/g_game bin/libcirc
+ install -dm755 "${pkgdir}/usr/share/games/${pkgname}"
+ cp -rf bin/* "${pkgdir}/usr/share/games/${pkgname}"
+}
+
diff --git a/libcirc b/libcirc
new file mode 100755
index 000000000000..ee0d45bf37e1
--- /dev/null
+++ b/libcirc
@@ -0,0 +1,8 @@
+#!/usr/bin/sh
+
+# liberation-circuit start script
+# Currently there is no way to explicitly specify the asset folder location
+# so we have to switch the working directory before starting the game.
+
+cd /usr/share/games/liberation-circuit
+./libcirc