summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlf2018-11-07 04:41:21 +0000
committerlf2018-11-07 04:41:21 +0000
commit4bd44ab91178f8ecb348c8e38d795f888346f79a (patch)
tree8379ed1fb65ca3ab6b6f32f78d1e7a4cbb8eabe3
downloadaur-4bd44ab91178f8ecb348c8e38d795f888346f79a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--acme-dns.service18
-rw-r--r--sysusers.conf1
-rw-r--r--tmpfiles.conf1
6 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dececc6b2f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = acme-dns
+ pkgdesc = DNS server for ACME dns-01 challenges
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/joohoi/acme-dns
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = sysusers.conf
+ source = tmpfiles.conf
+ source = acme-dns.service
+ source = https://github.com/joohoi/acme-dns/archive/v0.6.tar.gz
+ sha256sums = edd9873e5d24736b9164467f7543dab42dc177d6c98b4ca6a572dfcbdd2202a4
+ sha256sums = e8a8b3ffda44a3c346925ba4de197f1b6f139bfe52b9f77e6cb3f87677d3ad98
+ sha256sums = 08dec87163a9cfc1b69c1762652b650d8714d8a0cc83f2d65b59adf43722dbbb
+ sha256sums = 0746055444873a248b2bf8459beacc0cfbed013a021695d2f3cc072492291946
+
+pkgname = acme-dns
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a52611a641d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..768c06b50d49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: lf <packages at lfcode dot ca>
+
+pkgname=acme-dns
+pkgver=0.6
+pkgrel=1
+pkgdesc="DNS server for ACME dns-01 challenges"
+arch=('x86_64')
+url="https://github.com/joohoi/acme-dns"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=('sysusers.conf' 'tmpfiles.conf' 'acme-dns.service' "https://github.com/joohoi/acme-dns/archive/v${pkgver}.tar.gz")
+sha256sums=('edd9873e5d24736b9164467f7543dab42dc177d6c98b4ca6a572dfcbdd2202a4'
+ 'e8a8b3ffda44a3c346925ba4de197f1b6f139bfe52b9f77e6cb3f87677d3ad98'
+ '08dec87163a9cfc1b69c1762652b650d8714d8a0cc83f2d65b59adf43722dbbb'
+ '0746055444873a248b2bf8459beacc0cfbed013a021695d2f3cc072492291946')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build -v
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 config.cfg "$pkgdir/etc/acme-dns/config.cfg"
+ install -Dm644 "$srcdir/acme-dns.service" "$pkgdir/usr/lib/systemd/system/acme-dns.service"
+ install -Dm644 "$srcdir/sysusers.conf" "$pkgdir/usr/lib/sysusers.d/acme-dns.conf"
+ install -Dm644 "$srcdir/tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/acme-dns.conf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/acme-dns.service b/acme-dns.service
new file mode 100644
index 000000000000..bb3e95c9c112
--- /dev/null
+++ b/acme-dns.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Limited DNS server with RESTful HTTP API to handle ACME DNS challenges easily and securely
+After=network.target
+
+[Service]
+User=acme-dns
+Group=acme-dns
+AmbientCapabilities=CAP_NET_BIND_SERVICE
+ExecStart=/usr/bin/acme-dns
+Restart=on-failure
+
+SystemCallArchitecture=native
+RestrictAddressFamilies=AF_INET AF_INET6
+SystemCallFilter=@system-service
+PrivateTmp=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sysusers.conf b/sysusers.conf
new file mode 100644
index 000000000000..6e5d73b91e3a
--- /dev/null
+++ b/sysusers.conf
@@ -0,0 +1 @@
+u acme-dns - "acme-dns service user" /nonexistent
diff --git a/tmpfiles.conf b/tmpfiles.conf
new file mode 100644
index 000000000000..bf42cd98fdb2
--- /dev/null
+++ b/tmpfiles.conf
@@ -0,0 +1 @@
+d /var/lib/acme-dns 0755 acme-dns acme-dns - -