summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-04-22 16:01:08 +0200
committerbartus2021-04-22 16:01:08 +0200
commit4bdea1ca916f651b127e8151f6aa7036f7091a67 (patch)
treecb44028a6f91b15893f9d95ea71f3d1befd9d83f
parent50ce9d669f601118fcb995f1d19440ffabfec044 (diff)
downloadaur-4bdea1ca916f651b127e8151f6aa7036f7091a67.tar.gz
Fix gcc10 build (missing headers)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--gcc10.patch13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 406c2655bd3b..920c1876dcbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = usd19
pkgdesc = 3D VFX pipeline interchange file format.
pkgver = 19.11
- pkgrel = 2
+ pkgrel = 3
url = https://www.openusd.org
arch = x86_64
license = Apache
@@ -25,9 +25,11 @@ pkgbase = usd19
source = git+https://github.com/PixarAnimationStudios/USD.git#tag=v19.11
source = boost_python2.patch
source = blender.patch
+ source = gcc10.patch
sha256sums = SKIP
sha256sums = dec16bd0270c9d682f34c555e38812ea010bee88907a02d6ce60f3f319b21425
sha256sums = a4b92e59eb6330109f65d1b168ad0c4b1292c5317f579dcbf0594df22ffbc587
+ sha256sums = c45a4503be17764a39f0be8e9524804c64c038b11fe2bf9c5627c88b5d523837
pkgname = usd19
diff --git a/PKGBUILD b/PKGBUILD
index e7be4a49f8ad..d32be40c8a9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ fi
pkgname=usd19
pkgver=${_ver#v}
-pkgrel=2
+pkgrel=3
pkgdesc="3D VFX pipeline interchange file format."
arch=('x86_64')
url="https://www.openusd.org"
@@ -29,13 +29,15 @@ makedepends+=('boost' 'cmake' 'git' 'intel-tbb' 'ninja')
provides=("usd=${pkgver}")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch"
- "blender.patch")
+ "blender.patch"
+ "gcc10.patch")
sha256sums=('SKIP'
'dec16bd0270c9d682f34c555e38812ea010bee88907a02d6ce60f3f319b21425'
- 'a4b92e59eb6330109f65d1b168ad0c4b1292c5317f579dcbf0594df22ffbc587')
+ 'a4b92e59eb6330109f65d1b168ad0c4b1292c5317f579dcbf0594df22ffbc587'
+ 'c45a4503be17764a39f0be8e9524804c64c038b11fe2bf9c5627c88b5d523837')
prepare() {
- git -C USD apply -v "${srcdir}"/{boost_python2,blender}.patch
+ git -C USD apply -v "${srcdir}"/{boost_python2,blender,gcc10}.patch
}
#pkgver() {
diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644
index 000000000000..90d98ce13eec
--- /dev/null
+++ b/gcc10.patch
@@ -0,0 +1,13 @@
+diff --git a/pxr/usd/lib/ar/packageUtils.cpp b/pxr/usd/lib/ar/packageUtils.cpp
+index d497587b3..ed3df295f 100644
+--- a/pxr/usd/lib/ar/packageUtils.cpp
++++ b/pxr/usd/lib/ar/packageUtils.cpp
+@@ -29,6 +29,8 @@
+ #include "pxr/base/tf/pathUtils.h"
+ #include "pxr/base/tf/stringUtils.h"
+
++#include <algorithm>
++
+ PXR_NAMESPACE_OPEN_SCOPE
+
+ namespace