summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoraj2023-09-16 20:43:43 +0200
committernoraj2023-09-16 20:43:43 +0200
commit4be5f844ecbc2dff97c6123351ca49debb19bb98 (patch)
tree98800cbebc5be545e64e1bfc642830342c0a26d9
parent58e7f3a3c6f5477fe72458b8343fd167a7f042f7 (diff)
downloadaur-4be5f844ecbc2dff97c6123351ca49debb19bb98.tar.gz
10.4.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xget_nessus_link.rb35
3 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68ed2e63227e..b955e169efcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nessus-agent
pkgdesc = Nessus vulnerability scanner agent
- pkgver = 10.4.0
+ pkgver = 10.4.2
pkgrel = 1
url = https://www.tenable.com/downloads/nessus-agents
install = nessus-agent.install
@@ -11,9 +11,9 @@ pkgbase = nessus-agent
conflicts = nessus
options = !strip
options = debug
- source = NessusAgent-10.4.0-fc34.x86_64.rpm::https://www.tenable.com/downloads/api/v1/public/pages/nessus-agents/downloads/19428/download?i_agree_to_tenable_license_agreement=true
+ source = NessusAgent-10.4.2-fc34.x86_64.rpm::https://www.tenable.com/downloads/api/v1/public/pages/nessus-agents/downloads/20517/download?i_agree_to_tenable_license_agreement=true
source = LICENSE
- b2sums = 60f795e2c1a1960a2384836160771da4d8a76f08da4365bcec4f51147f535bfee63b496c5ed3ee2c656c20c937d5021aeabac8a06239362205ab16a1bd6895a8
+ b2sums = 559b8b97d8849ff2d6bf50ba57e9498f7b848b996868c17e51fdf1f6395b306ceb5063ed8c09dfd942fac719ebabdcb9a1ff6e4d1558927f49880eee3c1658c8
b2sums = 2c68d4f30686a711fbf5c77b70d9b307f9fdcc8095cea79d8c310edfeea87563d94b9106fce35fc53685e6703afb729b9d81f504a1983c367621605690ea03e1
pkgname = nessus-agent
diff --git a/PKGBUILD b/PKGBUILD
index 1a2c414fd887..546f5e4ce459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=nessus-agent
_pkgname=nessus_agent
-pkgver=10.4.0
+pkgver=10.4.2
pkgrel=1
pkgdesc="Nessus vulnerability scanner agent"
arch=('x86_64')
@@ -13,9 +13,9 @@ license=('custom')
options=(!strip debug)
url="https://www.tenable.com/downloads/nessus-agents"
install="$pkgname.install"
-source=("NessusAgent-$pkgver-fc34.$arch.rpm::https://www.tenable.com/downloads/api/v1/public/pages/nessus-agents/downloads/19428/download?i_agree_to_tenable_license_agreement=true"
+source=("NessusAgent-$pkgver-fc34.$arch.rpm::https://www.tenable.com/downloads/api/v1/public/pages/nessus-agents/downloads/20517/download?i_agree_to_tenable_license_agreement=true"
LICENSE)
-b2sums=('60f795e2c1a1960a2384836160771da4d8a76f08da4365bcec4f51147f535bfee63b496c5ed3ee2c656c20c937d5021aeabac8a06239362205ab16a1bd6895a8'
+b2sums=('559b8b97d8849ff2d6bf50ba57e9498f7b848b996868c17e51fdf1f6395b306ceb5063ed8c09dfd942fac719ebabdcb9a1ff6e4d1558927f49880eee3c1658c8'
'2c68d4f30686a711fbf5c77b70d9b307f9fdcc8095cea79d8c310edfeea87563d94b9106fce35fc53685e6703afb729b9d81f504a1983c367621605690ea03e1')
conflicts=('nessus') # due to /etc/ld.so.conf.d/nessus.conf
diff --git a/get_nessus_link.rb b/get_nessus_link.rb
new file mode 100755
index 000000000000..2b0c5deed694
--- /dev/null
+++ b/get_nessus_link.rb
@@ -0,0 +1,35 @@
+#!/usr/bin/env ruby
+# frozen_string_literal: true
+
+# To install the prerequisites, use the command below:
+# pacman -S ruby-nokogiri
+
+require 'json'
+require 'nokogiri'
+require 'open-uri'
+
+def get_json
+ res = URI.open('https://www.tenable.com/downloads/nessus-agents')
+ doc = Nokogiri::HTML(res)
+ json = doc.at_css('#__NEXT_DATA__').content
+ JSON.parse(json)
+end
+
+def get_link
+ data = get_json
+ url, filename = nil
+ downloads = data['props']['pageProps']['page']['downloads']
+ downloads.each do |download|
+ filename = download['file']
+ if filename.end_with?('-fc34.x86_64.rpm')
+ url = "https://www.tenable.com/downloads/api/v1/public/pages/nessus-agents/downloads/#{download['id']}/download?i_agree_to_tenable_license_agreement=true"
+ break
+ end
+ end
+ raise 'Cannot find a download link!' if url.nil?
+
+ puts filename
+ puts url
+end
+
+get_link if __FILE__ == $PROGRAM_NAME