summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2022-11-21 22:03:20 +0100
committerAntoine Viallon2022-11-24 00:55:17 +0100
commit4bf2dc5277ea9615944ba572b8c3e70803504d73 (patch)
treea4cdf074debffb4c5cc1443dca63279a06755edb
parentb367a00f536d73684b911691e246776852e1f78d (diff)
downloadaur-4bf2dc5277ea9615944ba572b8c3e70803504d73.tar.gz
1.0.1
Signed-off-by: Peter Jung <admin@ptr1337.dev> Signed-off-by: Antoine Viallon <antoine@lesviallon.fr>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b336c338ba40..c62455bf2aa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ananicy-cpp
pkgdesc = Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage.
- pkgver = 1.0.0.rc7
+ pkgver = 1.0.1
pkgrel = 1
url = https://gitlab.com/ananicy-cpp/ananicy-cpp/
arch = x86_64
@@ -11,15 +11,22 @@ pkgbase = ananicy-cpp
arch = pentium4
license = GPLv3
makedepends = cmake
+ makedepends = clang
makedepends = git
+ makedepends = nlohmann-json
+ makedepends = bpf
depends = fmt
depends = spdlog
depends = nlohmann-json
depends = systemd
+ depends = libelf
+ depends = zlib
+ depends = libbpf
optdepends = ananicy-rules-git: community rules
- source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v1.0.0-rc7/ananicy-cpp-v1.0.0-rc7.tar.gz
- source = https://gitlab.com/ananicy-cpp/stl-polyfills/std-format/-/archive/45296602ad78a804411e7c3b617e13759f38e4e7/std-format-45296602ad78a804411e7c3b617e13759f38e4e7.tar.gz
- md5sums = fb921722da05102093ca86beb0998ee7
- md5sums = e3654b522fb829dcad2818ff7b8de8e9
+ optdepends = ananicy-rules: rules for ananicy-cpp
+ source = https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v1.0.1/ananicy-cpp-v1.0.1.tar.gz
+ source = https://gitlab.com/vnepogodin/std-format/-/archive/dfa4fdc87c7cb9bb1683125009baa7278bb85901/std-format-dfa4fdc87c7cb9bb1683125009baa7278bb85901.tar.gz
+ md5sums = e0107e820c42b17ae774a0c695780902
+ md5sums = e1f9d6bf78380b04a6a500a671bd8d38
pkgname = ananicy-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 89279bd658a6..3f8cea6db885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
pkgname=ananicy-cpp
-_pkgver=1.0.0-rc7
+_pkgver=1.0.1
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
@@ -10,21 +10,22 @@ license=(GPLv3)
source=(
"https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${_pkgver}/${pkgname}-v${_pkgver}.tar.gz"
)
-md5sums=('fb921722da05102093ca86beb0998ee7'
- 'e3654b522fb829dcad2818ff7b8de8e9')
+md5sums=('e0107e820c42b17ae774a0c695780902'
+ 'e1f9d6bf78380b04a6a500a671bd8d38')
declare -g -A externals
-externals['std-format']="45296602ad78a804411e7c3b617e13759f38e4e7"
+externals['std-format']="dfa4fdc87c7cb9bb1683125009baa7278bb85901"
for external in "${!externals[@]}"; do
- source+=(https://gitlab.com/ananicy-cpp/stl-polyfills/${external}/-/archive/${externals[$external]}/${external}-${externals[$external]}.tar.gz)
+ source+=(https://gitlab.com/vnepogodin/${external}/-/archive/${externals[$external]}/${external}-${externals[$external]}.tar.gz)
done
arch=(x86_64 i386 armv7h x86_64_v3 aarch64 pentium4)
-depends=(fmt spdlog nlohmann-json systemd)
-makedepends=(cmake git)
-optdepends=("ananicy-rules-git: community rules")
+depends=(fmt spdlog nlohmann-json systemd libelf zlib libbpf)
+makedepends=(cmake clang git nlohmann-json bpf)
+optdepends=("ananicy-rules-git: community rules"
+ "ananicy-rules: rules for ananicy-cpp")
prepare() {
cd "$pkgname-v${_pkgver}"
@@ -41,6 +42,8 @@ prepare() {
-DUSE_EXTERNAL_JSON=ON \
-DUSE_EXTERNAL_FMTLIB=ON \
-DENABLE_SYSTEMD=ON \
+ -DUSE_BPF_PROC_IMPL=ON \
+ -DBPF_BUILD_LIBBPF=OFF \
-DVERSION=${_pkgver}
}