summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-01-07 02:14:06 -0500
committeréclairevoyant2023-01-07 02:14:06 -0500
commit4c016e759946a88804d5ba8af89ec0c60fe5f947 (patch)
treec70e4163a3c4a1fbbab78dd78ed6211f4785a88d
parent65be957aee34c05418762e710ca0f4cfe2292bfc (diff)
downloadaur-4c016e759946a88804d5ba8af89ec0c60fe5f947.tar.gz
torch7-cwrap-git: install license
Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD48
2 files changed, 26 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8408dde2c1e..b9b49be82e31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Aug 28 08:57:02 UTC 2016
pkgbase = torch7-cwrap-git
pkgdesc = Tool to aid wrapping C functions to be used from Lua
pkgver = r35.dbd0a62
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/torch/cwrap
arch = any
- license = BSD
+ license = custom
makedepends = git
provides = torch7-cwrap
conflicts = torch7-cwrap
- source = torch7-cwrap-git::git+https://github.com/torch/cwrap
- sha512sums = SKIP
+ source = git+https://github.com/torch/cwrap
+ b2sums = SKIP
pkgname = torch7-cwrap-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c17348fe305a..4ac4186e1638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
-# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
-pkgdesc='Tool to aid wrapping C functions to be used from Lua'
-pkgname='torch7-cwrap-git'
+# Maintainer: éclairevoyant
+# Contributor: Adrián Pérez de Castro <aperez at igalia dot com>
+
+_pkgname=torch7-cwrap
+pkgname="$_pkgname-git"
pkgver=r35.dbd0a62
-pkgrel=1
-conflicts=('torch7-cwrap')
-provides=('torch7-cwrap')
+pkgrel=2
+pkgdesc='Tool to aid wrapping C functions to be used from Lua'
arch=('any')
-url='https://github.com/torch/cwrap'
+_gitname=cwrap
+url="https://github.com/torch/$_gitname"
+license=('custom')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
makedepends=('git')
-license=('BSD')
-source=("${pkgname}::git+${url}")
-sha512sums=('SKIP')
-
-pkgver () {
- cd "${pkgname}"
- (
- set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
-}
+source=("git+$url")
+b2sums=('SKIP')
-build () {
- echo 'Nothing to build'
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package () {
- cd "${pkgname}"
- for filename in *.lua ; do
- install -Dm644 "${filename}" \
- "${pkgdir}/usr/share/lua/5.1/cwrap/${filename}"
+package() {
+ cd $_gitname
+ for filename in *.lua; do
+ install -Dm644 "$filename" "$pkgdir/usr/share/lua/5.1/cwrap/$filename"
done
+ install -Dm644 COPYRIGHT.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}