summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-07-10 01:45:08 +0200
committerNarrat2015-07-10 01:46:06 +0200
commit4c0ae8c302f9e14ac1e57479f71ec0c5ae4e1795 (patch)
tree54cdfe215a908e57e250a42685a04fd7195c7504
parentbd55e3c18d3060425f1bcc7aa2f7d333d1e79986 (diff)
downloadaur-4c0ae8c302f9e14ac1e57479f71ec0c5ae4e1795.tar.gz
opendict: Update to 0.6.6
+ some Guideline updates and changes (pacman4.2)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD49
-rw-r--r--opendict.install11
3 files changed, 39 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 440055a80eda..b8f64e168124 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = opendict
pkgdesc = Multiplatform computer dictionary software
- pkgver = 0.6.3
- pkgrel = 4
+ pkgver = 0.6.6
+ pkgrel = 1
url = http://opendict.idiles.com/
+ install = opendict.install
arch = any
license = GPL
- depends = python2>=2.3
depends = wxpython
- depends = pyxml
- depends = gettext>=0.14
- source = http://opendict.idiles.com/files/opendict-0.6.3.tar.gz
- md5sums = 2426a1de1131d0279dcea0cded43b063
+ depends = xdg-utils
+ source = http://downloads.sourceforge.net/project/opendict/opendict-0.6.6.tar.gz
+ md5sums = 2909fe7ebdcc8bba869c9ca24dbbe086
pkgname = opendict
diff --git a/PKGBUILD b/PKGBUILD
index 7443a686417e..7fb2772f0ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,34 @@
+# Maintainer: Lex Black <autumn-wind at web dot de>
# Contributor: Giedrius Slavinskas <giedrius25@gmail.com>
pkgname=opendict
-pkgver=0.6.3
-pkgrel=4
+pkgver=0.6.6
+pkgrel=1
pkgdesc="Multiplatform computer dictionary software"
arch=('any')
url="http://opendict.idiles.com/"
license=('GPL')
-depends=('python2>=2.3' 'wxpython' 'pyxml' 'gettext>=0.14')
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-install=
-source=(http://opendict.idiles.com/files/$pkgname-$pkgver.tar.gz)
-noextract=()
-md5sums=('2426a1de1131d0279dcea0cded43b063')
-icondir=share/icons/hicolor
+depends=('wxpython' 'xdg-utils')
+install=${pkgname}.install
+source=(http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('2909fe7ebdcc8bba869c9ca24dbbe086')
-build() {
- mkdir -p $startdir/pkg/usr/$icondir/24x24/apps
- mkdir -p $startdir/pkg/usr/$icondir/32x32/apps
- mkdir -p $startdir/pkg/usr/$icondir/48x48/apps
- mkdir -p $startdir/pkg/usr/$icondir/96x96/apps
- mkdir -p $startdir/pkg/usr/$icondir/scalable/apps
- mkdir -p $startdir/pkg/usr/bin
- mkdir -p $startdir/pkg/usr/share/applications
- cd $startdir/src/$pkgname-$pkgver
-
- # python2 fix
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # python2 fix
sed -i 's_/usr/share/doc/packages/python_/usr/lib/python2.7_g' po/Makefile
sed -i 's_python _python2 _' po/Makefile
sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' opendict.py
-
- make DESTDIR=$startdir/pkg/usr install || return 1
- ln -sf $startdir/pkg/usr/share/opendict/opendict.py $startdir/pkg/usr/bin/opendict
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR=$pkgdir/usr install
+
+ # Fix makefile symlink
+ cd $pkgdir/usr/bin
+ ln -sf ../share/opendict/opendict.py opendict
}
diff --git a/opendict.install b/opendict.install
new file mode 100644
index 000000000000..2c455e952b7b
--- /dev/null
+++ b/opendict.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}