summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2016-03-27 18:57:24 -0400
committerEric Berquist2016-03-27 18:57:24 -0400
commit4c0c2cd80be0b82e9411853cbebd3f56bd5b5c03 (patch)
treec268d19f4ee7e258ef9c9c67bb74d838dc90816e
downloadaur-4c0c2cd80be0b82e9411853cbebd3f56bd5b5c03.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD43
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..718c506fa794
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Mar 27 22:52:41 UTC 2016
+pkgbase = psi3-bin
+ pkgdesc = An open-source program for computing molecular properties using high-accuracy, ab initio, quantum mechanical models. (Debian binary build)
+ pkgver = 3.4.0.6
+ pkgrel = 1
+ url = https://sourceforge.net/projects/psicode/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gcc-libs
+ depends = lapack
+ provides = psi3
+ conflicts = psi3
+ options = !strip
+ options = libtool
+ options = staticlibs
+ source = http://ftp.us.debian.org/debian/pool/main/p/psicode/psi3_3.4.0-6_.deb
+
+pkgname = psi3-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b32e95368c05
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91ff5125153d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+
+_pkgname=psi3
+pkgname=${_pkgname}-bin
+pkgver=3.4.0.6
+_pkgver=3.4.0-6
+pkgrel=1
+pkgdesc="An open-source program for computing molecular properties using high-accuracy, ab initio, quantum mechanical models. (Debian binary build)"
+arch=("i686" "x86_64")
+url="https://sourceforge.net/projects/psicode/"
+license=("GPL2")
+depends=("gcc-libs" "lapack")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+options=("!strip" "libtool" "staticlibs")
+case "${CARCH}" in
+ "i686")
+ _arch='i386'
+ _sha256sum='825ccea23bad7cb7808c0f62d5041c64ac15d9cc8cbb6faefc858995e01340d2'
+ ;;
+ "x86_64")
+ _arch='amd64'
+ _sha256sum='174c245674c2e81326e66f4547c505305d10882fb9e5ae968dbe34924ab7316a'
+ ;;
+esac
+source=("http://ftp.us.debian.org/debian/pool/main/p/psicode/${_pkgname}_${_pkgver}_${_arch}.deb")
+sha256sums=("${_sha256sum}")
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+
+ msg2 "Extracting documentation..."
+ gunzip "${pkgdir}"/usr/share/doc/"${_pkgname}"/userman.ps.gz
+
+ msg2 "Adding license..."
+ install -Dm644 "${pkgdir}"/usr/share/doc/"${_pkgname}"/copyright "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+
+ msg2 "Removing Debian extras..."
+ rm -r "${pkgdir}"/usr/share/doc-base
+ rm "${pkgdir}"/usr/share/doc/"${_pkgname}"/copyright
+ rm "${pkgdir}"/usr/share/doc/"${_pkgname}"/changelog.Debian.gz
+}