summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-12-10 05:08:12 +0100
committerSebastian 'Swift Geek' Grzywna2017-12-10 05:09:39 +0100
commit4c1994367b91b6082df907e8e6eb59e58c17f971 (patch)
tree3841bf834632968177de56c5bfdcbc032c5f827b
parent5771fb075ea8c84318bd8015934a694b5885a7f2 (diff)
downloadaur-4c1994367b91b6082df907e8e6eb59e58c17f971.tar.gz
Fix VCS
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbd83c658885..546ae9ce4640 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-# Generated by makepkg 4.2.1
-# Sun May 17 04:29:56 UTC 2015
+# Generated by mksrcinfo v8
+# Sun Dec 10 04:09:33 UTC 2017
pkgbase = stm8flash-git
pkgdesc = Utility for flashing STM8 MCU family via ST-LINK (V1 and V2)
- pkgver = 20150517
+ pkgver = a
pkgrel = 1
url = https://github.com/vdudouyt/stm8flash
arch = i686
@@ -10,6 +10,8 @@ pkgbase = stm8flash-git
license = GPL2
makedepends = git
depends = libusb
+ source = git://github.com/vdudouyt/stm8flash.git
+ md5sums = SKIP
pkgname = stm8flash-git
diff --git a/PKGBUILD b/PKGBUILD
index dd6cb6296b51..4701bdad0c36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
pkgname="stm8flash-git"
-pkgver="20150517"
-pkgrel="1"
+_pkgname="stm8flash"
+pkgver=a
+pkgrel=1
pkgdesc="Utility for flashing STM8 MCU family via ST-LINK (V1 and V2)"
arch=('i686' 'x86_64')
url='https://github.com/vdudouyt/stm8flash'
license=('GPL2')
depends=('libusb')
makedepends=('git')
-source=()
-md5sums=()
+source=('git://github.com/vdudouyt/stm8flash.git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-parse --short HEAD # Fix to better comply with github display
+}
build() {
- cd "${srcdir}"
- git clone https://github.com/vdudouyt/stm8flash
- cd "stm8flash"
- make
+ cd "$srcdir/$_pkgname"
+ make
}
package() {
- cd "${srcdir}/stm8flash"
- mkdir -p "${pkgdir}/usr/bin"
- make DESTDIR="${pkgdir}" install
-} \ No newline at end of file
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir" install
+}