summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2015-06-10 14:07:19 +0200
committerSteffen Weber2015-06-10 14:07:19 +0200
commit4c1f6b1805144a5c5ec8ab71cda60bcff4bac163 (patch)
tree04a2a15f7ce20c8f1e1a91820464bb597dd0eeb0
downloadaur-4c1f6b1805144a5c5ec8ab71cda60bcff4bac163.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD65
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fde3293eb03d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = clarity-icon-theme
+ pkgdesc = Vector icons in 8 colourthemes for GTK
+ pkgver = 0.4.0
+ pkgrel = 3
+ url = http://gnome-look.org/content/show.php/Clarity?content=135654
+ arch = any
+ license = GPL3
+ makedepends = imagemagick
+ makedepends = librsvg
+ options = !strip
+ options = !zipman
+ source = http://load.boenki.org/clarity-icon-theme_0.4.0.tar.gz
+ source = clarity-icon-theme-rsvg.patch::https://github.com/jcubic/Clarity/commit/eec45bfefd0874b059aaf7926d134cc31ad7fd31.patch
+ source = clarity-icon-theme-huge-icons.patch::https://github.com/jcubic/Clarity/commit/63d2a085b11c5315c10fc115d4bbc4610ba6ed24.patch
+ md5sums = 4f843a762272967b177ebfa18b54fd6e
+ md5sums = ce4559e558d4f19577cfd72bb2aabeb8
+ md5sums = 27161dd28fc51bfa0da84aa193444811
+
+pkgname = clarity-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..02669b706164
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: Anonymo <meowdib at gmail dot com>
+
+pkgname=clarity-icon-theme
+pkgver=0.4.0
+pkgrel=3
+pkgdesc="Vector icons in 8 colourthemes for GTK"
+arch=('any')
+makedepends=('imagemagick' 'librsvg')
+url="http://gnome-look.org/content/show.php/Clarity?content=135654"
+license=('GPL3')
+options=(!strip !zipman)
+source=(http://load.boenki.org/${pkgname}_${pkgver}.tar.gz
+ $pkgname-rsvg.patch::https://github.com/jcubic/Clarity/commit/eec45bfefd0874b059aaf7926d134cc31ad7fd31.patch
+ $pkgname-huge-icons.patch::https://github.com/jcubic/Clarity/commit/63d2a085b11c5315c10fc115d4bbc4610ba6ed24.patch)
+md5sums=('4f843a762272967b177ebfa18b54fd6e'
+ 'ce4559e558d4f19577cfd72bb2aabeb8'
+ '27161dd28fc51bfa0da84aa193444811')
+
+##############################################################
+#Put the themes you want to build in _buildtheme array below.#
+#By default all themes will be built. #
+# #
+#Available themes: #
+# violaceus - violet/pink gradient #
+# lux_violaceus - glossy variant #
+# canus - grey gradient #
+# dark_canus - dark grey gradient #
+# caeruleus - blue gradient #
+# lux_caeruleus - glossy variant #
+# viridis - green gradient #
+# luteus - orange gradient #
+##############################################################
+
+_buildtheme=(violaceus lux_violaceus canus dark_canus caeruleus lux_caeruleus viridis luteus)
+
+prepare() {
+ cd "${srcdir}/${pkgname}_${pkgver}"
+ patch -p1 -i ../$pkgname-rsvg.patch
+ patch -p1 -i ../$pkgname-huge-icons.patch
+}
+
+build() {
+ for _theme in ${_buildtheme[*]}; do
+ cd "${srcdir}/${pkgname}_${pkgver}"
+ msg "Building theme ${_theme}"
+ make ${_theme}
+ make arch
+ install -d themes/${_theme}
+ cp -r {scalable,16x16,index.theme} themes/${_theme}
+ sed -i s/Name=Clarity/Name=Clarity-${_theme}/ themes/${_theme}/index.theme
+ done
+}
+
+package() {
+ for _theme in ${_buildtheme[*]}; do
+ install -d "${pkgdir}/usr/share/icons/clarity-${_theme}"
+ cp -r ${srcdir}/${pkgname}_${pkgver}/themes/${_theme}/{scalable,16x16,index.theme} \
+ "${pkgdir}/usr/share/icons/clarity-${_theme}"
+
+ cd "${pkgdir}/usr/share/icons/clarity-${_theme}"
+ ln -s applications-science.svg scalable/categories/applications-education.svg
+ ln -s applications-science.png 16x16/categories/applications-education.png
+ done
+}