summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2014-01-22 16:28:12 +0000
committerJon Gjengset2015-06-08 11:34:09 -0400
commit4c41e15306ef93340b53ab94ec524d816b33afa2 (patch)
tree5ac66cae0a4276575d62893bfcb53237eea42376
downloadaur-4c41e15306ef93340b53ab94ec524d816b33afa2.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rw-r--r--texlive.install14
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b227f187058
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = latex-acm-sig
+ pkgdesc = ACM SIG Proceedings Format style for LaTeX (acm_proc_article-sp and sig-alternate)
+ pkgver = 20120523
+ pkgrel = 1
+ url = http://www.acm.org/sigs/publications/proceedings-templates
+ install = texlive.install
+ arch = any
+ license = unknown
+ depends = texlive-core
+ conflicts = latex-template-acm
+ source = http://www.acm.org/sigs/publications/acm_proc_article-sp.cls
+ source = http://www.acm.org/sigs/publications/sig-alternate.cls
+ md5sums = 49fc14f68a73f326183ff0d766bec0c2
+ md5sums = 8230a5fbf2c386a55d2f105c064c7f85
+
+pkgname = latex-acm-sig
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3152c20e34aa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.pkg.*
+*.src.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c104b08b1508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jon Gjengset <jon@tsp.io>
+# Contributor: Olivier Mehani <shtrom-aur@ssji.net>
+# Maintained at https://github.com/jonhoo/latex-acm-sig-PKGBUILD
+
+pkgname=latex-acm-sig
+pkgver=20120523
+pkgrel=1
+pkgdesc="ACM SIG Proceedings Format style for LaTeX (acm_proc_article-sp and sig-alternate)"
+arch=('any')
+url="http://www.acm.org/sigs/publications/proceedings-templates"
+conflicts=('latex-template-acm')
+license=('unknown')
+depends=('texlive-core')
+install=texlive.install
+source=(
+ http://www.acm.org/sigs/publications/acm_proc_article-sp.cls
+ http://www.acm.org/sigs/publications/sig-alternate.cls
+)
+
+pkgver() {
+ grep "tracking data" *.cls | sed 's/.*{\(.*\)}.*/\1/' | awk '{print "date -d\""$0"\" +%Y%m%d"}' | sh | sort | tail -n1
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/texmf-dist/tex/latex/acm-sigproc/
+ install -m 644 *.cls ${pkgdir}/usr/share/texmf-dist/tex/latex/acm-sigproc/
+ ln -s ${pkgdir}/usr/share/texmf-dist/tex/latex/acm-sigproc/acm_proc_article-sp.cls ${pkgdir}/usr/share/texmf-dist/tex/latex/acm-sigproc/sig-proc.cls
+}
+
+md5sums=('49fc14f68a73f326183ff0d766bec0c2'
+ '8230a5fbf2c386a55d2f105c064c7f85')
+
+# vim:set ts=2 sw=2 et:
diff --git a/texlive.install b/texlive.install
new file mode 100644
index 000000000000..3ab7acb55d57
--- /dev/null
+++ b/texlive.install
@@ -0,0 +1,14 @@
+# Taken from texlive-publishers
+
+post_install() {
+ echo ">>> texlive: updating the filename database..."
+ /usr/bin/mktexlsr
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}