summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroliboy2021-08-27 19:13:50 +0300
committerroliboy2021-08-27 19:13:50 +0300
commit4c99a0ec9b8b784911dd16f8ade2958d6183fd4d (patch)
treee4860b6237ba0162b23520e7ee3509367cd1f4c8
parent712d6073037f882414ecb9d3d85bd676b5cbfd5e (diff)
downloadaur-4c99a0ec9b8b784911dd16f8ade2958d6183fd4d.tar.gz
update to version 3.4.0 and add optional python-orjson dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cd301cdb731..aca36e437397 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pywhat
pkgdesc = Identify emails, IP addresses and more
- pkgver = 3.3.0
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/bee-san/pyWhat
arch = any
@@ -10,7 +10,8 @@ pkgbase = python-pywhat
depends = python
depends = python-click
depends = python-rich
- source = python-pywhat-3.3.0.tar.gz::https://github.com/bee-san/pyWhat/archive/3.3.0.tar.gz
- sha256sums = a81891c712f197e0f1446c0b52288b3ebdfafd125e3b8621cfd311d2468c4577
+ optdepends = python-orjson: faster JSON serialization and deserialization
+ source = python-pywhat-3.4.0.tar.gz::https://github.com/bee-san/pyWhat/archive/3.4.0.tar.gz
+ sha256sums = bff050c5e3e982e7ae0ac7068b4d0af1db175acceda56d333ac5734aab5975eb
pkgname = python-pywhat
diff --git a/PKGBUILD b/PKGBUILD
index fd764b96c916..77fbf95f8707 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-pywhat
_pkgname=pyWhat
-pkgver=3.3.0
+pkgver=3.4.0
pkgrel=1
pkgdesc="Identify emails, IP addresses and more"
arch=("any")
@@ -15,10 +15,13 @@ makedepends=(
"python-dephell"
"python-setuptools"
)
+optdepends=(
+ "python-orjson: faster JSON serialization and deserialization"
+)
url="https://github.com/bee-san/pyWhat"
license=("GPL-3.0")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=("a81891c712f197e0f1446c0b52288b3ebdfafd125e3b8621cfd311d2468c4577")
+sha256sums=("bff050c5e3e982e7ae0ac7068b4d0af1db175acceda56d333ac5734aab5975eb")
prepare() {
cd "${_pkgname}-${pkgver}"