summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Terrien2015-05-25 14:38:26 -0700
committerKyle Terrien2015-05-25 17:26:34 -0700
commit4c99a9294b4fd6409ddbd1655dc75851ca56466f (patch)
tree861cdaf745d165d63d1e0f62cef871530077f288
parentf81a4c8f939f1aea7c99af188d09196045223944 (diff)
downloadaur-4c99a9294b4fd6409ddbd1655dc75851ca56466f.tar.gz
v2.48
Updated .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--disable-apm.patch48
3 files changed, 19 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52284de15e1d..4ea92eab1ae6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
+# Generated by makepkg 4.2.1
+# Tue May 26 00:20:29 UTC 2015
pkgbase = wmbattery
pkgdesc = Battery monitor dockapp for Window Maker
- pkgver = 2.41
- pkgrel = 1
- url = http://kitenet.net/~joey/code/wmbattery/
+ pkgver = 2.48
+ pkgrel = 2
+ url = http://windowmaker.org/dockapps/?name=wmbattery
arch = i686
arch = x86_64
license = GPL
depends = libxpm
- depends = hal
- source = git://git.kitenet.net/wmbattery#tag=2.41
- source = disable-apm.patch
- md5sums = SKIP
- md5sums = c5e2a979ade6d16069065c93f2cf2402
+ depends = upower
+ source = wmbattery-2.48.tar.gz::http://windowmaker.org/dockapps/?download=wmbattery-2.48.tar.gz
+ md5sums = 315e1546036674170ea2035e2f3604dc
pkgname = wmbattery
diff --git a/PKGBUILD b/PKGBUILD
index f71915576c17..563eab061920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Henrik Tunedal <putte_xvi at tunedal dot nu>
pkgname=wmbattery
-pkgver=2.41
-pkgrel=1
+pkgver=2.48
+pkgrel=2
pkgdesc="Battery monitor dockapp for Window Maker"
arch=(i686 x86_64)
-url="http://kitenet.net/~joey/code/wmbattery/"
+url="http://windowmaker.org/dockapps/?name=wmbattery"
license=('GPL')
-depends=(libxpm hal)
-source=(git://git.kitenet.net/wmbattery#tag=2.41
- disable-apm.patch)
-md5sums=('SKIP'
- 'c5e2a979ade6d16069065c93f2cf2402')
+depends=(libxpm upower)
+source=("$pkgname-$pkgver.tar.gz::http://windowmaker.org/dockapps/?download=wmbattery-2.48.tar.gz")
+md5sums=('315e1546036674170ea2035e2f3604dc')
build() {
- cd "$srcdir/$pkgname"
- patch -p1 <../disable-apm.patch || return 1
- autoreconf -fiv || return 1
- ./configure --prefix=/usr || return 1
- make || return 1
+ cd "$srcdir/dockapps-"*
+ autoreconf -fiv
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/dockapps-"*
make DESTDIR="$pkgdir/" install
}
diff --git a/disable-apm.patch b/disable-apm.patch
deleted file mode 100644
index 26d99cb84e0a..000000000000
--- a/disable-apm.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -purN wmbattery.orig/apm.h wmbattery/apm.h
---- wmbattery.orig/apm.h 2013-04-11 10:08:58.000000000 -0600
-+++ wmbattery/apm.h 2013-04-11 10:14:23.000000000 -0600
-@@ -1,4 +1,17 @@
--#include <apm.h>
-+typedef struct apm_info
-+{
-+ const char driver_version[10];
-+ int apm_version_major;
-+ int apm_version_minor;
-+ int apm_flags;
-+ int ac_line_status;
-+ int battery_status;
-+ int battery_flags;
-+ int battery_percentage;
-+ int battery_time;
-+ int using_minutes;
-+}
-+apm_info;
-
- /* Symbolic constants for apm may be in system apm.h, or may not. */
- #ifndef AC_LINE_STATUS_ON
-diff -purN wmbattery.orig/wmbattery.c wmbattery/wmbattery.c
---- wmbattery.orig/wmbattery.c 2013-04-11 10:08:58.000000000 -0600
-+++ wmbattery/wmbattery.c 2013-04-11 10:15:29.000000000 -0600
-@@ -528,10 +528,6 @@ void alarmhandler(int sig) {
- error("Cannot read HAL information.");
- }
- #endif
-- else if (! use_sonypi) {
-- if (apm_read(&cur_info) != 0)
-- error("Cannot read APM information.");
-- }
- else {
- if (sonypi_read(&cur_info) != 0)
- error("Cannot read sonypi information.");
-@@ -583,10 +579,7 @@ void check_battery_num(int real, int req
- int main(int argc, char *argv[]) {
- make_window(parse_commandline(argc, argv), argc ,argv);
-
-- /* Check for APM support (returns 0 on success). */
-- if (apm_exists() == 0) {
-- if (! delay)
-- delay = 1;
-+ if (0) {
- }
- #ifdef HAL
- /* Check for hal support. */