summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2020-05-27 19:24:12 -0700
committerAnatol Pomozov2020-05-27 19:24:12 -0700
commit4ca13b14523213c099ea5dc187b137f0a5110234 (patch)
treee356f447ed1d3dfd9786eb5a441e4c9bbe1e0965
parent9ee5668daffbdbbf1f89c3332fcb0f5ab3cd0f1b (diff)
downloadaur-4ca13b14523213c099ea5dc187b137f0a5110234.tar.gz
updpkg
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
-rw-r--r--fix.patch43
-rw-r--r--makefile.patch14
4 files changed, 69 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a5d51fb5997..2f88c977f33e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = vboot-utils
pkgdesc = Chromium OS verified boot utilities
- pkgver = 81.12871
+ pkgver = 84.13099
pkgrel = 1
url = https://chromium.googlesource.com/chromiumos/platform/vboot_reference
arch = i686
arch = x86_64
license = custom:chromiumos
+ makedepends = git
makedepends = libyaml
makedepends = trousers
depends = libutil-linux
depends = openssl
- source = https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/release-R81-12871.B.tar.gz
+ source = git+https://chromium.googlesource.com/chromiumos/platform/vboot_reference#branch=release-R84-13099.B
+ source = fix.patch
source = makefile.patch
sha256sums = SKIP
- sha256sums = 7804878ce24b2ca9bd8858bfffcf97b12627b2c7524879240a958cec244afdcb
+ sha256sums = 1303b8c82e4cec2300d50173d45d892b42579efbdaa5d7ea66704c1916323778
+ sha256sums = 695da021a15d43174a9ac9227ef28f834d6393c7c97750611ac27c6c4ea82dfd
pkgname = vboot-utils
diff --git a/PKGBUILD b/PKGBUILD
index 9e32378d6713..6e7b0eec5734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,39 @@
pkgname=vboot-utils
pkgdesc='Chromium OS verified boot utilities'
-pkgver=81.12871
+pkgver=84.13099
_tag=release-R${pkgver/\./-}.B
pkgrel=1
arch=(i686 x86_64)
url='https://chromium.googlesource.com/chromiumos/platform/vboot_reference'
license=('custom:chromiumos')
depends=(libutil-linux openssl)
-makedepends=(libyaml trousers)
-source=(https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/$_tag.tar.gz
+makedepends=(git libyaml trousers)
+source=(git+https://chromium.googlesource.com/chromiumos/platform/vboot_reference#branch=$_tag
+ fix.patch
makefile.patch)
-sha256sums=(SKIP
- '7804878ce24b2ca9bd8858bfffcf97b12627b2c7524879240a958cec244afdcb')
+sha256sums=('SKIP'
+ '1303b8c82e4cec2300d50173d45d892b42579efbdaa5d7ea66704c1916323778'
+ '695da021a15d43174a9ac9227ef28f834d6393c7c97750611ac27c6c4ea82dfd')
prepare() {
- patch -p1 < makefile.patch
+ cd vboot_reference
+ patch -p1 < ../makefile.patch
+ patch -p1 < ../fix.patch
}
build() {
+ cd vboot_reference
make
}
check() {
+ cd vboot_reference
make runtests || true
}
package() {
+ cd vboot_reference
make install DESTDIR="$pkgdir" MINIMAL=1
install -d "$pkgdir"/usr/share/vboot/
cp -r tests/devkeys "$pkgdir"/usr/share/vboot/devkeys
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..ae67fde8f4a4
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,43 @@
+commit ca26590ccc73a0c9ca625acab5f2acaa08408d7d
+Author: Anatol Pomozov <anatol.pomozov@gmail.com>
+Date: Wed May 27 19:17:03 2020 -0700
+
+ Fix linking issue
+
+ /usr/bin/ld: /mnt/cold/sources/vboot_reference/build/libvboot_util.a(subprocess.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:93: multiple definition of `subprocess_stdin'; /mnt/cold/sources/vboot_reference/build/libvboot_util.a(crossystem.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:93: first defined here
+ /usr/bin/ld: /mnt/cold/sources/vboot_reference/build/libvboot_util.a(subprocess.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:103: multiple definition of `subprocess_stderr'; /mnt/cold/sources/vboot_reference/build/libvboot_util.a(crossystem.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:103: first defined here
+ /usr/bin/ld: /mnt/cold/sources/vboot_reference/build/libvboot_util.a(subprocess.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:88: multiple definition of `subprocess_null'; /mnt/cold/sources/vboot_reference/build/libvboot_util.a(crossystem.o):/home/anatol/sources/vboot_reference/host/lib/include/subprocess.h:88: first defined here
+
+ Signed-off-by: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+diff --git a/host/lib/include/subprocess.h b/host/lib/include/subprocess.h
+index eaf75502..b24b987f 100644
+--- a/host/lib/include/subprocess.h
++++ b/host/lib/include/subprocess.h
+@@ -85,22 +85,22 @@ struct subprocess_target {
+ /**
+ * A convenience subprocess target which uses TARGET_NULL.
+ */
+-struct subprocess_target subprocess_null;
++extern struct subprocess_target subprocess_null;
+
+ /**
+ * A convenience subprocess target which uses TARGET_FD to STDIN_FILENO.
+ */
+-struct subprocess_target subprocess_stdin;
++extern struct subprocess_target subprocess_stdin;
+
+ /**
+ * A convenience subprocess target which uses TARGET_FD to STDOUT_FILENO.
+ */
+-struct subprocess_target subprocess_stdout;
++extern struct subprocess_target subprocess_stdout;
+
+ /**
+ * A convenience subprocess target which uses TARGET_FD to STDERR_FILENO.
+ */
+-struct subprocess_target subprocess_stderr;
++extern struct subprocess_target subprocess_stderr;
+
+ /**
+ * Call a process and run until completion.
diff --git a/makefile.patch b/makefile.patch
index fcb4251cd9d8..ec56c08f7fcf 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,12 +1,12 @@
diff --git a/Makefile b/Makefile
-index 0c075e06..2c3e5e9e 100644
+index b35dc913..3e8c2b45 100644
--- a/Makefile
+++ b/Makefile
-@@ -834,7 +834,6 @@ host_tools: utils futil tests
-
- .PHONY: host_stuff
- host_stuff: utillib hostlib \
+@@ -324,7 +324,6 @@ export BUILD_RUN
+ .PHONY: all
+ all: fwlib futil utillib hostlib cgpt tlcl \
+ $(if ${SDK_BUILD},utils_sdk,utils_board) \
- $(if $(filter x86_64,${ARCH}),fuzzers) \
- $(if ${NO_BUILD_TOOLS},,cgpt host_tools)
+ $(if ${COV},coverage)
- .PHONY: clean
+ ##############################################################################