summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreugene2023-09-20 18:24:49 +0000
committereugene2023-09-20 18:24:49 +0000
commit4cafe034b3ddf29f29e298c0c297b59d72e852e8 (patch)
tree41ce8a24b60ac31f81eab6d3bb2dfe7ee0f00a16
parent6f8085dd7c9e3796672641ac899e76d2ed167d38 (diff)
downloadaur-4cafe034b3ddf29f29e298c0c297b59d72e852e8.tar.gz
make ntfsprogs hard dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80ffbe98b409..f4e6ec3207ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = testdisk-wip
pkgdesc = Checks and undeletes partitions. Includes PhotoRec signature based recovery tool. WIP version
pkgver = 7.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.cgsecurity.org/wiki/TestDisk
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
makedepends = qt5-tools
depends = libjpeg
+ depends = ntfsprogs
optdepends = libewf: support EnCase files
- optdepends = ntfs-3g: support NTFS partitions
optdepends = qt5-base: QPhotoRec GUI
provides = testdisk
conflicts = testdisk
diff --git a/PKGBUILD b/PKGBUILD
index e26c40469d66..52e4273e7e31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Contributor: Steven Honeyman <stevenhoneyman at gmail com>
pkgname=testdisk-wip
pkgver=7.2
-pkgrel=2
+pkgrel=3
pkgdesc="Checks and undeletes partitions. Includes PhotoRec signature based recovery tool. WIP version"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="http://www.cgsecurity.org/wiki/TestDisk"
license=('GPL')
-depends=('libjpeg')
+depends=('libjpeg' 'ntfsprogs')
optdepends=('libewf: support EnCase files'
- 'ntfs-3g: support NTFS partitions'
'qt5-base: QPhotoRec GUI')
makedepends=('qt5-tools')
conflicts=('testdisk')
@@ -22,13 +21,7 @@ prepare() {
cd "$srcdir/testdisk-$pkgver-WIP"
# Some fixes to make it Qt5 capable
- sed -i '/<QWidget>/d' src/*.h
- sed -i '/<QWidget>/d' src/*.cpp
- sed -i 's/Qt::escape\(.*\)text())/QString\1text()).toHtmlEscaped()/g' src/qphotorec.cpp
-
- ## You might not need these, but I did for some reason
- test -f src/gnome/help-about.png || cp /usr/share/icons/gnome/48x48/actions/help-about.png src/gnome/
- test -f src/gnome/image-x-generic.png || cp /usr/share/icons/gnome/48x48/mimetypes/image-x-generic.png src/gnome/
+ sed -i '/<QWidget>/d' src/*.h src/*.cpp
}
build() {