summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2015-06-08 13:49:39 -0600
committerDrew DeVault2015-06-08 13:49:39 -0600
commit4ccdd10b7abfe144b5288be10597fe5cbb4dfab0 (patch)
tree054d6572340715140d203d16de93673181b2c8ac
downloadaur-4ccdd10b7abfe144b5288be10597fe5cbb4dfab0.tar.gz
Initial import from aur3
-rw-r--r--.SRCINFO36
-rwxr-xr-xPKGBUILD69
-rw-r--r--mgcb.sh2
-rw-r--r--monogame.pc.in9
4 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e68a8f369134
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = monogame-git
+ pkgdesc = XNA Implementation for Mono based platforms (git)
+ pkgver = v3.2.2792
+ pkgrel = 1
+ url = http://monogame.codeplex.com
+ arch = i686
+ arch = x86_64
+ license = Microsoft Public License
+ makedepends = nant
+ makedepends = nvidia-texture-tools
+ makedepends = dos2unix
+ makedepends = monodevelop
+ makedepends = sharpfont
+ makedepends = assimp-net
+ depends = opentk
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = sdl_image
+ depends = sdl_net
+ depends = smpeg
+ depends = sdl_gfx
+ provides = monogame
+ conflicts = monogame
+ conflicts = tao-framework
+ conflicts = tao-framework-svn
+ source = monogame::git+https://github.com/mono/MonoGame.git
+ source = Dependencies::git+https://github.com/Mono-Game/MonoGame.Dependencies.git
+ source = monogame.pc.in
+ source = mgcb.sh
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = ca37d66293d3aac43cac32628ed5d6b6
+ md5sums = 3cad3825e124ea7b7d060ba492adee47
+
+pkgname = monogame-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3ebb3fab4a3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+pkgname=monogame-git
+pkgver=v3.2.2792
+pkgrel=1
+pkgdesc="XNA Implementation for Mono based platforms (git)"
+arch=(i686 x86_64)
+license=("Microsoft Public License")
+depends=(opentk sdl_mixer sdl_ttf sdl_image sdl_net smpeg sdl_gfx)
+makedepends=(nant nvidia-texture-tools dos2unix monodevelop sharpfont assimp-net)
+conflicts=(monogame tao-framework tao-framework-svn)
+provides=(monogame)
+url="http://monogame.codeplex.com"
+source=("${pkgname%-*}::git+https://github.com/mono/MonoGame.git"
+"Dependencies::git+https://github.com/Mono-Game/MonoGame.Dependencies.git"
+"monogame.pc.in"
+"mgcb.sh")
+md5sums=(SKIP
+SKIP
+'ca37d66293d3aac43cac32628ed5d6b6'
+'3cad3825e124ea7b7d060ba492adee47')
+
+pkgver () {
+ cd "$srcdir/${pkgname%-*}"
+ git describe | sed 's|\(.*-.*\)-.*|\1|;s|-|.|'
+}
+
+prepare() {
+ cd "$srcdir/Dependencies"
+ find . -type f -exec dos2unix {} \;
+ cd ../${pkgname%-*}/ThirdParty/Dependencies
+ cp -r ../../../Dependencies/* .
+ cd ../..
+ find . -name '*.csproj' -exec sed -i 's,<DebugType>none,<DebugType>pdbonly,g' {} \;
+ cd ProjectTemplates/MonoDevelop/MonoDevelop.MonoGame/MonoDevelop.MonoGame
+ sed -i -e "s,assemblies/WindowsGL,/usr/lib/monogame,g" -e "s,\"3\.0\",\"${_mdver}\",g" MonoDevelop.MonoGame.addin.xml
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-*}"
+ mono Protobuild.exe
+ nant build_linux
+ cd ProjectTemplates/MonoDevelop/MonoDevelop.MonoGame
+ xbuild MonoDevelop.MonoGame.sln /p:Configuration=ReleaseLinux
+ cd ../../../
+ xbuild MonoGame.Framework.Linux.sln /p:Configuration=Release
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-*}/MonoGame.ContentPipeline"
+ install -Dm644 MonoGame.ContentPipeline.targets "$pkgdir/usr/lib/mono/xbuild/MonoGame.ContentPipeline.targets"
+ cd ../MonoGame.Framework/bin/Linux/AnyCPU/Release
+ find . -name 'MonoGame.Framework.dll*' -exec install -Dm644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ find . -name 'Lidgren.Network.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ find . -name 'Tao.Sdl.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ find . -name '*.mgfxo' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ cd "${srcdir}/${pkgname%-*}/MonoGame.Framework.Content.Pipeline/bin/Linux/AnyCPU/Release"
+ find . -name 'MonoGame.Framework.Content.Pipeline.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ find . -name 'Nvidia.TextureTools.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ install -m644 ManagedPVRTC.dll "$pkgdir/usr/lib/monogame/"
+ cd "${srcdir}/${pkgname%-*}/ProjectTemplates/MonoDevelop/MonoDevelop.MonoGame/MonoDevelop.MonoGame/bin/Linux/Release"
+ find . -type f -exec install -Dm644 {} "$pkgdir/usr/lib/monodevelop/AddIns/MonoDevelop.MonoGame/"{} \;
+ cd "${srcdir}/${pkgname%-*}/Tools/MGCB/bin/Linux/AnyCPU/Release"
+ find . -name 'MGCB.Linux.exe*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
+ cd "$pkgdir/usr/lib/monogame"
+ gacutil -i Tao.Sdl.dll -root "$pkgdir/usr/lib"
+ install -Dm644 "${srcdir}/${pkgname%-*}/LICENSE.txt" "$pkgdir/usr/share/licenses/monogame/LICENSE.txt"
+ install -Dm755 "$srcdir/mgcb.sh" "$pkgdir/usr/bin/mgcb"
+ install -Dm644 "$srcdir/monogame.pc.in" "$pkgdir/usr/lib/pkgconfig/monogame.pc"
+ sed -i "s|@VERSION@|$pkgver|" "$pkgdir/usr/lib/pkgconfig/monogame.pc"
+}
diff --git a/mgcb.sh b/mgcb.sh
new file mode 100644
index 000000000000..574a26fe5b30
--- /dev/null
+++ b/mgcb.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/mono $MONO_OPTIONS /usr/lib/monogame/MGCB.Linux.exe "$@"
diff --git a/monogame.pc.in b/monogame.pc.in
new file mode 100644
index 000000000000..af501deab090
--- /dev/null
+++ b/monogame.pc.in
@@ -0,0 +1,9 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib
+
+Name: MonoGame.Framework
+Description: XNA Implementation for Mono based platforms
+Version: @VERSION@
+Requires: opentk
+Libs: -r:${libdir}/monogame/MonoGame.Framework.dll -r:${libdir}/monogame/Lidgren.Network.dll -r:${libdir}/monogame/Tao.Sdl.dll