summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukeLR2020-01-28 10:42:49 +0100
committerLukeLR2020-01-28 10:42:49 +0100
commit4cd914529db800b966f8c882f877c44709be29e4 (patch)
treec51b630154033618723fefa4ee924c12b7b77899
downloadaur-4cd914529db800b966f8c882f877c44709be29e4.tar.gz
geany-plugin-jsonprettifier v1.6.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--Makefile.patch11
-rw-r--r--PKGBUILD29
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4216f1f1d22e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = geany-plugin-jsonprettifier
+ pkgdesc = Clean up unformatted JSON in Geany editor
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://plugins.geany.org/jsonprettifier.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = geany
+ depends = yajl
+ source = https://github.com/zhgzhg/Geany-JSON-Prettifier/archive/v1.6.0.tar.gz
+ source = Makefile.patch
+ sha256sums = 3192d4d304cf1ce0bac78997a0ede9a88724e1f0fadbcf9a1968e9cff496740e
+ sha256sums = 391e5b83f87b23ac2a01c8f3252f028f391361500b70ee4b29710267cc54fa49
+
+pkgname = geany-plugin-jsonprettifier
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..f2c18c636a21
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text Geany-JSON-Prettifier-1.6.0-bak/Makefile Geany-JSON-Prettifier-1.6.0/Makefile
+--- Geany-JSON-Prettifier-1.6.0-bak/Makefile 2020-01-28 10:25:26.554720020 +0100
++++ Geany-JSON-Prettifier-1.6.0/Makefile 2020-01-28 10:24:39.528054318 +0100
+@@ -1,5 +1,5 @@
+-libdir.x86_64 := $(shell if [ -d "/usr/lib/x86_64-linux-gnu" ]; then echo "/usr/lib/x86_64-linux-gnu"; else echo "/usr/lib64"; fi )
+-libdir.i686 := $(shell if [ -d "/usr/lib/i386-linux-gnu" ]; then echo "/usr/lib/i386-linux-gnu"; else echo "/usr/lib"; fi )
++libdir.x86_64 := $(DESTDIR)/usr/lib
++libdir.i686 := $(DESTDIR)/usr/lib
+ libdir.macos := /usr/local/lib
+
+ ISNOTMACOS := $(shell uname -a | grep "Darwin" >/dev/null ; echo $$? )
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e4d19642655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lukas Rose <public@lrose.de>
+pkgname=geany-plugin-jsonprettifier
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="Clean up unformatted JSON in Geany editor"
+arch=('i686' 'x86_64')
+url="https://plugins.geany.org/jsonprettifier.html"
+license=('GPL2')
+depends=('geany' 'yajl')
+makedepends=('cmake')
+source=("https://github.com/zhgzhg/Geany-JSON-Prettifier/archive/v$pkgver.tar.gz" "Makefile.patch")
+sha256sums=('3192d4d304cf1ce0bac78997a0ede9a88724e1f0fadbcf9a1968e9cff496740e'
+ '391e5b83f87b23ac2a01c8f3252f028f391361500b70ee4b29710267cc54fa49')
+
+prepare() {
+ cd "Geany-JSON-Prettifier-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/Makefile.patch"
+}
+
+build() {
+ cd "Geany-JSON-Prettifier-$pkgver"
+ make -j1
+}
+
+package() {
+ cd "Geany-JSON-Prettifier-$pkgver"
+ mkdir -p "$pkgdir/usr/lib/geany"
+ make DESTDIR="$pkgdir/" install
+}