summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFacundo Tuesca2015-08-11 21:21:07 -0300
committerFacundo Tuesca2015-08-11 21:21:07 -0300
commit4cee7eb4f7d68d56522327d95983a86ac4323c10 (patch)
treefd879070771a1472857be24f8c0d688137ba4cab
downloadaur-4cee7eb4f7d68d56522327d95983a86ac4323c10.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--Rename_rot13_to_trrot13.patch107
3 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..872e45466ea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hxtools
+ pkgdesc = A collection of tools and scripts that have accumulated over the years, and each of which seems to be too small to warrants its own project.
+ pkgver = 20150304
+ pkgrel = 1
+ url = http://inai.de/projects/hxtools/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = libhx>=3.19
+ depends = perl
+ depends = util-linux
+ depends = pciutils
+ depends = libxcb
+ source = http://jftp.inai.de/hxtools/hxtools-20150304.tar.xz
+ source = Rename_rot13_to_trrot13.patch
+ sha256sums = 55265b16191831c4e332b0235b057e3f1e952298abf34734a8fa2ee9bb7be382
+ sha256sums = 89f65c581179582f178c1d60dbe9a702d7efb5b07f35442f03c9463af0c5b04d
+
+pkgname = hxtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..041df72beb82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Facundo Tuesca <facutuesca AT gmail DOT com>
+pkgname=hxtools
+pkgver=20150304
+pkgrel=1
+pkgdesc="A collection of tools and scripts that have accumulated over the years, and each of which seems to be too small to warrants its own project."
+arch=('i686' 'x86_64')
+url=http://inai.de/projects/hxtools/
+license=('GPL3')
+depends=('libhx>=3.19' perl util-linux pciutils libxcb)
+makedepends=()
+source=(http://jftp.inai.de/hxtools/hxtools-$pkgver.tar.xz
+ Rename_rot13_to_trrot13.patch)
+sha256sums=('55265b16191831c4e332b0235b057e3f1e952298abf34734a8fa2ee9bb7be382'
+ '89f65c581179582f178c1d60dbe9a702d7efb5b07f35442f03c9463af0c5b04d')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ## uncomment the following lines to avoid nameclash with same named binary in bsd-games package
+# mv doc/rot13.1 doc/trrot13.1
+# mv suser/rot13 suser/trrot13
+# patch -Np1 < "$srcdir/Rename_rot13_to_trrot13.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --libexecdir=/usr/lib --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+}
diff --git a/Rename_rot13_to_trrot13.patch b/Rename_rot13_to_trrot13.patch
new file mode 100644
index 000000000000..423b13689b06
--- /dev/null
+++ b/Rename_rot13_to_trrot13.patch
@@ -0,0 +1,107 @@
+From 3bc43fa346975130379b76b2b7882854f3d93763 Mon Sep 17 00:00:00 2001
+From: Marcel Huber <marcelhuberfoo@gmail.com>
+Date: Tue, 13 May 2014 22:54:53 +0200
+Subject: renaming rot13 to trrot13 to avoid nameclash with bsd-games package
+
+---
+ LICENSES.txt | 2 +-
+ doc/Makefile.am | 2 +-
+ doc/hxtools.7 | 2 +-
+ doc/trrot13.1 | 10 +++++-----
+ examples/437cipher | 2 +-
+ suser/Makefile.am | 2 +-
+ suser/trrot13 | 2 +-
+ 7 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/LICENSES.txt b/LICENSES.txt
+index a2698dd..524012b 100644
+--- a/LICENSES.txt
++++ b/LICENSES.txt
+@@ -61,7 +61,7 @@ suser/fxterm WTFPL-2.0+
+ suser/mailsplit WTFPL-2.0+
+ suser/pesubst WTFPL-2.0+
+ suser/qtar WTFPL-2.0+
+-suser/rot13 WTFPL-2.0+
++suser/trrot13 WTFPL-2.0+
+ suser/sysinfo GPL-2.0+
+ suser/tailhex GPL-2.0+
+ suser/wktimer GPL-2.0+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 8f7b5f7..b0591b1 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -44,7 +44,7 @@ dist_man_MANS = \
+ printcaps.8 \
+ psthreads.1 \
+ recursive_lower.1 \
+- rot13.1 \
++ trrot13.1 \
+ sourcefuncsize.1 \
+ spec-beautifier.1 \
+ ssa2srt.1 \
+diff --git a/doc/hxtools.7 b/doc/hxtools.7
+index 6dd3551..3ca42ed 100644
+--- a/doc/hxtools.7
++++ b/doc/hxtools.7
+@@ -129,7 +129,7 @@ display
+ .PP
+ \fBrecursive_lower\fP(1) \(en recursively lowercase all filenames
+ .PP
+-\fBrot13\fP(1) \(en shortcut to invoke tr(1) for ROT13
++\fBtrrot13\fP(1) \(en shortcut to invoke tr(1) for TRROT13
+ .PP
+ \fBrpmdep.pl\fP(1) \(en read RPM dependencies and output a graph
+ .PP
+diff --git a/doc/trrot13.1 b/doc/trrot13.1
+index 648fc1d..e9630da 100644
+--- a/doc/trrot13.1
++++ b/doc/trrot13.1
+@@ -1,15 +1,15 @@
+-.TH rot13 1 "2013-08-02" "hxtools" "hxtools"
++.TH trrot13 1 "2013-08-02" "hxtools" "hxtools"
+ .SH Name
+ .PP
+-rot13 \(em shortcut to tr(1) for ROT13
++trrot13 \(em shortcut to tr(1) for TRROT13
+ .SH Syntax
+ .PP
+-\fBrot13\fP [\fIfile\fP...]
++\fBtrrot13\fP [\fIfile\fP...]
+ .SH Description
+ .PP
+-ROT13 ("rotate by 13 places", sometimes hyphenated ROT-13) is a simple letter
++TRROT13 ("rotate by 13 places", sometimes hyphenated ROT-13) is a simple letter
+ substitution cipher that replaces a letter with the letter 13 letters after it
+ in the Latin alphabet.
+ .PP
+-rot13(1) will call out to tr(1) to do this substitution, and will read from
++trrot13(1) will call out to tr(1) to do this substitution, and will read from
+ standard input unless some filenames are given.
+diff --git a/suser/Makefile.am b/suser/Makefile.am
+index 50002a4..50012da 100644
+--- a/suser/Makefile.am
++++ b/suser/Makefile.am
+@@ -14,7 +14,7 @@ dist_bin_SCRIPTS = \
+ fduphl \
+ fxterm \
+ pesubst \
+- rot13 \
++ trrot13 \
+ qtar \
+ wktimer
+
+diff --git a/suser/trrot13 b/suser/trrot13
+index 6e41265..42be0da 100755
+--- a/suser/trrot13
++++ b/suser/trrot13
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ #
+-# do ROT13 substituion cipher
++# do TRROT13 substituion cipher
+ # written by Jan Engelhardt, 2013
+ #
+ # This program is free software; you can redistribute it and/or
+--
+1.9.2
+