summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2020-07-18 16:38:56 +0200
committerJoan Bruguera2020-07-18 16:38:56 +0200
commit4d08d251a4227b61eef3e3f66a73a631809bdd27 (patch)
tree602acf65fdb14b3a55637f3ebb301bce5621ae22
parent5926e9fcfb0bc75f029971dc752c5412c0134f51 (diff)
downloadaur-4d08d251a4227b61eef3e3f66a73a631809bdd27.tar.gz
Update to 2.6.12.20200718
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--python3-ports.patch32
3 files changed, 6 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e46847a0179f..1cb1aa9aa473 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tracking
pkgdesc = Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).
- pkgver = 2.6.11.20200316
+ pkgver = 2.6.12.20200718
pkgrel = 1
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
@@ -11,10 +11,8 @@ pkgbase = tracking
depends = python-pillow
depends = python-wxpython
depends = python-matplotlib
- source = https://ftp.tools.bsc.es/tracking/tracking-2.6.11-src.tar.bz2
- source = python3-ports.patch
- sha512sums = 9a9e4bda1d179511aa28bd9e08a8c7a61d6b54a1f392e948514926f54ddd35d7db4f4f39f0c0420cb016e7ff3a016785305a0a0aad4d35ace0ec8ceb129a2911
- sha512sums = 127d7a1989284ebfd8911090ce01e38fad7dbb12ceb307e73a6fb54dff09f9e0c99410376dce4a8e1e4308dc5c44e25218c929df6151b674b31a06e4e1075bfe
+ source = https://ftp.tools.bsc.es/tracking/tracking-2.6.12-src.tar.bz2
+ sha512sums = 7942b03025ed5506e320a22cbb80f6fee21395deae0317f12a3e8cb3400fb8324a2b39bfc29febb3b8544cd0378f414cc80bdaa826e5bb95d6480023d5c36dc1
pkgname = tracking
diff --git a/PKGBUILD b/PKGBUILD
index 33d8df91d9dc..12c27651dd72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,14 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='tracking'
pkgdesc='Analyze how the behavior of a parallel application evolves through different scenarios (from BSC).'
-pkgver='2.6.11.20200316'
+pkgver='2.6.12.20200718'
pkgrel='1'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('GPL2')
depends=(wxparaver clusteringsuite python-pillow python-wxpython python-matplotlib)
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
- python3-ports.patch)
-sha512sums=(9a9e4bda1d179511aa28bd9e08a8c7a61d6b54a1f392e948514926f54ddd35d7db4f4f39f0c0420cb016e7ff3a016785305a0a0aad4d35ace0ec8ceb129a2911
- 127d7a1989284ebfd8911090ce01e38fad7dbb12ceb307e73a6fb54dff09f9e0c99410376dce4a8e1e4308dc5c44e25218c929df6151b674b31a06e4e1075bfe)
-
-prepare() {
- cd "$srcdir/$pkgname-${pkgver%.*}"
-
- # WORKAROUND: Fix some scripts that still only work with Python 2
- patch -Np1 -i "$srcdir/python3-ports.patch"
-}
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2")
+sha512sums=(7942b03025ed5506e320a22cbb80f6fee21395deae0317f12a3e8cb3400fb8324a2b39bfc29febb3b8544cd0378f414cc80bdaa826e5bb95d6480023d5c36dc1)
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
diff --git a/python3-ports.patch b/python3-ports.patch
deleted file mode 100644
index 3f8b4d70c720..000000000000
--- a/python3-ports.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/src/scripts/scale-frames.py b/src/scripts/scale-frames.py
-index 38821eb..5f371e2 100755
---- a/src/scripts/scale-frames.py
-+++ b/src/scripts/scale-frames.py
-@@ -17,8 +17,8 @@ SuffixNormalizedCSV = ".norm"
-
- ### Prints help
- def PrintUsage():
-- print "SYNTAX"
-- print " " + sys.argv[0] + " [-s DIMENSION1,DIMENSION2...] TRACE1 TRACE2 ...\n"
-+ print("SYNTAX")
-+ print(" " + sys.argv[0] + " [-s DIMENSION1,DIMENSION2...] TRACE1 TRACE2 ...\n")
-
- if (len(sys.argv) < 2): # FIXME
- PrintUsage()
-@@ -75,14 +75,14 @@ while ((currentArg < len(sys.argv)) and (sys.argv[currentArg][0] == '-')):
- DimensionsToScale = [dim for dim in DimensionsToScale]
- else:
- PrintUsage()
-- print "*** INVALID PARAMETER "+sys.argv[currentArg];
-+ print("*** INVALID PARAMETER "+sys.argv[currentArg]);
- sys.exit(-1)
- currentArg = currentArg + 1
-
- ### 1 trace at least
- if (len(sys.argv) - currentArg < 1):
- PrintUsage()
-- print "*** Error: Pass 1 or more traces!"
-+ print("*** Error: Pass 1 or more traces!")
- sys.exit(-1)
-
- InputTraces = [] # array[ TRACE1, TRACE2 ... ]