summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-11-20 21:36:57 +0800
committeryjun2021-11-20 21:36:57 +0800
commit4d262b3c79c875ab5681cd8192d963e8a5f2815f (patch)
tree7dd852e625615860f50228fc88ae1b82fa59c812
parent81fec59b30bf7f4e2fd840a7ce6419fc3118e9cd (diff)
downloadaur-4d262b3c79c875ab5681cd8192d963e8a5f2815f.tar.gz
pkgbuild: fixed evil hardcode path in oray_rundaemon binary file
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD13
-rw-r--r--runsunloginclient.service6
-rw-r--r--sunloginclient.install1
5 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3beb0ac7aee5..bf0f127cd68d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sunloginclient
pkgdesc = Proprietary software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)
pkgver = 11.0.0.36662
- pkgrel = 2
+ pkgrel = 3
url = https://sunlogin.oray.com
install = sunloginclient.install
arch = x86_64
@@ -13,8 +13,7 @@ pkgbase = sunloginclient
source = runsunloginclient.service
source = LICENSE
sha256sums = 825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0
- sha256sums = 58942243be93d1e743fc42d9670e75a4f33f121faa3d6f2d44c95d73d1ead00c
- sha256sums = b3da0bda5ab0d4badb2cf7723dac95a9c5f5efb89f3d3f192d78728b064d0720
+ sha256sums = 7f36a60d84741d817a0d0804bd39c8c7d7058144a6934b2abf0841446f4a56de
+ sha256sums = SKIP
pkgname = sunloginclient
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..787a209c9e12
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zst
+pkg/
+src/
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
index b62f7b5bafd6..849124f6b4fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=sunloginclient
_pkgname=sunlogin
pkgver=11.0.0.36662
-pkgrel=2
+pkgrel=3
pkgdesc="Proprietary software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)"
arch=("x86_64")
url="https://sunlogin.oray.com"
@@ -17,8 +17,8 @@ source=("https://down.oray.com/${_pkgname}/linux/${pkgname}-${pkgver}-amd64.deb"
'LICENSE')
install="${pkgname}.install"
sha256sums=('825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0'
- '58942243be93d1e743fc42d9670e75a4f33f121faa3d6f2d44c95d73d1ead00c'
- 'b3da0bda5ab0d4badb2cf7723dac95a9c5f5efb89f3d3f192d78728b064d0720')
+ '7f36a60d84741d817a0d0804bd39c8c7d7058144a6934b2abf0841446f4a56de'
+ 'SKIP')
build() {
mkdir -p build
@@ -75,8 +75,11 @@ package() {
"${pkgdir}/opt/${_pkgname}/bin/${pkgname}"
sed -i "s#/usr/local/sunlogin/res/icon/%s.ico\x0#/opt/sunlogin/res/icon/%s.ico\x0\x0\x0\x0\x0\x0\x0#g" \
"${pkgdir}/opt/${_pkgname}/bin/${pkgname}"
- sed -i "s#/usr/local/sunlogin\x0#/opt/sunlogin\x0\x0\x0\x0\x0\x0\x0#g" \
- "${pkgdir}/opt/${_pkgname}/bin/oray_rundaemon"
+
+ # replace /usr/local with /opt
+ # prefix 0x48b8, suffix 0x4889, char count(?) 0x45d0
+ sed -i "s#\x48\xB8/usr/loc\x48\x89\x45\xD0\x48\xB8al#\x48\xB8///////o\x48\x89\x45\xD0\x48\xB8pt#g" \
+ "${pkgdir}/opt/${_pkgname}/bin/oray_rundaemon"
}
# vim: ts=2 sw=2 et:
diff --git a/runsunloginclient.service b/runsunloginclient.service
index 8aa8de872b28..ebe7240f564d 100644
--- a/runsunloginclient.service
+++ b/runsunloginclient.service
@@ -3,14 +3,10 @@ Description=check running sunloginclinet loop
Requires=network-online.target
After=network-online.target
-
[Service]
Type=simple
-ExecStart=sh -c '/opt/sunlogin/bin/oray_rundaemon -m server >/dev/null 2>&1 & /opt/sunlogin/bin/sunloginclient -m service'
+ExecStart=/opt/sunlogin/bin/oray_rundaemon -m server
ExecStop=
-Restart=always
-RestartSec=0
-
[Install]
WantedBy=multi-user.target
diff --git a/sunloginclient.install b/sunloginclient.install
index 7b93ac7d6dde..d78f52b4bd50 100644
--- a/sunloginclient.install
+++ b/sunloginclient.install
@@ -2,6 +2,7 @@ post_install() {
if systemctl -q is-active runsunloginclient.service ;then
systemctl daemon-reload
systemctl restart runsunloginclient.service
+ echo "restart runsunloginclient.service."
fi
ECHOLEN=$(echo -e|awk '{print length($0)}')