summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToolybird2023-06-26 11:36:10 +1000
committerToolybird2023-06-26 11:36:10 +1000
commit4d28dd6e14e4c77e11d7447e3c91e2217314be84 (patch)
treef8d5f65b4512d0889b6e02dd29a93c7776692fdc
parent2240973f63d522c0af64d813cba784921d8f4a21 (diff)
downloadaur-4d28dd6e14e4c77e11d7447e3c91e2217314be84.tar.gz
Upgrade to 1.0.93 and apply fixes
- tweak comments for dietlibc and exfat - adjust a sed "fix up" to account for upstream fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95a8adb9a43f..7af47960ccd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ventoy
pkgdesc = A new bootable USB solution
- pkgver = 1.0.91
+ pkgver = 1.0.93
pkgrel = 1
url = https://www.ventoy.net/
arch = x86_64
@@ -42,7 +42,7 @@ pkgbase = ventoy
noextract = cryptsetup-1.7.5.tar.xz
noextract = wimboot-2.7.3.tar.gz
options = !buildflags
- source = ventoy-1.0.91.tar.gz::https://github.com/ventoy/Ventoy/archive/refs/tags/v1.0.91.tar.gz
+ source = ventoy-1.0.93.tar.gz::https://github.com/ventoy/Ventoy/archive/refs/tags/v1.0.93.tar.gz
source = https://ftp.gnu.org/gnu/grub/grub-2.04.tar.xz
source = ventoy-grub-fix-build-with-binutils-2.36.patch::https://git.savannah.gnu.org/cgit/grub.git/patch/configure.ac?id=b9827513
source = git+https://github.com/ipxe/ipxe.git#commit=3fe683e
@@ -63,7 +63,7 @@ pkgbase = ventoy
source = https://busybox.net/downloads/busybox-1.32.0.tar.bz2
source = https://mirrors.edge.kernel.org/pub/linux/utils/cryptsetup/v1.7/cryptsetup-1.7.5.tar.xz
source = wimboot-2.7.3.tar.gz::https://github.com/ipxe/wimboot/archive/v2.7.3.tar.gz
- sha256sums = f807e417fab6f7a97a91c45c21d5456aac2ceb6c20f494ba7f0a83b91e25811d
+ sha256sums = e0ebe7e49ce778c35533f682ffc5428f1cfd713349d07f821beb1001776a60c7
sha256sums = e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d
sha256sums = db2a9018392a3984d1e1e649bde0ffc19c90fa4d96b9fd2d4caaf9c1ca2af68b
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7fe7e0bd0e6c..48b772df9897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,16 +33,16 @@
# have been modified.
pkgname=ventoy
-pkgver=1.0.91
+pkgver=1.0.93
_grub_ver=2.04 # (Jul 2019)
#_unifont_ver=15.0.01 # FIXME see NOTE below
_ipxe_ver=3fe683e # (Sep 29 2019)
_edk2_ver=stable201911 # (Dec 2019)
-_diet_ver=0.34 # FIXME repo pkg needs a patch, see below, build our own (64/32)
+_diet_ver=0.34 # FIXME AUR pkg needs a patch, see below, build our own (64/32)
_musl_ver=1.2.4 # upstream uses 1.2.1, use repo for 64-bit, build our own 32-bit
_kern_hdrs_musl_ver=4.19.88 # for busybox 32-bit
_fuse_ver=2.9.9 # need a static lib built against musl, build our own (64/32)
-_exfat_ver=1.3.0 # see comments below for why we build our own
+_exfat_ver=1.3.0 # (Sep 2018) old! FIXME see comments below for why we build our own
_lz4_ver=1.8.1.2 # (Jan 2018) old! FIXME statically linked into unsquashfs
_xz_ver=5.0.4 # (Jun 2012) old! FIXME statically linked into unsquashfs
_lzo_ver=2.08 # (Jun 2014) old! FIXME statically linked into unsquashfs
@@ -127,7 +127,7 @@ noextract=(
cryptsetup-"$_crypt_ver".tar.xz
wimboot-"$_wimboot_ver".tar.gz
)
-sha256sums=('f807e417fab6f7a97a91c45c21d5456aac2ceb6c20f494ba7f0a83b91e25811d'
+sha256sums=('e0ebe7e49ce778c35533f682ffc5428f1cfd713349d07f821beb1001776a60c7'
'e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d'
'db2a9018392a3984d1e1e649bde0ffc19c90fa4d96b9fd2d4caaf9c1ca2af68b'
'SKIP'
@@ -1205,8 +1205,7 @@ _create_img() (
-e '/^echo.*2D/s|^|test -w /var/log \&\& |' \
-e '/^date/s|^|test -w /var/log \&\& |' -i "$tmpdir"/Ventoy2Disk.sh
- sed -e 's|#!/bin/sh|#!/usr/bin/env bash|' \
- -e 's|\^ \\-s,|\^ -s,|' -i "$tmpdir"/tool/{VentoyWorker.sh,ventoy_lib.sh}
+ sed -e 's|#!/bin/sh|#!/usr/bin/env bash|' -i "$tmpdir"/tool/{VentoyWorker.sh,ventoy_lib.sh}
)
build() {