summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYorick Peterse2023-05-19 18:16:10 +0200
committerYorick Peterse2023-05-19 18:17:13 +0200
commit4d317466504a2b628950ebaa4776956c6fb37bb4 (patch)
tree2ee9623848bc4f2efc5224519ec1716d74252541
parentb4381bf6622bbb10160241b46540f0b700a3ca36 (diff)
downloadaur-4d317466504a2b628950ebaa4776956c6fb37bb4.tar.gz
Release v0.10.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce476af8a56d..3f544daab4da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = inko
pkgdesc = A language for building concurrent software with confidence
- pkgver = 0.10.0
+ pkgver = 0.11.0
pkgrel = 1
url = https://inko-lang.org
arch = x86_64
license = MPL2
- makedepends = rust>=1.62
+ makedepends = rust>=1.63
makedepends = make
- depends = libffi>=3.2.0
+ depends = llvm>=15.0.0
+ depends = llvm<=16.0.0
+ depends = git
+ depends = base-devel
provides = inko
conflicts = inko-git
options = strip
options = !docs
options = !libtool
options = !staticlibs
- source = https://releases.inko-lang.org/0.10.0.tar.gz
- sha256sums = d38e13532a71290386164246ac8cf7efb884131716dba6553b66a170dd3a2796
+ source = https://releases.inko-lang.org/0.11.0.tar.gz
+ sha256sums = fd1b492d0fc4d0e4930e3b3a547957ccb01898306797b1a1afbc4512eb045566
pkgname = inko
diff --git a/PKGBUILD b/PKGBUILD
index 739c47dc6905..a8dd759e6d6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: Yorick Peterse <aur AT yorickpeterse DOT com>
pkgname=inko
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
-pkgdesc="A statically-typed object-oriented language for writing concurrent programs"
-pkgdesc="A language for building concurrent software with confidence"
+pkgdesc="A language for building concurrent software with confidence "
url="https://inko-lang.org"
license=(MPL2)
arch=(x86_64)
-depends=('libffi>=3.2.0')
-makedepends=('rust>=1.62' make)
+depends=('llvm>=15.0.0' 'llvm<=16.0.0' git base-devel)
+makedepends=('rust>=1.63' make)
provides=(inko)
conflicts=(inko-git)
options=(strip !docs !libtool !staticlibs)
source=("https://releases.inko-lang.org/${pkgver}.tar.gz")
-sha256sums=('d38e13532a71290386164246ac8cf7efb884131716dba6553b66a170dd3a2796')
+sha256sums=('fd1b492d0fc4d0e4930e3b3a547957ccb01898306797b1a1afbc4512eb045566')
build() {
- # Enable the libffi-system feature so the system libffi is used, instead of
- # compiling it from source.
- make build FEATURES='libffi-system' PREFIX='/usr'
+ make build PREFIX='/usr'
}
package() {