summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2022-12-08 11:50:27 -0300
committerGonzalo Exequiel Pedone2022-12-08 11:50:27 -0300
commit4d417172f34e2869257cc4967540f2fd570ec2aa (patch)
treecff0c226c712e955aef2fe5167315547e38ced8c
parent77376c4a8209aa0b87c7e455b3c045a9e2fbd0d0 (diff)
downloadaur-4d417172f34e2869257cc4967540f2fd570ec2aa.tar.gz
Package updated to 1.2.13.
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Disable-versioning.patch37
-rw-r--r--PKGBUILD8
3 files changed, 28 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e5e2e889486..1084b024a53f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-64-zlib
pkgdesc = A compression/decompression Library (android)
- pkgver = 1.2.12
- pkgrel = 2
+ pkgver = 1.2.13
+ pkgrel = 1
url = http://www.zlib.net/
arch = any
license = custom:zlib
@@ -12,11 +12,11 @@ pkgbase = android-x86-64-zlib
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://zlib.net/zlib-1.2.12.tar.gz
+ source = http://zlib.net/zlib-1.2.13.tar.gz
source = 0001-Disable-versioning.patch
source = 0002-Fix-CC-definition.patch
- md5sums = 5fc414a9726be31427b440b434d05f78
- md5sums = 3e04fe1f84d547ea0ca318463e319ab7
+ md5sums = 9b8aa094c4e5765dabf4da391f00d15c
+ md5sums = c2d3fe1aba79ec3e75758b2f6478c980
md5sums = 2420be2579d725c1cf1e0aac7ae0a4fe
pkgname = android-x86-64-zlib
diff --git a/0001-Disable-versioning.patch b/0001-Disable-versioning.patch
index 60484470923e..0f76ef0f86f7 100644
--- a/0001-Disable-versioning.patch
+++ b/0001-Disable-versioning.patch
@@ -1,15 +1,15 @@
---- a/configure 2016-12-31 15:06:40.000000000 -0300
-+++ b/configure 2019-08-28 21:22:28.163601086 -0300
-@@ -208,7 +208,7 @@
- fi
- case "$uname" in
- Linux* | linux* | GNU | GNU/* | solaris*)
+--- a/configure 2022-10-13 02:06:55.000000000 -0300
++++ b/configure 2022-12-08 11:28:29.904045283 -0300
+@@ -227,7 +227,7 @@
+ *sparc*)
+ LDFLAGS="${LDFLAGS} -Wl,--no-warn-rwx-segments" ;;
+ esac
- LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so.1,--version-script,${SRCDIR}zlib.map"} ;;
+ LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so,--version-script,${SRCDIR}zlib.map"} ;;
*BSD | *bsd* | DragonFly)
LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so.1,--version-script,${SRCDIR}zlib.map"}
LDCONFIG="ldconfig -m" ;;
-@@ -346,8 +346,8 @@
+@@ -366,8 +366,8 @@
# destination names for shared library if not defined above
SHAREDLIB=${SHAREDLIB-"libz$shared_ext"}
@@ -20,18 +20,19 @@
echo >> configure.log
---- a/Makefile.in 2017-01-15 14:29:40.000000000 -0300
-+++ b/Makefile.in 2019-08-28 21:11:14.868386244 -0300
-@@ -34,7 +34,7 @@
+
+--- a/Makefile.in 2022-10-13 02:06:55.000000000 -0300
++++ b/Makefile.in 2022-12-08 11:28:29.904045283 -0300
+@@ -30,7 +30,7 @@
SHAREDLIB=libz.so
- SHAREDLIBV=libz.so.1.2.11
+ SHAREDLIBV=libz.so.1.2.13
SHAREDLIBM=libz.so.1
-LIBS=$(STATICLIB) $(SHAREDLIBV)
+LIBS=$(STATICLIB) $(SHAREDLIB)
AR=ar
ARFLAGS=rc
-@@ -278,11 +278,8 @@
+@@ -274,11 +274,8 @@
-@mv objs/gzwrite.o $@
@@ -44,23 +45,23 @@
-@rmdir objs
example$(EXE): example.o $(STATICLIB)
-@@ -291,11 +288,11 @@
+@@ -287,11 +284,11 @@
minigzip$(EXE): minigzip.o $(STATICLIB)
$(CC) $(CFLAGS) -o $@ minigzip.o $(TEST_LDFLAGS)
-examplesh$(EXE): example.o $(SHAREDLIBV)
-- $(CC) $(CFLAGS) -o $@ example.o -L. $(SHAREDLIBV)
+- $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS) -L. $(SHAREDLIBV)
+examplesh$(EXE): example.o $(SHAREDLIB)
-+ $(CC) $(CFLAGS) -o $@ example.o -L. $(SHAREDLIB)
++ $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS) -L. $(SHAREDLIB)
-minigzipsh$(EXE): minigzip.o $(SHAREDLIBV)
-- $(CC) $(CFLAGS) -o $@ minigzip.o -L. $(SHAREDLIBV)
+- $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS) -L. $(SHAREDLIBV)
+minigzipsh$(EXE): minigzip.o $(SHAREDLIB)
-+ $(CC) $(CFLAGS) -o $@ minigzip.o -L. $(SHAREDLIB)
++ $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS) -L. $(SHAREDLIB)
example64$(EXE): example64.o $(STATICLIB)
$(CC) $(CFLAGS) -o $@ example64.o $(TEST_LDFLAGS)
-@@ -313,15 +310,12 @@
+@@ -309,15 +306,12 @@
cp $(STATICLIB) $(DESTDIR)$(libdir)
chmod 644 $(DESTDIR)$(libdir)/$(STATICLIB)
-@($(RANLIB) $(DESTDIR)$(libdir)/libz.a || true) >/dev/null 2>&1
diff --git a/PKGBUILD b/PKGBUILD
index 423e98331f43..147ac90f55c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_android_arch=x86-64
pkgname=android-${_android_arch}-zlib
-pkgver=1.2.12
-pkgrel=2
+pkgver=1.2.13
+pkgrel=1
pkgdesc="A compression/decompression Library (android)"
arch=('any')
url="http://www.zlib.net/"
@@ -15,8 +15,8 @@ makedepends=('android-environment' 'android-pkg-config')
source=("http://zlib.net/zlib-${pkgver}.tar.gz"
"0001-Disable-versioning.patch"
"0002-Fix-CC-definition.patch")
-md5sums=('5fc414a9726be31427b440b434d05f78'
- '3e04fe1f84d547ea0ca318463e319ab7'
+md5sums=('9b8aa094c4e5765dabf4da391f00d15c'
+ 'c2d3fe1aba79ec3e75758b2f6478c980'
'2420be2579d725c1cf1e0aac7ae0a4fe')
prepare() {