summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2017-10-14 15:06:59 +0200
committerGilrain2017-10-14 15:06:59 +0200
commit4d53fc5e11c0870dbb8dd17a585d79b527f5242c (patch)
tree9038205443cdbc1b904a112905f26e75ac31c6a9
parentc1b347eb1610cee3b84878d4fe7fdf707e54921b (diff)
downloadaur-4d53fc5e11c0870dbb8dd17a585d79b527f5242c.tar.gz
Update to 3.0.3.0-1
-rw-r--r--.SRCINFO25
-rw-r--r--NLog.config12
-rw-r--r--PKGBUILD48
-rw-r--r--asf-config.sh2
-rw-r--r--asf-user.service3
-rw-r--r--asf.install12
-rw-r--r--asf.service4
-rwxr-xr-xasf.sh2
-rw-r--r--changelog65
9 files changed, 117 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e71e6f89da53..bdfb1dd2dd0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,30 @@
# Generated by mksrcinfo v8
-# Mon Jul 10 12:08:34 UTC 2017
+# Sat Oct 14 07:03:12 UTC 2017
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 2.3.2.0
- pkgrel = 2
+ pkgver = 3.0.3.0
+ pkgrel = 1
url = https://github.com/JustArchi/ArchiSteamFarm
install = asf.install
changelog = changelog
arch = any
license = Apache
- depends = mono>=4.8
- backup = opt/asf/config/ASF.json
+ makedepends = p7zip
+ depends = dotnet-sdk-2.0
+ noextract = asf-3.0.3.0.zip
backup = var/lib/asf/config/ASF.json
- source = https://github.com/JustArchi/ArchiSteamFarm/releases/download/2.3.2.0/ASF.zip
+ source = asf-3.0.3.0.zip::https://github.com/JustArchi/ArchiSteamFarm/releases/download/3.0.3.0/ASF-generic.zip
source = asf.sh
- source = asf-config.sh
source = asf.service
source = asf-user.service
source = asf.sysusers
- sha256sums = 1a9f50c3cf2eb00e5148bc21a209b0c7c275b6c36c8cae8b4d9b2469bee7ff33
- sha256sums = a5d0324c029efb1f99264e787fea26ad53953b4df59bf642bca1ffabad4027f5
- sha256sums = 63b8d4718e8cc61016ef415ff418e6180102b077315f5ce77bfcab9c03433565
- sha256sums = 183d7c2f93ca8ca95e00523c4920275e52ad83d049af95610b7cc0672983421c
- sha256sums = 1948780515929c7fc8ffa6033bc79a55cbae375a1397326ef9dba0dfbe91cc56
+ source = NLog.config
+ sha256sums = 8d3ed5d970a4fd2736f738cdec6428d7585223a2ed0d2bce5b5fa1376538cf9c
+ sha256sums = 8d76996c1024b80704b25af8a8800ef3f8a8a518d19c2a1e85ba62b58b22cdfd
+ sha256sums = e63b55f65e1c0c935945bd788f47a77be82e96a409b64660b5a96b9c190964ff
+ sha256sums = dcaf43586125e07488e338438158097b31ba335fcb238127dfb785a41d223f49
sha256sums = 883373be23f6f49ae597f61c1310d8cd45bce7c3ee1b5d456ffc9fedbe7dd486
+ sha256sums = cd2c704c01217c103f8ad1729920a142f63f686351c6a9557c50a33fb3c723fe
pkgname = asf
diff --git a/NLog.config b/NLog.config
new file mode 100644
index 000000000000..b6cdc5304624
--- /dev/null
+++ b/NLog.config
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="utf-8" ?>
+<nlog xmlns="http://www.nlog-project.org/schemas/NLog.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <targets>
+ <target xsi:type="ColoredConsole" name="ColoredConsole" detectConsoleAvailable="false" layout="${date:format=yyyy-MM-dd HH\:mm\:ss}|${processname}-${processid}|${level:uppercase=true}|${logger}|${message}${onexception:inner= ${exception:format=toString,Data}}" />
+ <target xsi:type="File" name="File" deleteOldFileOnStartup="true" fileName="/var/log/asf.log" layout="${date:format=yyyy-MM-dd HH\:mm\:ss}|${processname}-${processid}|${level:uppercase=true}|${logger}|${message}${onexception:inner= ${exception:format=toString,Data}}" />
+ </targets>
+
+ <rules>
+ <logger name="*" minlevel="Debug" writeTo="ColoredConsole" />
+ <logger name="*" minlevel="Debug" writeTo="File" />
+ </rules>
+</nlog>
diff --git a/PKGBUILD b/PKGBUILD
index 81afe9b85874..9b41e0be569e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,52 @@
# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname="asf"
-pkgver="2.3.2.0"
-pkgrel=2
+pkgver="3.0.3.0"
+pkgrel=1
pkgdesc="Steam cards farmer."
arch=('any')
url="https://github.com/JustArchi/ArchiSteamFarm"
license=('Apache')
-depends=('mono>=4.8')
+depends=('dotnet-sdk-2.0')
+makedepends=('p7zip')
changelog=changelog
-backup=('opt/asf/config/ASF.json' 'var/lib/asf/config/ASF.json')
+backup=('var/lib/asf/config/ASF.json')
install=${pkgname}.install
-source=("https://github.com/JustArchi/ArchiSteamFarm/releases/download/${pkgver}/ASF.zip"
+source=("${pkgname}-${pkgver}.zip::https://github.com/JustArchi/ArchiSteamFarm/releases/download/${pkgver}/ASF-generic.zip"
"${pkgname}.sh"
- "${pkgname}-config.sh"
"${pkgname}.service"
"${pkgname}-user.service"
- "${pkgname}.sysusers")
-sha256sums=('1a9f50c3cf2eb00e5148bc21a209b0c7c275b6c36c8cae8b4d9b2469bee7ff33'
- 'a5d0324c029efb1f99264e787fea26ad53953b4df59bf642bca1ffabad4027f5'
- '63b8d4718e8cc61016ef415ff418e6180102b077315f5ce77bfcab9c03433565'
- '183d7c2f93ca8ca95e00523c4920275e52ad83d049af95610b7cc0672983421c'
- '1948780515929c7fc8ffa6033bc79a55cbae375a1397326ef9dba0dfbe91cc56'
- '883373be23f6f49ae597f61c1310d8cd45bce7c3ee1b5d456ffc9fedbe7dd486')
+ "${pkgname}.sysusers"
+ "NLog.config")
+sha256sums=('8d3ed5d970a4fd2736f738cdec6428d7585223a2ed0d2bce5b5fa1376538cf9c'
+ '8d76996c1024b80704b25af8a8800ef3f8a8a518d19c2a1e85ba62b58b22cdfd'
+ 'e63b55f65e1c0c935945bd788f47a77be82e96a409b64660b5a96b9c190964ff'
+ 'dcaf43586125e07488e338438158097b31ba335fcb238127dfb785a41d223f49'
+ '883373be23f6f49ae597f61c1310d8cd45bce7c3ee1b5d456ffc9fedbe7dd486'
+ 'cd2c704c01217c103f8ad1729920a142f63f686351c6a9557c50a33fb3c723fe')
+noextract=('asf-3.0.3.0.zip')
+
+prepare() {
+ 7z x -o"${srcdir}/asf" ${pkgname}-${pkgver}.zip
+}
package() {
- install -d -m 755 "${pkgdir}/opt/${pkgname}"
+ install -d -m 755 "${pkgdir}/usr/lib/${pkgname}"
+ cp -rdp --no-preserve=ownership "${srcdir}/asf" "${pkgdir}/usr/lib"
+ find "${pkgdir}/usr/lib/${pkgname}" -type f -exec chmod 644 {} \;
+ find "${pkgdir}/usr/lib/${pkgname}" -type d -exec chmod 755 {} \;
+
install -d -m 755 "${pkgdir}/var/lib/${pkgname}/config"
- cp -dp --no-preserve=ownership *.exe "${pkgdir}/opt/${pkgname}"
- cp -dp --no-preserve=ownership config/* "${pkgdir}/var/lib/${pkgname}/config"
+ mv "${pkgdir}/usr/lib/${pkgname}/config" "${pkgdir}/var/lib/${pkgname}"
+ ln -sf "/var/lib/${pkgname}/config" "${pkgdir}/usr/lib/${pkgname}/config"
install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m755 "${srcdir}/${pkgname}-config.sh" "${pkgdir}/usr/bin/${pkgname}-config"
install -D -m644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -D -m644 "${srcdir}/${pkgname}-user.service" "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
install -D -m644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -D -m644 "${srcdir}/NLog.config" "${pkgdir}/usr/lib/${pkgname}/NLog.config"
# disable auto-updates and version checks
- sed -i 's/"AutoUpdates": true,/"AutoUpdates": false,/g' ${pkgdir}/var/lib/${pkgname}/config/ASF.json
- sed -i 's/"UpdateChannel": 1,/"UpdateChannel": 0,/g' ${pkgdir}/var/lib/${pkgname}/config/ASF.json
+ sed -i 's/"AutoUpdates": true,/"AutoUpdates": false,/g' "${pkgdir}/var/lib/${pkgname}/config/ASF.json"
+ sed -i 's/"UpdateChannel": 1/"UpdateChannel": 0/g' "${pkgdir}/var/lib/${pkgname}/config/ASF.json"
}
diff --git a/asf-config.sh b/asf-config.sh
deleted file mode 100644
index 80a6b56140b7..000000000000
--- a/asf-config.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec mono /opt/asf/ASF-ConfigGenerator.exe "$@"
diff --git a/asf-user.service b/asf-user.service
index f58efcefd117..bd1349985f6e 100644
--- a/asf-user.service
+++ b/asf-user.service
@@ -1,10 +1,11 @@
[Unit]
Description=ArchiSteamFarm User Service
Documentation=https://github.com/JustArchi/ArchiSteamFarm/wiki
+Documentation=https://justarchi.github.io/ArchiSteamFarm/
Wants=network.target
[Service]
-ExecStart=/usr/bin/asf --server --path=%h/.config/asf
+ExecStart=/usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll --server --path=%h/.config/asf
[Install]
WantedBy=default.target
diff --git a/asf.install b/asf.install
index dcbc7358fff8..f7b7b2f60c38 100644
--- a/asf.install
+++ b/asf.install
@@ -5,16 +5,4 @@ post_install() {
post_upgrade() {
post_install $1
- if [ "$(vercmp $2 2.1.3.1-2)" -lt 0 ] && [ grep -q "^asf:" /etc/passwd 2> /dev/null]; then
- usermod -s /bin/false -c "ArchiSteamFarm daemon" -d /var/lib/asf -g asf asf &> /dev/null
- fi
- if [ "$(vercmp $2 2.1.3.1-2)" -lt 0 ] && [ -d /opt/asf/config ]; then
- mv /opt/asf/config/ /var/lib/asf/
- mv /opt/asf/log.txt /var/lib/asf/
-
- chown -R asf: /var/lib/asf
-
- echo "# ASF config folder has been moved to /var/lib/asf"
- echo "# Consider this change when using /usr/bin/asf (e.g. 'asf --path=/var/lib/asf')"
- fi
}
diff --git a/asf.service b/asf.service
index 52fbf6e5a157..11372d59f84a 100644
--- a/asf.service
+++ b/asf.service
@@ -1,15 +1,17 @@
[Unit]
Description=ArchiSteamFarm Service
Documentation=https://github.com/JustArchi/ArchiSteamFarm/wiki
+Documentation=https://justarchi.github.io/ArchiSteamFarm/
Wants=network.target
After=network.target
[Service]
User=asf
Group=asf
-ExecStart=/usr/bin/mono /opt/asf/ASF.exe --server --path=/var/lib/asf
+ExecStart=/usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll --server --path=/var/lib/asf
ProtectSystem=true
ReadWritePaths=/var/lib/asf
+ReadWritePaths=/var/log/asf.log
[Install]
WantedBy=multi-user.target
diff --git a/asf.sh b/asf.sh
index 5a81feb7b880..d87346b94827 100755
--- a/asf.sh
+++ b/asf.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec mono /opt/asf/ASF.exe "$@"
+exec /usr/bin/dotnet /usr/lib/asf/ArchiSteamFarm.dll "$@"
diff --git a/changelog b/changelog
index 6cee5a2c06f4..bf09acbb4d4f 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,52 @@
+2017-10-11 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 3.0.3.0-1:
+ [!] Fixed wrong SteamTradeMatcher dupes logic (ref: #657).
+ ASF Windows variant now includes (once again) proper icon. Other variants might make use of ArchiSteamFarm.ico that is now added to the release.
+ Patched up WebSocket SteamProtocols option not working correctly on Windows 7 SP1.
+ IPC will now follow standard alphabetical bot sorting order when used without target bot instance.
+ Usual amount of code improvements, optimizations and bugfixes.
+ package: refactored for v3
+ package: default logging now done in /var/log/asf.log
+ package: removed legacy config migration
+ * 3.0.2.8:
+ Extra out-of-range command arguments are now joined into the last one.
+ ASF Trace logging will now also log echo messages (ref: #653).
+ * 3.0.2.7:
+ * 3.0.1.9:
+ Fixed a small regression introduced in 3.0.1.8 that could cause infinite relogin if GamesPlayedWhileIdle was enabled (ref: #623)
+ Fixed ASF not always (re)starting farming after getting disconnected.
+ Decreased default ASF memory usage by re-enabling old workstation GC, visit high-performance setup if you'd like to keep using server GC.
+ Misc code improvements, optimizations and bugfixes.
+ * 3.0.1.8:
+ Fixed a small regression introduced in 3.0.1.5 that caused GamesPlayedWhileIdle and CustomGamePlayedWhileIdle not always being triggered.
+ Improved reliability of CustomGamePlayed* display order.
+ Improved reliability of having IdleRefundableGames disabled.
+ Misc code improvements, optimizations and bugfixes.
+ * 3.0.1.6:
+ [!] ASF now runs on .NET Core, see V3 migration. You might be also interested in updated wiki sections, such as compatibility.
+ Added support for automatic Steam discovery queue, AutoDiscoveryQueue bot configuration property (ref: #580).
+ Removed !redeem^ and !redeem& commands. Re-added !redeem^ command that requires redeeming mode now (ref: #542).
+ Removed WCFHost, WCFPort and WCFBinding global configuration properties.
+ Added BackgroundGCPeriod, IPCHost and IPCPort global configuration properties.
+ Added MatchableTypes bot configuration property.
+ Added IdleRefundableGames bot configuration property (ref: #522).
+ Added Random, RedeemDateTimesAscending and RedeemDateTimesDescending to FarmingOrder bot configuration property.
+ Added BadgeLevelsAscending and BadgeLevelsDescending to FarmingOrder bot configuration property (ref: #510).
+ Added Double Fine Adventure (402590) to global blacklist.
+ Added !iq, !iqadd and !iqrm commands (ref: #545).
+ Added !pause& command (ref: #509).
+ Added !unpack command (ref: #537)
+ Added !transfer command (ref: #609)
+ Fixed ASF not aborting farming in Complex mode when getting disconnected from Steam network.
+ Fixed ASF sending multiple trades instead of one when multiple events arrive (ref: #583).
+ Fixed ASF attempting to initialize ASF 2FA time without network connectivity (ref: #598).
+ Greatly improved ASF logic as in when to check badge pages (no more useless checks after games switching)
+ Increased default value of IdleFarmingPeriod global configuration property from 3 to 8.
+ GiftsLimiterDelay will now also apply to !redeem, !owns and !addlicense requests (ref: #577).
+ Forwarding RedeemingPreferences will now also respect SteamUserPermissions.
+ ASF will now automatically include your trading token and MatchableTypes if you participate in our public listing.
+ !owns command will now also state extra owned bots count (ref: #564).
+ Gigantic amount of code improvements, optimizations and bugfixes.
2017-07-10 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 2.3.2.0-2:
package: solved a bug in systemd-sysusers by removing an empty line
@@ -40,20 +89,20 @@
Major code improvements, optimizations and bugfixes.
2017-03-29 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 2.3.0.5-1:
- [!] Reworked permissions, this is a breaking change [1].
- [!] Changed behaviour of !api command, this is a breaking change [2].
+ [!] Reworked permissions, this is a breaking change.
+ [!] Changed behaviour of !api command, this is a breaking change.
Added !api <Bots> command (ref: #485).
Added !nickname command.
- Added extra workaround for invalidating old trades [3].
+ Added extra workaround for invalidating old trades.
Fixed ASF compilation on OS X, also added OS X as a test platform to our Travis CI.
Fixed ASF being able to trigger a rare Steam glitch that could lead to change of bot's nickname to [unassigned] when FarmOffline is set to false.
Fixed recent Steam breaking change introduced by Valve that broke discovering of keys being redeemed in all ASF versions prior to 2.3.0.4 (ref: #508).
- ASF release is now compiled with latest Visual Studio 2017 by our AppVeyor CI (previously: VS15) [4].
+ ASF release is now compiled with latest Visual Studio 2017 by our AppVeyor CI (previously: VS15).
Major code improvements, optimizations and bugfixes.
2017-03-04 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 2.2.3.2-1:
[!] ASF is now smart enough to automatically choose proper appID for "Series" (video) apps with trading cards in them. Previously it'd be stuck farming wrong game (ref: #473).
- From now on running ASF will prevent Windows OS from going to sleep (ref: #457) [1].
+ From now on running ASF will prevent Windows OS from going to sleep (ref: #457).
Added extra logic for handling locked/disabled accounts (ref: #469).
Added KeepMissingGames to RedeemingPreferences bot config property (ref: #470).
Added back metadata publishing to all WCF bindings (ref: #448).
@@ -64,10 +113,10 @@
Fixed SendTradePeriod not working properly.
Fixed NLog issue that could lead to ASF crash when run via Mono in systemd environment without custom NLog.config (ref: #292).
Fixed WCF refusing to handle too large !api responses.
- Updated statistics and privacy policy (ref: #450) [2].
+ Updated statistics and privacy policy (ref: #450).
Updated internal SteamKit2 code, this results in some misc changes of !redeem statuses. I took the opportunity and documented them in the FAQ while I was at it.
Further unified ASF commands by adding bot identifier to all of them (ref: #468).
- Removed AcceptConfirmationsPeriod [3].
+ Removed AcceptConfirmationsPeriod.
Removed default entries in Blacklist global config property, since they're defined in hardcoded ASF GlobalBlacklist already.
ASF will no longer accept SteamTradeMatcher trades without MatchEverything, if we can't fetch our inventory during parsing the trade.
Major code improvements, optimizations and bugfixes.
@@ -196,7 +245,7 @@
[ConfigGenerator] Properties are now being categorized for easier modifications.
2016-08-05 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 2.1.3.9-1:
- [!] Important ForwardKeysToOtherBots enhancements [1].
+ [!] Important ForwardKeysToOtherBots enhancements.
[!] CardDropsRestricted is now true by default.
Added new FarmingOrder bot config property, thanks to @stackia in #312 . Visit wiki for more info.
WCF now supports metadata publishing, thanks to @stackia in #309