summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Bazile2019-11-28 21:54:02 +0100
committerRomain Bazile2019-11-28 21:54:02 +0100
commit4d67fa69f08ec48eee035a481b26e13795f7693a (patch)
tree28f99f1fe5a4761d14e8e8bfaf18256376f92979
parent32d45ecbff1c3bcf4f82a43086a84b9ff0d4b6d8 (diff)
downloadaur-4d67fa69f08ec48eee035a481b26e13795f7693a.tar.gz
addition of install and version correction
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--xygrib.install15
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71611620288c..827f4adb6c32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xygrib-git
pkgdesc = Grib reader and weather visualization software. Zygrib fork.
pkgver = 1.2.6.1.r74.ga47fee3
- pkgrel = 1
+ pkgrel = 2
url = https://opengribs.org/
arch = x86_64
arch = aarch64
@@ -18,7 +18,9 @@ pkgbase = xygrib-git
provides = xygrib
conflicts = xygrib
source = xygrib-git::git+https://github.com/opengribs/XyGrib.git
+ source = xygrib.install
sha1sums = SKIP
+ sha1sums = 58925746bf6ac941ab34e268517581f1e01e9cff
pkgname = xygrib-git
diff --git a/PKGBUILD b/PKGBUILD
index 5bb7d6163cdb..7831086ab8a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xygrib-git
pkgver=1.2.6.1.r74.ga47fee3
-pkgrel=1
+pkgrel=2
pkgdesc="Grib reader and weather visualization software. Zygrib fork."
arch=('x86_64' 'aarch64')
license=("GPL3")
@@ -13,8 +13,9 @@ provides=('xygrib')
depends=('libnova' 'qwt' 'proj' 'qt5-base' 'openjpeg2')
makedepends=('cmake' 'zlib' 'bzip2' 'libpng')
url="https://opengribs.org/"
-source=("$pkgname::git+https://github.com/opengribs/XyGrib.git")
-sha1sums=('SKIP')
+source=("$pkgname::git+https://github.com/opengribs/XyGrib.git" "xygrib.install")
+sha1sums=('SKIP'
+ '58925746bf6ac941ab34e268517581f1e01e9cff')
pkgver() {
cd $pkgname
@@ -34,7 +35,7 @@ package() {
mkdir -p $pkgdir/usr/share/applications
mkdir -p $pkgdir/usr/bin
cd $pkgname
- cp linux_online_installer/config/xyGrib_32.png $pkgdir/usr/share/icons/hicolor/
+ cp linux_online_installer/config/xyGrib_32.png $pkgdir/usr/share/icons/hicolor/xygrib.png
cp debian/xygrib.desktop $pkgdir/usr/share/applications/
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr/share/openGribs/ ../
diff --git a/xygrib.install b/xygrib.install
new file mode 100644
index 000000000000..0a039b4dd254
--- /dev/null
+++ b/xygrib.install
@@ -0,0 +1,15 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+