summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2023-06-28 23:41:15 +0200
committerj.r2023-06-28 23:41:15 +0200
commit4d6bdea723d3455eb55c6e906c7897dcfb44ddfe (patch)
tree6934e2379e4bd1f88e7f099c61e2451bbf95862a
parent3841d53dd0d1903a2c4300c2978bf6840f5fbe46 (diff)
downloadaur-4d6bdea723d3455eb55c6e906c7897dcfb44ddfe.tar.gz
Switch to wheel based build workflow
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e03c32c658a8..5b2f28201e57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
pkgbase = telegram-tg-git
pkgdesc = terminal telegram client that really works
pkgver = 0.19.0.r3.2b0c0cf
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/paul-nameless/tg
arch = any
license = Unlicense
makedepends = git
+ makedepends = python-build
+ makedepends = python-poetry
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-telegram>=0.15.0
depends = python3
depends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 2ac6ef1136e6..783978564c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=telegram-tg
pkgname=$_pkgname-git
pkgver=0.19.0.r3.2b0c0cf
-pkgrel=1
+pkgrel=2
pkgdesc="terminal telegram client that really works"
arch=(any)
url="https://github.com/paul-nameless/tg"
license=('Unlicense')
depends=('python-telegram>=0.15.0' 'python3' 'python-setuptools')
-makedepends=('git')
+makedepends=('git' 'python-build' 'python-poetry' 'python-installer' 'python-wheel')
optdepends=(
'libnotify: for notifications, you could also use other programs: see config'
'ffmpeg: to record voice msgs and upload videos correctly'
@@ -39,11 +39,11 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- python3 setup.py build
+ python setup.py bdist_wheel
}
package() {
cd "$srcdir/$_pkgname"
- python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}