summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm dragon2015-09-18 15:12:38 -0400
committerStorm dragon2015-09-18 15:12:38 -0400
commit4d97adbb0089455e8ae97938d66a120a6cd60abd (patch)
treef0d602cff066191b3226119fd767d84e68184bef
downloadaur-4d97adbb0089455e8ae97938d66a120a6cd60abd.tar.gz
Initial commit, copied from the AUR 3.
-rw-r--r--.SRCINFO99
-rw-r--r--PKGBUILD107
-rw-r--r--install.sh12
-rw-r--r--system.service17
-rw-r--r--tmpfiles.conf2
-rw-r--r--user.service13
6 files changed, 250 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc13f4611fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,99 @@
+pkgbase = xmms2-git
+ pkgdesc = X-platform Music Multiplexing System 2
+ pkgver = 0.8DrO_o.862.g10d457e
+ pkgrel = 1
+ url = https://xmms2.org/
+ install = install.sh
+ arch = armv6h
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ checkdepends = cunit
+ checkdepends = valgrind
+ makedepends = alsa-lib
+ makedepends = avahi
+ makedepends = boost
+ makedepends = curl
+ makedepends = cython
+ makedepends = faad2
+ makedepends = ffmpeg
+ makedepends = fftw
+ makedepends = flac
+ makedepends = fluidsynth
+ makedepends = jack
+ makedepends = libao
+ makedepends = libcdio-paranoia
+ makedepends = libdiscid
+ makedepends = libgme
+ makedepends = libmad
+ makedepends = libmms
+ makedepends = libmodplug
+ makedepends = libmpcdec
+ makedepends = libofa
+ makedepends = libsamplerate
+ makedepends = libshout
+ makedepends = libvorbis
+ makedepends = libxml2
+ makedepends = mac
+ makedepends = mpg123
+ makedepends = opusfile
+ makedepends = perl
+ makedepends = ruby
+ makedepends = sidplay2-libs
+ makedepends = smbclient
+ makedepends = speex
+ makedepends = wavpack
+ makedepends = libpulse
+ makedepends = python2
+ depends = glib2
+ depends = readline
+ optdepends = alsa-lib: ALSA output
+ optdepends = avahi: announce xmms2d via bonjour/mDNS/zeroconf
+ optdepends = boost: C++ bindings
+ optdepends = curl: play HTTP streams
+ optdepends = cython: Python bindings
+ optdepends = faad2: AAC support
+ optdepends = ffmpeg: WMA, avcodec & avformat support
+ optdepends = fftw: visualization
+ optdepends = flac: FLAC support
+ optdepends = fluidsynth: MIDI support
+ optdepends = jack: JACK output
+ optdepends = libao: libao output
+ optdepends = libcdio-paranoia: CDDA support
+ optdepends = libdiscid: CDDA support
+ optdepends = libgme: support for various video game music formats
+ optdepends = libmad: MP3 support
+ optdepends = libmms: play MMS streams
+ optdepends = libmodplug: MOD support
+ optdepends = libmpcdec: Musepack support
+ optdepends = libofa: MusicDNS fingerprinting
+ optdepends = libsamplerate: vocoder support
+ optdepends = libshout: Icecast output
+ optdepends = libvorbis: Ogg Vorbis support
+ optdepends = libxml2: XSPF and podcast support
+ optdepends = mac: APE support
+ optdepends = mpg123: alternative MP3 support
+ optdepends = opusfile: Opus support
+ optdepends = perl: Perl bindings
+ optdepends = ruby: Ruby bindings
+ optdepends = sidplay2-libs: support for C64 music files
+ optdepends = smbclient: direct CIFS/SMB access
+ optdepends = speex: Speex support
+ optdepends = wavpack: WavPack support
+ optdepends = oss: OSS output
+ optdepends = pulseaudio: PulseAudio output
+ provides = xmms2
+ conflicts = xmms2
+ conflicts = xmms2-devel
+ source = git://git.xmms2.org/xmms2/xmms2-devel.git
+ source = tmpfiles.conf
+ source = system.service
+ source = user.service
+ md5sums = SKIP
+ md5sums = d3ab09ed8d1cf982468d1ceb141d4a9d
+ md5sums = 4b026ab80e853f24b5cf13b310afb83c
+ md5sums = f773f674882946065c02e36e9548eb00
+
+pkgname = xmms2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28ca21cea58a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,107 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Contributor: Aaron 'venisonslurpee' Laursen <venisonslurpee@gmail.com>
+# Contributor: Christopher Rosell <chrippa@tanuki.se>
+# Contributor: lh <jarryson@gmail.com>
+# Contributor: Sebastian Schwarz <seschwar@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Xilon <xilon@gmail.com>
+
+pkgname=xmms2-git
+pkgver=0.8DrO_o.862.g10d457e
+pkgrel=1
+pkgdesc="X-platform Music Multiplexing System 2"
+arch=(armv6h i686 x86_64)
+url="https://xmms2.org/"
+license=(GPL LGPL)
+_depends=('alsa-lib: ALSA output'
+ 'avahi: announce xmms2d via bonjour/mDNS/zeroconf'
+ 'boost: C++ bindings'
+ 'curl: play HTTP streams'
+ 'cython: Python bindings'
+ 'faad2: AAC support'
+ 'ffmpeg: WMA, avcodec & avformat support'
+ 'fftw: visualization'
+ 'flac: FLAC support'
+ 'fluidsynth: MIDI support'
+ 'jack: JACK output'
+ 'libao: libao output'
+ 'libcdio-paranoia: CDDA support'
+ 'libdiscid: CDDA support'
+ 'libgme: support for various video game music formats'
+ 'libmad: MP3 support'
+ 'libmms: play MMS streams'
+ 'libmodplug: MOD support'
+ 'libmpcdec: Musepack support'
+ 'libofa: MusicDNS fingerprinting'
+ 'libsamplerate: vocoder support'
+ 'libshout: Icecast output'
+ 'libvorbis: Ogg Vorbis support'
+ 'libxml2: XSPF and podcast support'
+ 'mac: APE support'
+ 'mpg123: alternative MP3 support'
+ 'opusfile: Opus support'
+ 'perl: Perl bindings'
+ 'ruby: Ruby bindings'
+ 'sidplay2-libs: support for C64 music files'
+ 'smbclient: direct CIFS/SMB access'
+ 'speex: Speex support'
+ 'wavpack: WavPack support')
+depends=(glib2 readline)
+makedepends=("${_depends[@]%%:*}" libpulse python2)
+checkdepends=(cunit valgrind)
+optdepends=("${_depends[@]}" 'oss: OSS output' 'pulseaudio: PulseAudio output')
+provides=(xmms2)
+conflicts=(xmms2 xmms2-devel)
+install=install.sh
+source=(git://git.xmms2.org/xmms2/xmms2-devel.git
+ tmpfiles.conf
+ system.service
+ user.service)
+md5sums=('SKIP'
+ 'd3ab09ed8d1cf982468d1ceb141d4a9d'
+ '4b026ab80e853f24b5cf13b310afb83c'
+ 'f773f674882946065c02e36e9548eb00')
+
+pkgver() {
+ cd "$srcdir/xmms2-devel"
+ git describe --always | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/xmms2-devel"
+ git submodule update --init
+ sed -i '$a#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 /* 1 second of 48kHz 32bit audio */' src/plugins/avcodec/avcodec_compat.h
+ sed -i 's,#include <cdio/cdda.h>,#include <cdio/paranoia/cdda.h>,' src/plugins/cdda/cdda.c
+ sed -i 's,libsmbclient.h,samba-4.0/libsmbclient.h,' src/plugins/samba/{samba.c,wscript}
+}
+
+build() {
+ cd "$srcdir/xmms2-devel"
+ ./waf configure --prefix=/usr --sbindir=/usr/bin --without-ldconfig \
+ --with-ruby-archdir=`ruby -e 'puts RbConfig::CONFIG["vendorarchdir"]'` \
+ --with-ruby-libdir=`ruby -e 'puts RbConfig::CONFIG["vendorlibdir"]'`
+ ./waf build
+}
+
+check() {
+ cd "$srcdir/xmms2-devel"
+ ./waf --alltests
+}
+
+package() {
+ cd "$srcdir/xmms2-devel"
+ ./waf --destdir="$pkgdir" install
+ install -d -o46 -g46 "$pkgdir/var/lib/xmms2"
+ install -Dm0644 "$srcdir/tmpfiles.conf" \
+ "$pkgdir/usr/lib/tmpfiles.d/xmms2.conf"
+ install -Dm0644 "$srcdir/system.service" \
+ "$pkgdir/usr/lib/systemd/system/xmms2d.service"
+ install -Dm0644 "$srcdir/user.service" \
+ "$pkgdir/usr/lib/systemd/user/xmms2d.service"
+
+ ## also install python2 bindings
+ PYTHON=/usr/bin/python2 ./waf configure --prefix=/usr \
+ --with-optionals=python --without-xmms2d
+ ./waf build
+ ./waf --destdir="$pkgdir" install
+}
diff --git a/install.sh b/install.sh
new file mode 100644
index 000000000000..efb6c081845a
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,12 @@
+post_install() {
+ getent group xmms2 > /dev/null || groupadd -r -g 46 xmms2
+ getent passwd xmms2 > /dev/null || useradd -r -u 46 -g xmms2 -d /var/lib/xmms2 -s /bin/false -G audio xmms2
+ usr/bin/systemd-tmpfiles --create xmms2.conf
+ true
+}
+
+post_remove() {
+ getent passwd xmms2 > /dev/null && userdel xmms2
+ getent group xmms2 > /dev/null && groupdel xmms2
+ true
+}
diff --git a/system.service b/system.service
new file mode 100644
index 000000000000..f3e524d4e04f
--- /dev/null
+++ b/system.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=XMMS2 daemon
+Documentation=man:xmms2-launcher(1) man:xmms2d(1)
+Wants=fluidsynth.service
+After=fluidsynth.service network.target sound.target
+
+[Service]
+Type=forking
+User=xmms2
+# Trick xmms2d into correctly using /var/lib/xmms2 for its configuration
+Environment=XDG_CONFIG_HOME=/var/lib
+PIDFile=%t/xmms2/xmms2d.pid
+ExecStart=/usr/bin/xmms2-launcher -l /var/log/xmms2d.log -P %t/xmms2/xmms2d.pid
+ExecStop=/usr/bin/xmms2 server shutdown
+
+[Install]
+WantedBy=multi-user.target
diff --git a/tmpfiles.conf b/tmpfiles.conf
new file mode 100644
index 000000000000..61cd6a797a1c
--- /dev/null
+++ b/tmpfiles.conf
@@ -0,0 +1,2 @@
+d /run/xmms2 0755 xmms2 xmms2
+f /var/log/xmms2d.log 0644 xmms2 xmms2
diff --git a/user.service b/user.service
new file mode 100644
index 000000000000..dc27ad150033
--- /dev/null
+++ b/user.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=XMMS2 daemon
+Documentation=man:xmms2-launcher(1) man:xmms2d(1)
+After=network.target sound.target
+
+[Service]
+Type=forking
+PIDFile=%t/xmms2d.pid
+ExecStart=/usr/bin/xmms2-launcher -P %t/xmms2d.pid
+ExecStop=/usr/bin/xmms2 server shutdown
+
+[Install]
+WantedBy=default.target