summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2020-10-01 23:24:41 +0200
committerPopolon2020-10-01 23:24:41 +0200
commit4dc1493ecf37734f613260e4c8dd3dd9a8f84bd2 (patch)
tree5ab0c6201cc46d1a487d014bcae6e7059aa5619b
parentc57c1e723ae3528d86fec68a9bb493671e1ac1d0 (diff)
downloadaur-4dc1493ecf37734f613260e4c8dd3dd9a8f84bd2.tar.gz
Update to freetype 2.10.2
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD11
-rw-r--r--openoffice.patch12
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23c4781d3420..c3b16545e0bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Dec 2 02:10:25 UTC 2016
pkgbase = openoffice-uglyfix-freetype2
pkgdesc = Compiles freetype2 .so files and puts them in the openoffice/libreoffice directory to fix font ugliness
- pkgver = 2.7
+ pkgver = 2.10.2
pkgrel = 1
url = http://freetype.sourceforge.net
arch = i686
@@ -11,10 +9,10 @@ pkgbase = openoffice-uglyfix-freetype2
depends = zlib
depends = libreoffice
options = !libtool
- source = http://downloads.sourceforge.net/sourceforge/freetype/freetype-2.7.tar.bz2
+ source = https://downloads.sourceforge.net/sourceforge/freetype/freetype2/2.10.2/freetype-2.10.2.tar.xz
source = openoffice.patch
- md5sums = be4601619827b7935e1d861745923a68
- md5sums = 1f909d5c71b810c68a50dea33995a713
+ md5sums = 7c0d5a39f232d7eb9f9d7da76bf08074
+ md5sums = 1670a80091ed66f381d415a7b6ea17d1
pkgname = openoffice-uglyfix-freetype2
diff --git a/PKGBUILD b/PKGBUILD
index a97d8d7e2f68..c5d13887f2fc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Contributor: ilikenwf/Matt Parnell <parwok@gmail.com>
+# Contributor: Popolon <popolon@popolon.org>
# Maintainer: ilikenwf/Matt Parnell <parwok@gmail.com>
pkgname=openoffice-uglyfix-freetype2
-pkgver=2.7
+pkgver=2.10.2
pkgrel=1
pkgdesc="Compiles freetype2 .so files and puts them in the openoffice/libreoffice directory to fix font ugliness"
arch=(i686 x86_64)
@@ -10,10 +10,11 @@ license=('GPL')
url="http://freetype.sourceforge.net"
depends=('zlib' 'libreoffice')
options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/freetype/freetype-${pkgver}.tar.bz2
+# -source=(http://downloads.sourceforge.net/sourceforge/freetype/freetype-${pkgver}.tar.bz2
+source=(https://downloads.sourceforge.net/sourceforge/freetype/freetype2/${pkgver}/freetype-${pkgver}.tar.xz
openoffice.patch)
-md5sums=('be4601619827b7935e1d861745923a68'
- '1f909d5c71b810c68a50dea33995a713')
+md5sums=('7c0d5a39f232d7eb9f9d7da76bf08074'
+ '1670a80091ed66f381d415a7b6ea17d1')
prepare()
{
diff --git a/openoffice.patch b/openoffice.patch
index 3d7e3109fb83..c4ca3c8cae7c 100644
--- a/openoffice.patch
+++ b/openoffice.patch
@@ -1,6 +1,6 @@
---- include/freetype/freetype.orig 2013-12-21 22:58:05.639880352 -0600
-+++ include/freetype/freetype.h 2013-12-21 22:57:36.886881072 -0600
-@@ -2592,7 +2592,7 @@
+--- include/freetype/freetype.h 2020-05-08 11:01:46.000000000 +0200
++++ ../freetype.h 2020-10-01 23:17:23.171690435 +0200
+@@ -3037,7 +3037,7 @@
#define FT_LOAD_RENDER ( 1L << 2 )
#define FT_LOAD_NO_BITMAP ( 1L << 3 )
#define FT_LOAD_VERTICAL_LAYOUT ( 1L << 4 )
@@ -9,12 +9,12 @@
#define FT_LOAD_CROP_BITMAP ( 1L << 6 )
#define FT_LOAD_PEDANTIC ( 1L << 7 )
#define FT_LOAD_IGNORE_GLOBAL_ADVANCE_WIDTH ( 1L << 9 )
-@@ -2600,7 +2600,7 @@
+@@ -3045,7 +3045,7 @@
#define FT_LOAD_IGNORE_TRANSFORM ( 1L << 11 )
#define FT_LOAD_MONOCHROME ( 1L << 12 )
#define FT_LOAD_LINEAR_DESIGN ( 1L << 13 )
-#define FT_LOAD_NO_AUTOHINT ( 1L << 15 )
+#define FT_LOAD_FORCE_AUTOHINT ( 1L << 15 )
- /* Bits 16..19 are used by `FT_LOAD_TARGET_' */
+ /* Bits 16-19 are used by `FT_LOAD_TARGET_` */
#define FT_LOAD_COLOR ( 1L << 20 )
-
+ #define FT_LOAD_COMPUTE_METRICS ( 1L << 21 )