summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-11-30 20:46:39 +0800
committermaz-12015-11-30 20:46:39 +0800
commit4de70c4bff0dc2223e34bac15b5ef2d625cfa190 (patch)
tree25cad1227158d803d542a516a7cc8c4a355adaa1
parent320ab3427541f9b3653b79bf9df0ba1f82a6027f (diff)
downloadaur-4de70c4bff0dc2223e34bac15b5ef2d625cfa190.tar.gz
bump
-rw-r--r--PKGBUILD20
-rw-r--r--port_to_kf5.patch20
-rwxr-xr-xzh_CN.po147
3 files changed, 174 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69ff38b362b8..405cef738eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,20 +11,30 @@ license="GPL"
depends=('kdelibs4support' 'cdemu-daemon>=2.0')
provides=('kde-cdemu-manager')
conflicts=('kde-cdemu-manager')
-makedepends=('cmake')
+makedepends=('cmake' 'kdoctools' 'qt5-tools' 'extra-cmake-modules')
source=(http://www.kde-apps.org/CONTENT/content-files/99752-kde_cdemu-$pkgver.0.tar.bz2
- port_to_kf5.patch)
+ port_to_kf5.patch
+ zh_CN.po)
md5sums=('c0e56401e2c2f2c4652915a44af128b8'
- '8d6c70628bbfd664efe0f1462708244d')
+ 'SKIP'
+ 'SKIP')
prepare() {
cd $srcdir/kde_cdemu
patch -p1 < ../port_to_kf5.patch
+ cp ${srcdir}/zh_CN.po $srcdir/kde_cdemu/po
}
build() {
cd $srcdir/kde_cdemu
- mkdir build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` ..
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DSYSCONF_INSTALL_DIR=/etc \
+ -DBUILD_TESTING=OFF \
+ ..
+
make
}
diff --git a/port_to_kf5.patch b/port_to_kf5.patch
index 646abca881f1..fd16a713e16b 100644
--- a/port_to_kf5.patch
+++ b/port_to_kf5.patch
@@ -1,6 +1,6 @@
diff -Naur a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2013-01-13 05:04:17.000000000 +0800
-+++ b/CMakeLists.txt 2015-10-11 14:37:38.701454938 +0800
++++ b/CMakeLists.txt 2015-11-30 20:24:59.296150854 +0800
@@ -1,9 +1,17 @@
cmake_minimum_required(VERSION 2.6)
project(kde_cdemu)
@@ -24,7 +24,7 @@ diff -Naur a/CMakeLists.txt b/CMakeLists.txt
diff -Naur a/src/CMakeLists.txt b/src/CMakeLists.txt
--- a/src/CMakeLists.txt 2010-09-05 06:47:43.000000000 +0800
-+++ b/src/CMakeLists.txt 2015-10-11 14:38:05.748120774 +0800
++++ b/src/CMakeLists.txt 2015-11-30 20:30:07.878598397 +0800
@@ -3,20 +3,22 @@
configure_file(kdecdemuversion.h.in ${PROJECT_BINARY_DIR}/kdecdemuversion.h)
@@ -43,8 +43,10 @@ diff -Naur a/src/CMakeLists.txt b/src/CMakeLists.txt
set(kde_cdemu_SRCS main.cpp kdecdemu.cpp mainwindow.cpp cdemu.cpp messagebox.cpp)
- kde4_add_ui_files(kde_cdemu_SRCS mainwindow.ui)
- kde4_add_executable(kde_cdemu ${kde_cdemu_SRCS})
+-kde4_add_ui_files(kde_cdemu_SRCS mainwindow.ui)
+-kde4_add_executable(kde_cdemu ${kde_cdemu_SRCS})
++ki18n_wrap_ui(kde_cdemu_SRCS mainwindow.ui)
++add_executable(kde_cdemu ${kde_cdemu_SRCS})
-target_link_libraries(kde_cdemu ${KDE4_KDEUI_LIBS} ${KDE4_KIO_LIBS})
+target_link_libraries(kde_cdemu KF5::KDELibs4Support KF5::KIOCore Qt5::Widgets)
@@ -56,12 +58,13 @@ diff -Naur a/src/CMakeLists.txt b/src/CMakeLists.txt
install(FILES kde_cdemu.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
diff -Naur a/src/main.cpp b/src/main.cpp
--- a/src/main.cpp 2013-01-13 06:16:12.000000000 +0800
-+++ b/src/main.cpp 2015-10-11 14:37:38.701454938 +0800
-@@ -21,18 +21,22 @@
++++ b/src/main.cpp 2015-11-30 20:29:06.613459670 +0800
+@@ -21,18 +21,24 @@
#include <KAboutData>
#include <KCmdLineArgs>
#include <KUniqueApplication>
-+#include <klocale.h>
++#include <klocalizedstring.h>
++//kdelibs4support
+#include <k4aboutdata.h>
#include "kdecdemu.h"
@@ -71,6 +74,7 @@ diff -Naur a/src/main.cpp b/src/main.cpp
{
- KAboutData aboutData("kde_cdemu", "konqueror", ki18n("KDE CDEmu Manager"), KDE_CDEMU_VERSION, ki18n("A KDE Frontend to CDEmu"),
- KAboutData::License_GPL_V3, ki18n("Copyright (c) 2009-2013 Marcel Hasler"));
++ KLocalizedString::setApplicationDomain("kde_cdemu");
+ K4AboutData aboutData("kde_cdemu", 0, ki18n("KDE CDEmu Manager"), KDE_CDEMU_VERSION, ki18n("A KDE Frontend to CDEmu"), K4AboutData::License_GPL_V3,
+ ki18n("Copyright (c) 2009-2013 Marcel Hasler"), KLocalizedString(),
+ "http://kde-apps.org/content/show.php?content=99752&forumpage=5");
@@ -85,7 +89,7 @@ diff -Naur a/src/main.cpp b/src/main.cpp
diff -Naur a/src/mainwindow.cpp b/src/mainwindow.cpp
--- a/src/mainwindow.cpp 2013-01-13 05:14:30.000000000 +0800
-+++ b/src/mainwindow.cpp 2015-10-11 14:37:38.701454938 +0800
++++ b/src/mainwindow.cpp 2015-11-30 20:24:59.296150854 +0800
@@ -32,6 +32,7 @@
#include <KMessageBox>
#include <KStandardAction>
diff --git a/zh_CN.po b/zh_CN.po
new file mode 100755
index 000000000000..1414a7fef02e
--- /dev/null
+++ b/zh_CN.po
@@ -0,0 +1,147 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+#, fuzzy
+msgid ""
+msgstr ""
+"Project-Id-Version: PACKAGE VERSION\n"
+"Report-Msgid-Bugs-To: mahasler@gmail.com\n"
+"POT-Creation-Date: 2013-01-12 23:09+0100\n"
+"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+"Last-Translator: Lin Ziyun <ohmygod19993@gmail.com>\n"
+"Language-Team: LANGUAGE <LL@li.org>\n"
+"Language: \n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=CHARSET\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. i18n: file: src/mainwindow.ui:20
+#. i18n: ectx: property (windowTitle), widget (QMainWindow, MainWindow)
+#: po/rc.cpp:3 src/main.cpp:30 rc.cpp:3
+msgid "KDE CDEmu Manager"
+msgstr "KDE CDEmu 管理器"
+
+#. i18n: file: src/mainwindow.ui:58
+#. i18n: ectx: property (text), widget (QTreeWidget, DeviceList)
+#: po/rc.cpp:6 rc.cpp:6
+msgid "Device"
+msgstr "设备"
+
+#. i18n: file: src/mainwindow.ui:63
+#. i18n: ectx: property (text), widget (QTreeWidget, DeviceList)
+#: po/rc.cpp:9 src/mainwindow.cpp:58 rc.cpp:9
+msgid "File"
+msgstr "文件"
+
+#. i18n: file: src/mainwindow.ui:71
+#. i18n: ectx: property (title), widget (QGroupBox, SelectImageBox)
+#: po/rc.cpp:12 rc.cpp:12
+msgid "Select image"
+msgstr "选择镜像"
+
+#. i18n: file: src/mainwindow.ui:80
+#. i18n: ectx: property (text), widget (KPushButton, SelectFileButton)
+#: po/rc.cpp:15 rc.cpp:15
+msgid "..."
+msgstr "..."
+
+#. i18n: file: src/mainwindow.ui:105
+#. i18n: ectx: property (text), widget (KPushButton, MountButton)
+#: po/rc.cpp:18 rc.cpp:18
+msgid "Mount"
+msgstr "挂载"
+
+#. i18n: file: src/mainwindow.ui:125
+#. i18n: ectx: property (text), widget (KPushButton, UnmountButton)
+#: po/rc.cpp:21 rc.cpp:21
+msgid "Unmount"
+msgstr "卸载"
+
+#: po/rc.cpp:22 rc.cpp:22
+msgctxt "NAME OF TRANSLATORS"
+msgid "Your names"
+msgstr "Lin Ziyun"
+
+#: po/rc.cpp:23 rc.cpp:23
+msgctxt "EMAIL OF TRANSLATORS"
+msgid "Your emails"
+msgstr "ohmygod19993@gmail.com"
+
+#: src/main.cpp:30
+msgid "A KDE Frontend to CDEmu"
+msgstr "CDEmu的KDE前端"
+
+#: src/main.cpp:31
+msgid "Copyright (c) 2009-2013 Marcel Hasler"
+msgstr "Copyright (c) 2009-2013 Marcel Hasler"
+
+#: src/main.cpp:32
+msgid "Marcel Hasler"
+msgstr "Marcel Hasler"
+
+#: src/main.cpp:32
+msgid "Developer & Maintainer"
+msgstr "开发者与维护者"
+
+#: src/main.cpp:40
+msgid "Mount an image"
+msgstr "挂载一个镜像"
+
+#: src/main.cpp:41
+msgid "Unmount an image"
+msgstr "卸载一个镜像"
+
+#: src/main.cpp:42
+msgid "Show information about devices"
+msgstr "显示设备信息"
+
+#: src/mainwindow.cpp:103
+msgid "CDEmu daemon running."
+msgstr "CDEmu守护进程正在运行。"
+
+#: src/mainwindow.cpp:106
+msgid "CDEmu daemon not running."
+msgstr "CDEmu守护进程未运行。"
+
+#: src/mainwindow.cpp:121
+msgid "Please select a file first."
+msgstr "请先选择一个文件。"
+
+#: src/mainwindow.cpp:121 src/mainwindow.cpp:128 src/mainwindow.cpp:145
+#: src/messagebox.cpp:65
+msgid "Error"
+msgstr "错误"
+
+#: src/mainwindow.cpp:128 src/mainwindow.cpp:145
+msgid "Please select a device first."
+msgstr "请先选择一个设备。"
+
+#: src/messagebox.cpp:33
+msgid "Everything OK."
+msgstr "一切正常。"
+
+#: src/messagebox.cpp:37
+msgid "The selected virtual device is in use."
+msgstr "选中的设备被占用。"
+
+#: src/messagebox.cpp:41
+msgid "The selected virtual device is not available."
+msgstr "选中的设备不可用。"
+
+#: src/messagebox.cpp:45
+msgid "All virtual devices are in use."
+msgstr "所有虚拟设备均被占用。"
+
+#: src/messagebox.cpp:49
+msgid "The file doesn't exist."
+msgstr "文件不存在。"
+
+#: src/messagebox.cpp:53
+msgid "Unable to connect to the CDEmu daemon."
+msgstr "无法连接到CDEmu守护进程。"
+
+#: src/messagebox.cpp:57
+msgid "An unknown error occured."
+msgstr "未知错误。"