summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-07 18:29:49 +0800
committerChocobo12019-05-07 18:45:33 +0800
commit4e022ff8872d323973bab34ed76d50fb96ed51a7 (patch)
tree1a09ed47c3d6abc8d43e9912f554f44bf511819e
parentf83592bf897ae79f1b90cbf5e7d97923112b7d48 (diff)
downloadaur-4e022ff8872d323973bab34ed76d50fb96ed51a7.tar.gz
upgpkg: lzbench-git 1.7.3.r21.g3d48788-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
-rw-r--r--no-static.patch13
3 files changed, 27 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 290ef5e2092b..212a002c367f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = lzbench-git
- pkgdesc = An in-memory benchmark of open-source LZ77/LZSS/LZMA compressors
- pkgver = 1.7.1.r13.gdf29c60
+ pkgdesc = An in-memory benchmark of open-source compressors
+ pkgver = 1.7.3.r21.g3d48788
pkgrel = 1
url = https://github.com/inikep/lzbench
+ arch = i686
arch = x86_64
- license = unknown
+ license = GPL3
makedepends = git
depends = gcc-libs
provides = lzbench
conflicts = lzbench
- source = lzbench-git::git+https://github.com/inikep/lzbench.git
- source = no-static.patch
+ source = git+https://github.com/inikep/lzbench.git
sha256sums = SKIP
- sha256sums = 0e3f1de18f9da318163a7c771a4c15fee38b16c2f26390ee61b51eef0d9eb19e
pkgname = lzbench-git
diff --git a/PKGBUILD b/PKGBUILD
index fde495209741..6136b176115a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
-# Maintainer: fatalis <fatalis@fatalis.pw>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Former maintainer: fatalis <fatalis@fatalis.pw>
+
pkgname=lzbench-git
-pkgver=1.7.1.r13.gdf29c60
+pkgver=1.7.3.r21.g3d48788
pkgrel=1
-pkgdesc='An in-memory benchmark of open-source LZ77/LZSS/LZMA compressors'
-arch=('x86_64')
-url='https://github.com/inikep/lzbench'
-license=('unknown')
+pkgdesc="An in-memory benchmark of open-source compressors"
+arch=('i686' 'x86_64')
+url="https://github.com/inikep/lzbench"
+license=('GPL3')
depends=('gcc-libs')
makedepends=('git')
provides=('lzbench')
conflicts=('lzbench')
-source=("${pkgname}::git+${url}.git"
- 'no-static.patch')
-sha256sums=('SKIP'
- '0e3f1de18f9da318163a7c771a4c15fee38b16c2f26390ee61b51eef0d9eb19e')
+source=("git+https://github.com/inikep/lzbench.git")
+sha256sums=('SKIP')
+
prepare() {
- cd "${pkgname}"
- patch -p0 < ../no-static.patch
+ cd "lzbench"
+
+ sed -i 's/LDFLAGS += -lrt -static/LDFLAGS += -lrt/' "Makefile"
}
pkgver() {
- cd "${pkgname}"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+ cd "lzbench"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname}"
+ cd "lzbench"
+
make
}
package() {
- cd "${pkgname}"
- install -Dm755 lzbench "${pkgdir}/usr/bin/lzbench"
+ cd "lzbench"
+
+ install -Dm755 "lzbench" "$pkgdir/usr/bin/lzbench"
}
diff --git a/no-static.patch b/no-static.patch
deleted file mode 100644
index 878fea9b1e97..000000000000
--- a/no-static.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git Makefile Makefile
-index 11d1259..01c4cd7 100644
---- Makefile
-+++ Makefile
-@@ -51,7 +51,7 @@ else
- DONT_BUILD_LZHAM ?= 1
- DONT_BUILD_CSC ?= 1
- else
-- LDFLAGS += -lrt -static
-+ LDFLAGS += -lrt
- endif
- LDFLAGS += -lpthread
- endif