summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-05-24 17:16:56 +0200
committerChristopher Reimer2015-05-24 17:16:56 +0200
commit4e081423989dab89dab84f9ed71a2170255b577c (patch)
tree7a26a69f3c19a2f037823e35be47287534dff292
downloadaur-4e081423989dab89dab84f9ed71a2170255b577c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8421fb69668
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mp3fs
+ pkgdesc = FUSE-based transcoding filesystem from FLAC to MP3
+ pkgver = 0.91
+ pkgrel = 1
+ url = http://khenriks.github.com/mp3fs
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = flac
+ depends = fuse
+ depends = lame
+ depends = libid3tag
+ source = https://github.com/khenriks/mp3fs/releases/download/v0.91/mp3fs-0.91.tar.gz
+ md5sums = 8b1e7543114c2bcc5b8eb9562e15c909
+
+pkgname = mp3fs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40f59aee3fa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Christopher Reimer <archlinux[at]creimer[dot]net>
+pkgname=mp3fs
+pkgver=0.91
+pkgrel=1
+pkgdesc="FUSE-based transcoding filesystem from FLAC to MP3"
+arch=('i686' 'x86_64')
+url="http://khenriks.github.com/mp3fs"
+license=('GPL3')
+depends=('flac' 'fuse' 'lame' 'libid3tag')
+source=("https://github.com/khenriks/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('8b1e7543114c2bcc5b8eb9562e15c909')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file