summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2022-02-02 08:46:41 +0100
committersoloturn2022-02-02 08:56:56 +0100
commit4e22e64bdc381e68ae068d33c4796decaa253d54 (patch)
treee57adc6df99f9c6cbc967dd557c25d9f73f8e0ef
downloadaur-4e22e64bdc381e68ae068d33c4796decaa253d54.tar.gz
2021 initial
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
-rw-r--r--easytax-ag-2021.desktop7
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a56f9766bfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = easytax-ag-2021
+ pkgdesc = Aargau tax declaration software.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.ag.ch/de/dfr/steuern/natuerliche_personen/steuererklaerung__easytax/steuererklaerung_easytax1.jsp
+ arch = any
+ license = custom
+ depends = java-runtime>=8
+ depends = bash
+ source = https://msg-easytax.ch/ag/2021/EasyTax2021AG_unix_1_0.tar.gz
+ source = easytax-ag-2021.desktop
+ sha256sums = 531c03131b5a9ecf500fee3fbbf03e215d5ac02db6e5bcae72016838d09f17d8
+ sha256sums = 59e9781415d7e6cd07b249002fd8737c545f5bdbc764fa228e1a0cfc9a56d0f4
+
+pkgname = easytax-ag-2021
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a483c5719a56
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/Easy*
+/easy*zst
+/pkg
+/src
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df4fd4e5e3ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jeremy Stucki <dev@jeremystucki.ch>
+# Maintainer: Daniel Wilhelm <concat(shield, wed) @ outlook.com>
+# Maintainer: soloturn@gmail.com
+
+yyyy=2021
+pkgname=easytax-ag-${yyyy}
+pkgver=1.0
+pkgrel=1
+pkgdesc="Aargau tax declaration software."
+arch=(any)
+url="https://www.ag.ch/de/dfr/steuern/natuerliche_personen/steuererklaerung__easytax/steuererklaerung_easytax1.jsp"
+license=('custom')
+depends=("java-runtime>=8" "bash")
+source=(
+ "https://msg-easytax.ch/ag/${yyyy}/EasyTax${yyyy}AG_unix_1_0.tar.gz"
+ "$pkgname.desktop"
+)
+sha256sums=(
+ '531c03131b5a9ecf500fee3fbbf03e215d5ac02db6e5bcae72016838d09f17d8'
+ '59e9781415d7e6cd07b249002fd8737c545f5bdbc764fa228e1a0cfc9a56d0f4'
+)
+
+package() {
+ # package the software, the xdg desktop file so GUI finds it
+ # and the link in bin so commandline finds it.
+ mkdir -p "$pkgdir"/usr/lib
+ mv "$srcdir"/EasyTax${yyyy}AG/ "$pkgdir"/usr/lib/$pkgname/
+
+ mkdir -p "$pkgdir"/usr/share/applications
+ cp *.desktop "$pkgdir"/usr/share/applications/
+
+ mkdir -p "$pkgdir"/usr/bin
+ binname=$(basename "$pkgdir"/usr/lib/$pkgname/EasyTax*)
+ ln -sf /usr/lib/${pkgname}/$binname "$pkgdir"/usr/bin/$pkgname
+}
diff --git a/easytax-ag-2021.desktop b/easytax-ag-2021.desktop
new file mode 100644
index 000000000000..b9966111131f
--- /dev/null
+++ b/easytax-ag-2021.desktop
@@ -0,0 +1,7 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Type=Application
+Name=EasyTax 2021 AG
+Exec=/bin/sh "/usr/bin/easytax-ag-2021"
+Categories=Office;
+