summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartiMcFly2016-08-19 15:34:40 +0200
committerMartiMcFly2016-08-19 15:34:40 +0200
commit4e2b7bf6d52004e26c5622bd4b41a78c27313fe0 (patch)
tree35371a8f4b2e83bf057562501a9fd7f6998ffae2
parent24382f6b4f5766ec2dc3a7ef32f502ef89f52da0 (diff)
downloadaur-4e2b7bf6d52004e26c5622bd4b41a78c27313fe0.tar.gz
update to zarafa 7.2.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--install22
-rw-r--r--z-push.ini2
4 files changed, 52 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 803c6f269c92..48533f6a991f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,29 @@
# Generated by mksrcinfo v8
-# Tue Aug 9 14:55:16 UTC 2016
+# Fri Aug 19 13:34:27 UTC 2016
pkgbase = z-push
pkgdesc = open-source implementation of the ActiveSync protocol
- pkgver = 2.2.8
- pkgrel = 84
+ pkgver = 2.3.0
+ pkgrel = 1
url = http://z-push.sf.net/
install = install
arch = any
groups = zarafa
+ groups = kopano
license = AGPL3
+ depends = nginx
depends = php<7
+ depends = memcached
+ depends = libmemcached
+ depends = php-memcached
+ depends = zarafa-server
depends = php-fpm<7
- optdepends = nginx
optdepends = apache
optdepends = zarafa-server
options = !strip
backup = etc/webapps/z-push/nginx-location.conf
backup = etc/php/conf.d/z-push.ini
backup = etc/php/fpm.d/z-push.conf
- source = z-push-2.2.8.tar.gz::http://download.z-push.org/final/2.2/z-push-2.2.8.tar.gz
+ source = z-push-2.3.0.tar.gz::http://download.z-push.org/final/2.3/z-push-2.3.0.tar.gz
source = apache.example.conf
source = htaccess
source = z-push.ini
@@ -28,10 +33,10 @@ pkgbase = z-push
source = php-fpm.example.conf
source = z-push-admin
source = z-push-top
- md5sums = e55b04680bb9c698301155c47aeb87f8
+ md5sums = SKIP
md5sums = 32a459bd61135b6c5e99e82e3a6b0007
md5sums = 1091aa1ba272ef05bf628f73b05c527a
- md5sums = fee38ae6ba98ae7afcb49b1edbc31d8e
+ md5sums = SKIP
md5sums = b61c194ee4e3e3bf8bfa6a72e6f38019
md5sums = 9637d4164f85cb3fb9a886654645a46c
md5sums = 1bdab5b1e4473c1b0f6ce2e5c8f1da61
diff --git a/PKGBUILD b/PKGBUILD
index a90305cd74c6..6a972d227bfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
-# Maintainer: MartiMcFly martimcfly@autorisation.de
+# Maintainer: MartiMcFly <martimcfly [at] autorisation.de>
# Contributor: C Anthony Risinger
# Contributer: Jörg Thalheim <joerg@higgsboson.tk>
pkgname=z-push
-groups=('zarafa')
-pkgver=2.2.8
-pkgrel=84
+groups=('zarafa'
+ 'kopano')
+pkgver=2.3.0
+_pkgrel=2.3
+pkgrel=1
pkgdesc="open-source implementation of the ActiveSync protocol"
arch=('any')
url="http://z-push.sf.net/"
license=('AGPL3')
-depends=('php<7'
+depends=('nginx'
+ 'php<7'
+ 'memcached'
+ 'libmemcached'
+ 'php-memcached'
+ 'zarafa-server' # php-mapi
'php-fpm<7')
-optdepends=('nginx'
- 'apache'
+optdepends=('apache'
'zarafa-server')
install='install'
backup=('etc/webapps/z-push/nginx-location.conf'
'etc/php/conf.d/z-push.ini'
'etc/php/fpm.d/z-push.conf')
options=('!strip')
-source=("${pkgname}-${pkgver}.tar.gz::http://download.z-push.org/final/2.2/${pkgname}-${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::http://download.z-push.org/final/${_pkgrel}/${pkgname}-${pkgver}.tar.gz"
"apache.example.conf"
"htaccess"
"z-push.ini"
@@ -30,11 +36,10 @@ source=("${pkgname}-${pkgver}.tar.gz::http://download.z-push.org/final/2.2/${pkg
"php-fpm.example.conf"
"z-push-admin"
"z-push-top")
-
-md5sums=('e55b04680bb9c698301155c47aeb87f8'
+md5sums=('SKIP'
'32a459bd61135b6c5e99e82e3a6b0007'
'1091aa1ba272ef05bf628f73b05c527a'
- 'fee38ae6ba98ae7afcb49b1edbc31d8e'
+ 'SKIP'
'b61c194ee4e3e3bf8bfa6a72e6f38019'
'9637d4164f85cb3fb9a886654645a46c'
'1bdab5b1e4473c1b0f6ce2e5c8f1da61'
@@ -48,6 +53,7 @@ package() {
cp -r ${srcdir}/${pkgname}-${pkgver}/* ${pkgdir}/usr/share/webapps/z-push/
cp ${srcdir}/htaccess ${pkgdir}/usr/share/webapps/z-push/.htaccess
rm ${pkgdir}/usr/share/webapps/z-push/config.php
+ sed -i -e "s|\('MAPI_SERVER', \).*$|\1'file:///var/run/zarafad/server.sock'\);|" ${pkgdir}/usr/share/webapps/z-push/backend/kopano/config.php
mkdir -p ${pkgdir}/usr/bin
cp ${srcdir}/z-push-admin ${pkgdir}/usr/bin
@@ -59,6 +65,9 @@ package() {
cp ${srcdir}/nginx-ssl.example.conf ${pkgdir}/etc/webapps/z-push/
cp ${srcdir}/nginx-location.conf ${pkgdir}/etc/webapps/z-push/
cp ${srcdir}/${pkgname}-${pkgver}/config.php ${pkgdir}/etc/webapps/z-push/config.example.php
+ sed -i -e "s|\('BACKEND_PROVIDER', \).*$|\1'BackendKopano'\);|" ${pkgdir}/etc/webapps/z-push/config.example.php
+ sed -i -e "s|\('IPC_PROVIDER', \).*$|\1'IpcMemcachedProvider'\);|" ${pkgdir}/etc/webapps/z-push/config.example.php
+
ln -s /etc/webapps/z-push/config.php ${pkgdir}/usr/share/webapps/z-push/config.php
mkdir -p ${pkgdir}/etc/php/conf.d
diff --git a/install b/install
index 399f8dfb9f3f..6a9087a1e230 100644
--- a/install
+++ b/install
@@ -1,9 +1,23 @@
+#!/bin/bash
+
+# care about existing files
+function installdir() {
+ local owner="$1"
+ local moddir="$2"
+ local modfile="$3"
+ local directory="$4"
+
+ mkdir -p "$directory"
+ find $directory -exec chown "$owner" {} \;
+ find $directory -type f -exec chmod "$modfile" {} \;
+ find $directory -type d -exec chmod "$moddir" {} \;
+}
+
+
post_install() {
cp -n /etc/webapps/z-push/config.example.php /etc/webapps/z-push/config.php
- mkdir -p /var/lib/z-push
-
- chown -R http:http /var/lib/z-push
- chown -R http:http /var/log/z-push
+ installdir http:http 700 600 /var/lib/z-push
+ installdir http:http 700 600 /var/log/z-push
}
diff --git a/z-push.ini b/z-push.ini
index 5ba4bfddff81..d7f024ee4701 100644
--- a/z-push.ini
+++ b/z-push.ini
@@ -5,6 +5,8 @@ extension=shmop.so
extension=soap.so
extension=sysvsem.so
extension=sysvshm.so
+extension=pcntl.so
+extension=memcached.so
; in order to use the utils this system wide is needed
open_basedir=${open_basedir}:/usr/share/webapps/z-push:/etc/webapps/z-push:/var/lib/z-push:/var/log/z-push:/usr/share/php/mapi