summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Moffa2021-08-21 15:38:40 +0200
committerMattia Moffa2021-08-21 15:38:40 +0200
commit4e2bea6f2015d5f0acc35544f91b18226a9a97f2 (patch)
treebd013f4698e2d4d76f72025dd5ac9f50d07e0943
parent443eabd73fff0af6100b94ce428a4d06b9eec975 (diff)
downloadaur-4e2bea6f2015d5f0acc35544f91b18226a9a97f2.tar.gz
Actually fixed icon copying with AUR_BUILD=false
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 1 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48fe48d85613..3c8339081c9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,9 +29,3 @@ pkgname = eclipse-jee
pkgname = eclipse-cpp
pkgname = eclipse-php
-
-pkgname = eclipse-common
- pkgdesc = Highly extensible IDE (common files)
- depends = java-environment>=8
- depends = webkit2gtk
- depends = unzip
diff --git a/PKGBUILD b/PKGBUILD
index c72913c963c3..b214e5763891 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Marco Crosio <marco.crosio@gmail.com>
# Toggle this if you're building outside of the AUR, for a repo.
-AUR_BUILD=false
+AUR_BUILD=true
# Edit to enable/disable packages to build
pkgname=(eclipse-{java,jee,cpp,php})
@@ -134,15 +134,8 @@ Categories=Development;IDE;Java;
StartupNotify=true
END
- if [ "$AUR_BUILD" = false ]; then
- for i in 16 22 24 32 48 64 128 256 512 1024; do
- install -Dm644 eclipse-common/plugins/org.eclipse.platform_*/eclipse$i.png \
- "$pkgdir/usr/share/icons/hicolor/${i}x$i/apps/eclipse.png"
- done
- else
for i in 16 22 24 32 48 64 128 256 512 1024; do
install -Dm644 $1/plugins/org.eclipse.platform_*/eclipse$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x$i/apps/eclipse.png"
done
- fi
}