summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Dvoretsky2017-05-03 21:45:18 +0300
committerEugene Dvoretsky2017-05-03 21:45:18 +0300
commit4e2faa0e436f2b5eee2e79e97b3e6fda829bf361 (patch)
treec5434ceaafa630c6516ac2ddf6b2865ece9536cd
downloadaur-4e2faa0e436f2b5eee2e79e97b3e6fda829bf361.tar.gz
Init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f7b41baf59c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed May 3 18:44:56 UTC 2017
+pkgbase = python2-pylibtiff-git
+ pkgdesc = A python wrapper of the C libtiff library
+ pkgver = r138.33735eb
+ pkgrel = 1
+ url = https://github.com/pearu/pylibtiff
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2-setuptools
+ makedepends = git
+ depends = python2-numpy
+ depends = libtiff
+ provides = python2-libtiff
+ provides = python2-pylibtiff
+ conflicts = python2-libtiff-svn
+ source = python2-pylibtiff::git+https://github.com/pearu/pylibtiff.git
+ sha256sums = SKIP
+
+pkgname = python2-pylibtiff-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..416b4cc30f87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Eugene Dvoretsky <radioxoma at gmail dot com>
+
+pkgname=python2-pylibtiff-git
+pkgver=r138.33735eb
+pkgrel=1
+pkgdesc="A python wrapper of the C libtiff library"
+arch=('i686' 'x86_64')
+url="https://github.com/pearu/pylibtiff"
+license=('BSD')
+depends=('python2-numpy' 'libtiff')
+makedepends=('python2-setuptools' 'git')
+provides=('python2-libtiff' 'python2-pylibtiff')
+conflicts=('python2-libtiff-svn')
+source=("${pkgname%-git}::git+https://github.com/pearu/pylibtiff.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/python2-pylibtiff
+ python2 setup.py build
+
+ # Don't care about "ImportError: No module named tif_lzw"
+ python2 -c "from libtiff import TIFF" || true
+}
+
+package() {
+ cd $srcdir/python2-pylibtiff
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}