summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 23:20:51 +0800
committerSukanka2022-06-06 23:20:51 +0800
commit4e5fa860e951740fac6ed574507936050c69b65a (patch)
tree28ebceef8e1a7768901cc1cc4ca5d3a839083da1
downloadaur-4e5fa860e951740fac6ed574507936050c69b65a.tar.gz
add r-slgi
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ef6891d15c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = r-slgi
+ pkgdesc = Synthetic Lethal Genetic Interaction
+ pkgver = 1.54.0
+ pkgrel = 3
+ url = https://bioconductor.org/packages/SLGI
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-go.db
+ depends = r-scisi
+ optdepends = r-go.db
+ optdepends = r-org.sc.sgd.db
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/SLGI_1.54.0.tar.gz
+ sha256sums = 3a23957fbd9a5f0cee491cbeb6985a611b5550a2868d73dcd03e1332096e5c0e
+
+pkgname = r-slgi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19c4c829e6e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=SLGI
+_pkgver=1.54.0
+pkgname=r-${_pkgname,,}
+pkgver=1.54.0
+pkgrel=3
+pkgdesc='Synthetic Lethal Genetic Interaction'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-biobase
+ r-biocgenerics
+ r-go.db
+ r-scisi
+)
+optdepends=(
+ r-go.db
+ r-org.sc.sgd.db
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3a23957fbd9a5f0cee491cbeb6985a611b5550a2868d73dcd03e1332096e5c0e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: