summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Flemström2015-07-21 17:24:15 +0200
committerDavid Flemström2015-07-21 17:24:15 +0200
commit4e67b732826ac346391a0c29f1351b6570ad5962 (patch)
treef74bacce94b8fed148b80305f376c172b75f982a
parentcd186b6f4fcfdfdbfccd8a364d727568f829826e (diff)
downloadaur-4e67b732826ac346391a0c29f1351b6570ad5962.tar.gz
Set HELIOS_MASTER variable to localhost by default
-rw-r--r--PKGBUILD7
-rwxr-xr-xhelios-env.sh3
2 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a74f95ed668..8c62aec0ea7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,12 @@ depends=('java-runtime' 'zookeeper')
makedepends=('git' 'maven')
source=("$pkgname::git+ssh://git@github.com/spotify/helios.git"
'helios-master.service'
- 'helios-agent.service')
+ 'helios-agent.service'
+ 'helios-env.sh')
md5sums=('SKIP'
'2aeb4f23cf3520abbffa230d50a96ce6'
- 'a0f0cd98b3b3888aba00ff8436e22506')
+ 'a0f0cd98b3b3888aba00ff8436e22506'
+ '584cdaa52f45e71d6d4dfc6c6c11e02a')
pkgver() {
cd "$pkgname"
@@ -29,6 +31,7 @@ package() {
install -dm755 "$pkgdir/var/lib/helios-master"
install -dm755 "$pkgdir/var/lib/helios-agent"
+ install -Dm755 helios-env.sh -t "$pkgdir/etc/profile.d/helios-env.sh"
install -Dm644 helios-master.service -t "$pkgdir/usr/lib/systemd/system"
install -Dm644 helios-agent.service -t "$pkgdir/usr/lib/systemd/system"
diff --git a/helios-env.sh b/helios-env.sh
new file mode 100755
index 000000000000..9a7558f11dfa
--- /dev/null
+++ b/helios-env.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+export HELIOS_MASTER=http://localhost:5801