summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreggz@eieren2023-05-05 14:05:29 +0200
committereggz@eieren2023-05-05 14:05:29 +0200
commit4e6ff8f5b9c46e4d626c386441a1023b094be590 (patch)
treec4c913d0b4d6f7372fcf3dd4768e8c72ea16a229
parent13eb7b54fe66af9190b71e66a2a4f960616958e7 (diff)
downloadaur-4e6ff8f5b9c46e4d626c386441a1023b094be590.tar.gz
make sure users have pip for new build method
Signed-off-by: eggz@eieren <eggz@eieren.local>
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a78f633369f..f823a767fcbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = graphite-web
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = python-pip
depends = python-pytz
depends = python-six
depends = python-flask
diff --git a/PKGBUILD b/PKGBUILD
index aa4fb419d46b..64522761bd3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ license=('Apache')
depends=('python-pytz' 'python-six' 'python-flask' 'python-structlog'
'python-yaml' 'python-tzlocal' 'python-cairocffi' 'python-pyparsing'
'python-django' 'python3-django-tagging')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-pip')
optdepends=('python-flask-cache: For caching'
'python-raven: For sentry support')
arch=('any')
@@ -71,7 +71,7 @@ package() {
pip install --no-deps --root="$pkgdir" dist/*.whl
#Fix dir structure
- mkdir -p $pkgdir/opt/graphite/
+ mkdir -p $pkgdir/opt/graphite/
mv $pkgdir/usr/* $pkgdir/opt/graphite/
mkdir -p $pkgdir/opt/graphite/webapp/graphite/
mv $pkgdir/opt/graphite/lib/python3.11/site-packages/graphite/* $pkgdir/opt/graphite/webapp/graphite/