summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-05 17:37:18 -0700
committerMark Wagie2024-01-05 17:37:18 -0700
commit4ea3e10e7037743fe9e72e1decfc1956ed72af53 (patch)
tree4136260991f7779ba8940bc49b3b5648d1868ebb
parent8e1ec904ed0e9f60acec44f772121d3e5e569d93 (diff)
downloadaur-4ea3e10e7037743fe9e72e1decfc1956ed72af53.tar.gz
3.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed567a2348a4..14f3d7d3733d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-userspacefs
pkgdesc = Cross-platform user-space file systems for Python
- pkgver = 2.0.6
+ pkgver = 3.0.0
pkgrel = 1
url = https://thelig.ht/code/userspacefs
arch = any
@@ -9,10 +9,11 @@ pkgbase = python-userspacefs
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- depends = python
+ depends = python-aiohttp
+ depends = python-typing_extensions
conflicts = python-fusepyng
replaces = python-fusepyng
- source = https://files.pythonhosted.org/packages/source/u/userspacefs/userspacefs-2.0.6.tar.gz
- sha256sums = 5a8f4d6d4c84d01eef6df9d0b1c0c632404dea94a1c3f6d1e1c173c79c2e4d49
+ source = https://files.pythonhosted.org/packages/source/u/userspacefs/userspacefs-3.0.0.tar.gz
+ sha256sums = 7d10855c478fe059ee093f98c33797f69afe4239b6391285dfa89412503ea1c8
pkgname = python-userspacefs
diff --git a/PKGBUILD b/PKGBUILD
index 65382d878a6e..1dad74598074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=python-userspacefs
_name=${pkgname#python-}
-pkgver=2.0.6
+pkgver=3.0.0
pkgrel=1
pkgdesc="Cross-platform user-space file systems for Python"
arch=('any')
url="https://thelig.ht/code/userspacefs"
license=('GPL3')
-depends=('python')
+depends=('python-aiohttp' 'python-typing_extensions')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
conflicts=('python-fusepyng')
replaces=('python-fusepyng')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('5a8f4d6d4c84d01eef6df9d0b1c0c632404dea94a1c3f6d1e1c173c79c2e4d49')
+sha256sums=('7d10855c478fe059ee093f98c33797f69afe4239b6391285dfa89412503ea1c8')
build() {
cd "$_name-$pkgver"