summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2020-06-23 01:14:48 -0300
committerTércio Martins2020-06-23 01:14:48 -0300
commit4ed73cbaeb1b87771d419b208d4270967325913c (patch)
tree581cd5d08ba8a193933d63394eb9eabee0ebc7b9
parentbf0ef5d6007cc0d4746cc75c051f2433c8d0fd15 (diff)
downloadaur-4ed73cbaeb1b87771d419b208d4270967325913c.tar.gz
Update to version 2.3.15
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
2 files changed, 15 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3af80b8869ea..96557c52f117 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openfx-misc
pkgdesc = Miscellaneous OpenFX plugins
- pkgver = 2.3.15_rc20
+ pkgver = 2.3.15
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-misc
arch = i686
@@ -9,13 +9,9 @@ pkgbase = openfx-misc
license = GPL
makedepends = openmp
depends = libgl
- optdepends = natron-plugins: More presets for the Shadertoy plugin
- source = openfx-misc_13fd908.tar.gz::https://github.com/NatronGitHub/openfx-misc/tarball/13fd908
- source = openfx_db5aa97.tar.gz::https://github.com/NatronGitHub/openfx/tarball/db5aa97
- source = openfx-supportext_53c12bd.tar.gz::https://github.com/NatronGitHub/openfx-supportext/tarball/53c12bd
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ optdepends = natron-plugins-git: More presets for the Shadertoy plugin
+ source = openfx-misc-Natron-2.3.15.tar.xz::https://github.com/NatronGitHub/openfx-misc/releases/download/Natron-2.3.15/openfx-misc-Natron-2.3.15.tar.xz
+ sha512sums = 614b12da180ceb4df2ea3a309b434d52eaa4ea6d2bf79ababb00b4b53c637b21c5b96f88ea7e74a2f05a0ef6df4ec1d32484f2c83ee390a193638379c5b868bf
pkgname = openfx-misc
diff --git a/PKGBUILD b/PKGBUILD
index 9d6b14f8f88e..0b97c47853de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,46 +2,29 @@
# Contributor: Hugo Courtial <hugo [at] courtial [not colon] me>
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
-_openfx_misc_commit=13fd908
-_openfx_commit=db5aa97
-_openfx_supportext_commit=53c12bd
-
pkgname=openfx-misc
-pkgver=2.3.15_rc20
+pkgver=2.3.15
+_pkgname="${pkgname}-Natron-${pkgver}"
pkgrel=1
arch=('i686' 'pentium4' 'x86_64')
pkgdesc="Miscellaneous OpenFX plugins"
url="https://github.com/NatronGitHub/openfx-misc"
license=('GPL')
-makedepends=('openmp')
depends=('libgl')
-optdepends=('natron-plugins: More presets for the Shadertoy plugin')
-source=("openfx-misc_$_openfx_misc_commit.tar.gz::https://github.com/NatronGitHub/openfx-misc/tarball/$_openfx_misc_commit"
- "openfx_$_openfx_commit.tar.gz::https://github.com/NatronGitHub/openfx/tarball/$_openfx_commit"
- "openfx-supportext_$_openfx_supportext_commit.tar.gz::https://github.com/NatronGitHub/openfx-supportext/tarball/$_openfx_supportext_commit")
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP')
-
-_pkgname="NatronGitHub-$pkgname-$_openfx_misc_commit"
-
-prepare() {
- tar -xzf "$srcdir/openfx_$_openfx_commit.tar.gz" --strip 1 \
- -C "$srcdir/$_pkgname/openfx/"
- tar -xzf "$srcdir/openfx-supportext_$_openfx_supportext_commit.tar.gz" --strip 1 \
- -C "$srcdir/$_pkgname/SupportExt/"
-}
+makedepends=('openmp')
+optdepends=('natron-plugins-git: More presets for the Shadertoy plugin')
+source=("${_pkgname}.tar.xz::${url}/releases/download/Natron-${pkgver}/${_pkgname}.tar.xz")
+sha512sums=('614b12da180ceb4df2ea3a309b434d52eaa4ea6d2bf79ababb00b4b53c637b21c5b96f88ea7e74a2f05a0ef6df4ec1d32484f2c83ee390a193638379c5b868bf')
build() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
make CONFIG=release \
- CXXFLAGS_ADD=-fopenmp \
- LDFLAGS_ADD=-fopenmp
+ OPENMP=1
}
package() {
- cd "$srcdir/$_pkgname"
- mkdir -p "$pkgdir/usr/OFX/Plugins"
- make install PLUGINPATH=$pkgdir/usr/OFX/Plugins \
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/OFX/Plugins"
+ make install PLUGINPATH="${pkgdir}/usr/OFX/Plugins" \
CONFIG=release
}