summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2019-07-04 20:14:49 +0800
committerLin UX2019-07-04 20:14:49 +0800
commit4ef24e749b1f24367a35bad7c4e1674aeb45145b (patch)
tree5b3622a40ffbd93ff3444df8925f79d108df705d
parent041f94e0522c188ea3a56fb483bd2b5a22c30682 (diff)
downloadaur-4ef24e749b1f24367a35bad7c4e1674aeb45145b.tar.gz
upgrade
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD9
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b094a8ea50..2a0646315fba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vim-python-mode
pkgdesc = A vim plugin that make vim into python IDE
- pkgver = 0.9.2
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/python-mode/python-mode
arch = any
@@ -8,19 +8,18 @@ pkgbase = vim-python-mode
license = LGPL3
depends = vim
depends = python
- optdepends = python-astroid
- optdepends = autopep8
- optdepends = python-mccabe
- optdepends = python-pycodestyle
- optdepends = python-pydocstyle
- optdepends = python-pyflakes
- optdepends = pylama
- optdepends = python-pylint
- optdepends = python-rope
- optdepends = python-six
- optdepends = python-snowballstemmer
- source = https://github.com/python-mode/python-mode/archive/0.9.2.tar.gz
- sha256sums = 1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd
+ depends = python-astroid
+ depends = autopep8
+ depends = python-mccabe
+ depends = python-pycodestyle
+ depends = python-pydocstyle
+ depends = python-pyflakes
+ depends = python-pylint
+ depends = python-rope
+ depends = python-six
+ depends = python-snowballstemmer
+ source = https://github.com/python-mode/python-mode/archive/0.10.0.tar.gz
+ sha256sums = 6197e6f2ab190e58a68f01ed784155f2273af31633fd49bb459e8fa498e834cd
pkgname = vim-python-mode
diff --git a/PKGBUILD b/PKGBUILD
index d413065530fc..54ce6e8521ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,18 @@
pkgname=vim-python-mode
_pkgname=python-mode
-pkgver=0.9.2
+pkgver=0.10.0
pkgrel=1
pkgdesc='A vim plugin that make vim into python IDE'
arch=('any')
license=('LGPL3')
url='https://github.com/python-mode/python-mode'
-depends=('vim' 'python')
-optdepends=('python-astroid' 'autopep8' 'python-mccabe' 'python-pycodestyle' 'python-pydocstyle' 'python-pyflakes' 'pylama' 'python-pylint' 'python-rope' 'python-six' 'python-snowballstemmer')
+depends=('vim' 'python' 'python-astroid' 'autopep8' 'python-mccabe' 'python-pycodestyle' 'python-pydocstyle' 'python-pyflakes' 'python-pylint' 'python-rope' 'python-six' 'python-snowballstemmer')
+#pylama' '
groups=('vim-plugins')
source=("https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=(1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd)
+sha256sums=('6197e6f2ab190e58a68f01ed784155f2273af31633fd49bb459e8fa498e834cd')
+
package() {
cd "${_pkgname}-${pkgver}"