summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2022-08-01 18:39:18 +1000
committerJP-Ellis2022-08-01 18:39:18 +1000
commit4f002bf1ebb2350b6d4312fbe8107d977b3114f9 (patch)
tree68ae0f28ab84d177b58fa409c70560c73811cbf1
parent02752fd8c4fa4b51d167f7621c0a51a0ffef2a0c (diff)
downloadaur-4f002bf1ebb2350b6d4312fbe8107d977b3114f9.tar.gz
v0.12
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch73
-rw-r--r--isbnlib-3.10-fix.patch23
4 files changed, 7 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95d04839321f..ffe498a0b99a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = papis
pkgdesc = Papis is a powerful and highly extensible command-line based document and bibliography manager.
- pkgver = 0.11.1
+ pkgver = 0.12
pkgrel = 1
url = https://github.com/papis/papis
arch = any
@@ -27,10 +27,7 @@ pkgbase = papis
depends = python-lxml
depends = python-slugify
optdepends = papis-rofi: integration with rofi
- source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.11.1.tar.gz
- source = isbnlib-3.10-fix.patch
- sha256sums = e54739a1771ba4da4afe30b0b52dfc220543926765f975d14e8ddce508f4fdf9
- sha256sums = 3f79cc4c5deb31cd56590b2c17e3d7a22fefd18e03580139ad665154b814fa10
+ source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.12.tar.gz
+ sha256sums = 9005ff51ec27c2ebf542c9c6f2a987e77060c53dce12a57de8ce39afb3deb483
pkgname = papis
-
diff --git a/PKGBUILD b/PKGBUILD
index fdf0561f54f4..b2649fd9482d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=papis
-pkgver=0.11.1
+pkgver=0.12
pkgrel=1
pkgdesc="Papis is a powerful and highly extensible command-line based document and bibliography manager."
arch=('any')
@@ -10,6 +10,7 @@ depends=('python'
'python-requests'
'python-filetype'
'python-pyparsing'
+ # 'python-configparser' This dependency from setup.py is part of the standard library in Python 3.10
'python-arxiv2bib'
'python-pyaml'
'python-chardet'
@@ -29,15 +30,12 @@ depends=('python'
'python-slugify'
)
optdepends=('papis-rofi: integration with rofi')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "isbnlib-3.10-fix.patch")
-sha256sums=('e54739a1771ba4da4afe30b0b52dfc220543926765f975d14e8ddce508f4fdf9'
- '3f79cc4c5deb31cd56590b2c17e3d7a22fefd18e03580139ad665154b814fa10')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('9005ff51ec27c2ebf542c9c6f2a987e77060c53dce12a57de8ce39afb3deb483')
noextract=()
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p 1 < "${srcdir}/isbnlib-3.10-fix.patch"
}
build() {
diff --git a/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch b/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch
deleted file mode 100644
index cedf1ed35734..000000000000
--- a/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From b8ce11c08dc32051545e73e858f0cd044ac12ef2 Mon Sep 17 00:00:00 2001
-From: Alexandru Fikl <alexfikl@gmail.com>
-Date: Sun, 3 May 2020 10:51:49 -0500
-Subject: [PATCH] add compatibility with isbnlib >= 3.10
-
----
- papis/isbn.py | 21 ++++++++++++---------
- setup.py | 2 +-
- 2 files changed, 13 insertions(+), 10 deletions(-)
-
-diff --git a/papis/isbn.py b/papis/isbn.py
-index fe137cd3..0bbfbd52 100644
---- a/papis/isbn.py
-+++ b/papis/isbn.py
-@@ -1,6 +1,7 @@
- import papis.document
- import logging
- import isbnlib
-+import isbnlib.registry
- import click
- # See https://github.com/xlcnd/isbnlib for details
- from typing import Optional, Dict, Any, List
-@@ -11,18 +12,20 @@
- def get_data(
- query: str = "",
- service: Optional[str] = None) -> List[Dict[str, Any]]:
-- global logger
-- results = [] # type: List[Dict[str, Any]]
-+ isbnlib_version = tuple(int(n) for n in isbnlib.__version__.split('.'))
-+ if service is None and isbnlib_version >= (3, 10, 0):
-+ service = "default"
-+
- logger.debug('Trying to retrieve isbn')
- isbn = isbnlib.isbn_from_words(query)
- data = isbnlib.meta(isbn, service=service)
-- if data is None:
-- return results
-- else:
-- logger.debug('Trying to retrieve isbn')
-- assert(isinstance(data, dict))
-+
-+ results = [] # type: List[Dict[str, Any]]
-+ if data is not None:
-+ assert isinstance(data, dict)
- results.append(data_to_papis(data))
-- return results
-+
-+ return results
-
-
- def data_to_papis(data: Dict[str, Any]) -> Dict[str, Any]:
-@@ -45,7 +48,7 @@ def data_to_papis(data: Dict[str, Any]) -> Dict[str, Any]:
- '--service',
- '-s',
- default='goob',
-- type=click.Choice(['wcat', 'goob', 'openl'])
-+ type=click.Choice(list(isbnlib.registry.services.keys()))
- )
- def explorer(ctx: click.core.Context, query: str, service: str) -> None:
- """
-diff --git a/setup.py b/setup.py
-index 65fc183c..dd136e71 100644
---- a/setup.py
-+++ b/setup.py
-@@ -65,7 +65,7 @@
- "bibtexparser>=0.6.2",
- "click>=7.0.0",
- "habanero>=0.6.0",
-- "isbnlib>=3.9.1,<3.10",
-+ "isbnlib>=3.9.1",
- "prompt_toolkit>=2.0.5",
- "tqdm>=4.1",
- "pygments>=2.2.0",
diff --git a/isbnlib-3.10-fix.patch b/isbnlib-3.10-fix.patch
deleted file mode 100644
index 8b4ca82b6774..000000000000
--- a/isbnlib-3.10-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From da807047045bcc8371d3775a8533f3575ccb18f3 Mon Sep 17 00:00:00 2001
-From: Alejandro Gallo <aamsgallo@gmail.com>
-Date: Sat, 16 Jan 2021 12:23:30 +0100
-Subject: [PATCH] Remove isbnlib's restriction on the version
-
-Related to issue #242
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index de7958b1..a76e2b74 100644
---- a/setup.py
-+++ b/setup.py
-@@ -65,7 +65,7 @@
- "bibtexparser>=0.6.2",
- "click>=7.0.0",
- "habanero>=0.6.0",
-- "isbnlib>=3.9.1,<3.10",
-+ "isbnlib>=3.9.1",
- "prompt_toolkit>=2.0.5",
- "tqdm>=4.1",
- "pygments>=2.2.0",