summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2021-09-30 15:02:40 +0300
committerYigit Sever2021-09-30 15:02:40 +0300
commit4f382359b7f186a64d591140cf019a002e3dd29b (patch)
tree90de4c4d7cbeb81c69760c28c23b2dc475dfae99
parentdd2728c558612c70ef403df886a4440507057da1 (diff)
downloadaur-4f382359b7f186a64d591140cf019a002e3dd29b.tar.gz
Update to v1.2.6
- Set the upstream url to the new (maintained) fork - Remove the pid patch as it's no longer needed
-rw-r--r--.SRCINFO15
-rw-r--r--100-pidfile.patch11
-rw-r--r--PKGBUILD30
3 files changed, 19 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443ff968666e..ff90fb336492 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = htpdate
pkgdesc = A client for time synchronisation
- pkgver = 1.2.2
- pkgrel = 3
- url = http://www.vervest.org/htp/
+ pkgver = 1.2.6
+ pkgrel = 1
+ url = https://github.com/angeloc/htpdate
arch = i686
arch = x86_64
license = GPL2
depends = glibc
- source = http://www.vervest.org/htp/archive/c/htpdate-1.2.2.tar.xz
+ source = htpdate-1.2.6.tar.gz::https://github.com/angeloc/htpdate/archive/v1.2.6.tar.gz
source = htpdate.service
- source = 100-pidfile.patch
- md5sums = aad8c33933648532ac8716c809b15be1
- md5sums = d00fce722a88150cffb1b322e6cc8869
- md5sums = f4612bb44274ed571117724a49abb3c1
+ sha256sums = d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909
+ sha256sums = 2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b
pkgname = htpdate
-
diff --git a/100-pidfile.patch b/100-pidfile.patch
deleted file mode 100644
index a56aba4ed823..000000000000
--- a/100-pidfile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- htpdate.c 2019-07-12 19:10:17.000000000 +0200
-+++ htpdate.c.patched 2020-05-06 13:15:51.419075086 +0200
-@@ -499,7 +499,7 @@
- printlog( 1, "Error writing pid file" );
- exit(1);
- } else {
-- fprintf( pid_file, "%u\n", (unsigned short)pid );
-+ fprintf( pid_file, "%d\n", (signed int)pid );
- fclose( pid_file );
- }
- printlog( 0, "htpdate version "VERSION" started" );
diff --git a/PKGBUILD b/PKGBUILD
index ad8a2bc926af..9e2d27580065 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,28 @@
-# Maintainer: Dominik Schrempf <dominik.schrempf at gmail dot com>
+# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+# Contributor: Dominik Schrempf <dominik.schrempf at gmail dot com>
# Contributor: Jonathan Ryan <jryan at curious-computing dot com>
# Contributor: Hussam Al-Tayeb <hussam at visp dot net dot lb>
pkgname=htpdate
-pkgver=1.2.2
-pkgrel=3
+pkgver=1.2.6
+pkgrel=1
pkgdesc="A client for time synchronisation"
-arch=(i686 x86_64)
-url="http://www.vervest.org/htp/"
+arch=('i686' 'x86_64')
+url="https://github.com/angeloc/htpdate"
license=(GPL2)
depends=('glibc')
-# TODO: In the process of adding two patches from OpenWRT, but they are rejected.
-# See https://aur.archlinux.org/packages/htpdate/.
-source=("http://www.vervest.org/htp/archive/c/${pkgname}-${pkgver}.tar.xz"
- "htpdate.service"
- "100-pidfile.patch")
-md5sums=('aad8c33933648532ac8716c809b15be1'
- 'd00fce722a88150cffb1b322e6cc8869'
- 'f4612bb44274ed571117724a49abb3c1')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "htpdate.service")
+sha256sums=('d2cff522b8f53b00769dcca77d8025b19238ed35d702a4739dc05e387f718909'
+ '2f12bdf0745fbf7c52f465e78b47635fbdc6fa372e63fb94a6063a5f67ff8c8b')
build() {
cd ${pkgname}-${pkgver}
- patch htpdate.c ../100-pidfile.patch
make
}
package() {
- install -D -m 644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
+ install -D -m644 htpdate.service ${pkgdir}/usr/lib/systemd/system/htpdate.service
cd ${pkgname}-${pkgver}
- install -D -m 755 htpdate ${pkgdir}/usr/bin/htpdate
- install -D -m 644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
+ install -D -m755 htpdate ${pkgdir}/usr/bin/htpdate
+ install -D -m644 htpdate.8 ${pkgdir}/usr/share/man/man8/htpdate.8
}